CorelDRAW 10

1. Компьютерная графика 1.1 Растровые рисунки
1.2 Векторные рисунки
1.3 Цветные изображения 2. Знакомство с CorelDRAW 10 2.1 Новое в десятой версии
2.2 Понятие объекта в CorelDRAW
2.3 Основные принципы работы в CorelDRAW 10
2.4 Элементы рабочего окна редактора 3. Создание векторных объектов 3.1 Создание простых фигур
3.2 Рисование линий
3.3 Основы работы с текстом 4. Редактирование изображений 4.1 Выделение объектов
4.2 Изменение масштаба просмотра изображений
4.3 Отмена и возврат последних действий
4.4 Перемещение, копирование и удаление объектов
4.5 Использование сетки, направляющих и измерительных линеек
4.6 Привязка объектов
4.7 Блокирование объектов
4.8 Цвет контура и заливки объекта 5. Работа с несколькими объектами 5.1 Изменение взаимного
5.2 Объединение объектов в группы
5.3 Наложение объектов друг на друга
5.4 Соединение объектов
5.5 Формирование объектов из нескольких других 6. Повседневная работа с CorelDRAW 10 6.1 Сохранение документа на диске и его загрузка в CorelDRAW 10
6.2 Печать созданных изображений
6.3 Использование шаблонов 7. Изменение формы обьектов 7.1 Трансформация обьектов
7.2 Изменение формы стандартных обьектов
7.3 Редактирование автофигур 8. Редактирование контура и заливки 8.1 Толщина контура, стиль линий и различные типы стрелок
8.2 Однородная заливка
8.3 Градиентная заливка
8.4 Заливка с помощью узоров
8.5 Заливка текстурой
8.6 Дополнительные возможности заливки 9. Интерактивная заливка 9.1 Основные инструмены интерактивной заливки
9.2 Использование ранее созданных заливок
9.3 Настройка заливки объктов
9.4 Сетчатая заливка 10. Вставка готовых рисунков 10.1 Использование библиотеки графических символов
10.2 Работа с заголовками
10.3 Импорт и экспорт рисунков
10.4 Получение изображений со сканера и цифровой камеры 11. Профессиональная работа с текстом 11.1 Форматирование и редактирование текста
11.2 Размещение текста вдоль кривой
11.3 Изменение расположения символов текста 12. Создание рисунков для ИНТЕРНЕТ 12.1 Вставка обьектов ИНТЕРНЕТА
12.2 Создание анимированных кнопок
12.3 Публикация документов в ИНТЕРНЕТЕ 13. Создание электронной документации 13.1 Особенности работы с многостраничными документами
13.2 Публикация в формате PDF 14. Повышенные удобства работы 14.1 Контекстное меню и копирование свойств объектов
14.2 Информация о документе CorelDRAW 10
14.3 Использование скриптов
14.4 Дополнительные возможности работы с объектом
14.5 Некоторые полезные закркпления
14.6 Поиск и замена графических объектов
14.7 Использование различных режимов просмитра документа
14.8 Полезные настройки редактора 15. Применение эффектов 15.1 Перетекание объекта в другой и эффект подобия
15.2 Интерактивное искажение, применение оболочек и
перспективы
15.3 Объемные объекты
15.4 Фигурная обрезка
15.5 Линзы
15.6 Интерактивная прозрачность
15.7 Создание теней объектов
15.8 Художественная обводка 16. Работа с растровыми изображениями 16.1 Преобразование в растровую графику
16.2 Трассировка растровых изображений
16.3 Редактирование растровых рисунков
16.4 Использование цветных масок
16.5 Дополнительные средства изменения растровых объектов 17. Эффекты для растровых изображений 17.1 Коррекция цвета
17.2 Трансформация растровых объектов 18. Художественные эффекты растровой графики 18.1 Трехмерные преобразования
18.2 Имитация живописи
18.3 Использование размытых рисунков
18.4 Художественное преобразование цвета
18.5 Обработка контуров
18.6 Оригинальные эффекты
18.7 Искажения рисунков
18.8 Добавление и удаление шумов


V N S . R U : CorelDRAW 10 [ Справочное руководство на русском языке ]

I. Основы работы в CorelDRAW 10

Графический редактор CorelDRAW 10 предназначен для работы с векторной графикой и является несомненным лидером среди аналогичных программ. Популярность CorelDRAW объясняется большим набором средств создания и редактирования графических образов, удобным интерфейсом и высоким качеством получаемых изображений. Особенно удобен CorelDRAW 10 при создании иллюстраций, состоящих их множества рисунков, фотографий и надписей. Расположить в нужных местах компоненты изображения с помощью CorelDRAW 10 чрезвычайно просто. В пакет программ CorelDRAW 10 кроме собственно редактора векторной графики входит редактор растровой графики Corel Photo-Paint. Интерфейс обеих программ очень похож, а по возможностям они дополняют друг друга. Используя две эти программы, вы сможете выполнить практически любую, самую сложную, графическую работу. Новая программа, входящая в состав пакета CorelDRAW 10, называемая Corel R.A.V.E., предназначена для создания анимации. Теперь вы можете создавать мультфильмы на основе векторной графики. Программа Corel R.A.V.E. позволяет экспортировать результат в разнообразные популярные форматы, в том числе в формат Macromedia Flash. Также в стандартную поставку CorelDRAW 10 входит множество готовых картинок, которые вы можете использовать при создании собственных иллюстраций.
1.Компьютерная графика

Перед началом работы с CorelDRAW 10 вы должны иметь представление о способах представления графической информации в компьютере. Если вы знаете о растровой .и векторной графике, а также о моделях представления цвета, то можете пропустить эту часть книги. Если же вы не знакомы с этими понятиями, прочитайте предлагаемый материал. Он поможет вам быстрее освоить CorelDRAW 10.

1.1. Растровые рисунки Чтобы компьютер смог обрабатывать рисунки, они должны быть представлены в числовой форме, или, как принято говорить, закодированы. Для кодирования рисунок разбивают на небольшие одноцветные части. Все цвета, использованные в изображении, нумеруют, и для каждой части записывают номер ее цвета. Запомнив последовательность расположения частей и номер цвета для каждой части, можно однозначно описать любой рисунок. Однако, количество цветов в природе бесконечно, и приходится похожие цвета нумеровать одинаковыми числами. В зависимости от количества используемых цветов, можно закодировать более или менее реалистичное изображение. Понятно, что, чем меньше цветов в рисунке, тем меньше номеров приходится использовать, и тем проще закодировать изображение. В самом простом случае используется только черный и белый цвет. Рисунки, закодированные описанным способом, называются растровыми изображениями, растрами или битмапами, от английского слова bitmap - карта бит. Части, на которые разбиваются изображения, называют пикселями (PICture ELement - элемент рисунка). Пиксели часто называют точками. Рисунок из множества пикселей можно сравнить с мозаикой. Из большого количества разноцветных камешков собирается произвольная картина (Рис. 1.1).

Рис. 1.1. Увеличенное растровое изображение
Если для представления каждого пикселя в черно-белом рисунке достаточно одного бита, то для работы с цветом этого явно недостаточно. Однако подход при кодировании цветных изображений остается неизменным. Любой рисунок разбивается на пиксели, то есть небольшие части, каждая из которых имеет свой цвет. Объем информации, описывающий цвет пикселя, определяет глубину цвета. Чем больше информации определяет цвет каждой точки в рисунке, тем больше вариантов цвета существует. Не определив размер пикселя, невозможно построить изображение на основе закодированных данных. Если же мы зададим размер, то без проблем восстановим закодированный рисунок. Однако на практике не используют размер пикселей, а задают две другие величины: размер рисунка и его разрешение. Размер описывает физические габариты изображения, то есть его высоту и ширину. Можно задать размеры в метрах, миллиметрах, дюймах или любых других величинах. Но в компьютере чаще всего размер задается в пикселях. При отображении на мониторе и печати на принтере каждый пиксель представляется отдельной точкой, если оборудование не делает специальных преобразований. На старых мониторах, с крупным зерном кинескопа, рисунок получится большим, а на современном принтере, в котором используются мельчайшие точки, рисунок получится очень маленьким. А каким он должен быть на самом деле? Для этого задается разрешение изображения. Разрешение - это плотность размещения пикселей, формирующих изображение, то есть количество пикселей на заданном отрезке. Чаще всего разрешение измеряется в количестве точек на дюйм - dpi (Dot Per Inch). При отображении рисунков на мониторе, используют разрешение от 72 dpi до 120 dpi. При печати самым распространенным разрешением является 300 dpi, но для получения высококачественных отпечатков на современных цветных принтерах можно использовать и большее разрешение.

Растровые изображения достаточно широко используются в вычислительной технике. Фотографии и рисунки, введенные в компьютер, хранятся именно в виде растровых изображений. Большинство рисунков во всемирной компьютерной сети Интернет представляют собой растровые файлы. Имеется множество программ, предназначенных для работы с растровыми рисунками. Растровые изображения обладают одним очень существенным недостатком: их трудно увеличивать или уменьшать, то есть масштабировать. При уменьшении растрового изображения несколько соседних точек преобразуются в одну, поэтому теряется разборчивость мелких деталей изображения. При увеличении - увеличивается размер каждой точки, поэтому появляется ступенчатый эффект. Кроме того, растровые изображения занимают много места в памяти и на диске. Чтобы избежать указанных проблем, изобрели, так называемый, векторный способ кодирования изображений.
<< назад содержание вперед >>


1.2 Векторные рисунки

В векторном способе кодирования геометрические фигуры, кривые и прямые линии, составляющие рисунок, хранятся в памяти компьютера в виде математических формул и геометрических абстракций, таких как круг, квадрат, эллипс и подобных фигур. Например,, чтобы закодировать круг, не надо разбивать его на отдельные пиксели, а следует запомнить его радиус, координаты центра и цвет. Для прямоугольника достаточно знать размер сторон, место, где он находится и цвет закраски. С помощью математических формул можно описать самые разные фигуры. Чтобы нарисовать более сложный рисунок, применяют несколько простых фигур. Например, взяв прямоугольник с закругленными краями и закрасив его в черный цвет, добавив три белых прямоугольника и еще один черный, также с закругленными краями, мы можем получить рисунок трехдюймовой дискеты (Рис. 1.2).

Рис. 1.2. Векторный рисунок из составных частей

Любое изображение в векторном формате состоит из множества составляющих частей, которые можно редактировать независимо друг от друга. Эти части называются объектами. С помощью комбинации нескольких объектов, можно создавать новый объект, поэтому объекты могут иметь достаточно сложный вид. Для каждого объекта, его размеры, кривизна и местоположение хранятся в виде числовых коэффициентов. Благодаря этому появляется возможность масштабировать изображения с помощью простых математических операции, в частности, простым умножением параметров графических элементов на коэффициент масштабирования. При этом качество изображения остается без изменений. Используя векторную графику, можно не задумываться о том, готовите ли вы миниатюрную эмблему или рисуете двухметровый транспарант. Вы работаете над рисунком совершенно одинаково в обоих случаях. В любой момент вы можете преобразовать изображение в любой размер без потерь качества. Важным преимуществом векторного способа кодирования изображений является то, что размеры графических файлов векторной графики имеют значительно меньший размер, чем файлы растровой графики. Однако есть и недостатки работы с векторной графикой. Прежде всего, некоторая условность получаемых изображений. Так как все рисунки состоят из кривых, описанных формулами, трудно получить реалистичное изображение. Для этого понадобилось бы слишком много элементов, поэтому рисунки векторной графики не могут использоваться для кодирования фотографий. Если попытаться описать фотографию, размер полученного файла окажется больше, чем соответствующего файла растровой графики.
<< назад содержание вперед >>


1.3. Цветные изображения

Как уже отмечалось, каждый пиксель растрового изображения содержит информацию о цвете. Любой векторный объект также содержит информацию о цвете его контура и закрашенной области. Информация может занимать от одного до тридцати двух бит, в зависимости от глубины цвета. Если мы работаем с черно-белыми изображениями, то цвет кодируется нулем или единицей. Никаких проблем в этом случае не возникает. Для несложных рисунков, содержащих 256 цветов или столько же градаций серого цвета, нетрудно пронумеровать все используемые цвета. Но, для изображений в истинном цвете, содержащих миллионы разных оттенков, простая нумерация не подходит. Для них разработаны несколько моделей представления цвета, помогающих однозначно определить любой оттенок. Цветовая модель определяет способ создания цветов, используемых в изображении. Всего разработано три основных цветовых модели и множество их модификаций. Коротко рассмотрим основные модели представления цвета. Из школьного курса физики мы знаем, что солнечный свет можно разложить на отдельные цветные составляющие. В то же время, собрав вместе в нужных пропорциях разноцветные лучи, мы получим луч белого цвета. Изменим немного пропорции - и у нас готов источник света заданного цвета. В телевизорах и компьютерных мониторах используется люминофор, который светится красным, зеленым и синим цветом. Смешивая эти три цвета можно получить разнообразные цвета и их оттенки. На этом и основана модель представления цвета RGB, названная так по начальным буквам входящих в нее цветов: Red - красный, Green - зеленый, Blue - синий. Любой цвет в этой модели представляется тремя числами, описывающими величину каждой цветовой составляющей. Черный цвет образуется, когда интенсивность всех трех составляющих равна нулю, а белый - когда их интенсивность максимальна. Множество компьютерного оборудования работает с использованием модели RGB, кроме того, эта модель очень проста. Этим объясняется ее широкое распространение. К сожалению, в модели RGB теоретически невозможно получить некоторые цвета, например насыщенный сине-зеленый, поэтому работать с моделью цвета RGB не всегда удобно. Кроме того, модель RGB сильно связана с реализацией ее на конкретных устройствах. Большинство цветов, которые мы видим в окружающем нас мире, являются следствием отражения и поглощения света. Например, солнечный свет, палая на зеленую траву, частично поглощается, и отражается только его зеленая составляющая. При печати на принтере, на бумагу наносится цветная краска, которая отражает только свет определенного цвета. Все остальные цвета поглощаются, или вычитаются из солнечного света. На эффекте вычитания цветов построена другая модель представления цвета, называемая CMYK. Эти буквы также взяты из названий цветов: Cyan - голубой, Magenta - пурпурный, Yellow - желтый, black - - черный. Строго говоря, Magenta не является пурпурным цветом. Точное название этого цвета -фуксин, но в компьютерной литературе и в программах принято называть этот цвет пурпурным. В разновидности этой модели, называемой CMY, отсутствует черный цвет, но она применяется значительно реже. Выбор цветов для модели неслучаен, они тесно связаны с цветами модели RGB. Голубой цвет образуется при поглощении красного, пурпурный при поглощении зеленого, а желтый отраженный цвет получается в результате поглощения синего. При нанесении большего количества красок разных цветов поглощается больше цвета и меньше отражается. Таким образом, при смешении максимальных значений этих трех цветов мы должны получить черный цвет, а при полном отсутствии краски должен получиться белый цвет. Однако в действительности при смешении трех красок получается грязно-бурый цвет, так как используемые реальные красители отражают и поглощают цвет не так, как описано в теории. Черный цвет получается только при добавлении черной краски, поэтому в модель CMYK и добавлена черная составляющая. Система CMYK широко применяется в полиграфии. Типографское оборудование работает исключительно с этой моделью, да и современные принтеры тоже используют красители четырех цветов. При печати на бумагу наносятся несколько слоев прозрачной краски, и в результате мы получаем цветное изображение, содержащее миллионы различных оттенков. Системы RGB и CMYK удобны при работе с конкретным оборудованием, но не очень удобны для человеческого восприятия. Представив себе желаемый цвет, вы не сможете сказать, сколько в нем составляющих цветов той или иной модели. Следующая модель цвета основана на восприятии цвета человеком. Все цвета в ней описываются тремя числами. Одно задает собственно цвет, другое - насыщенность цвета, а третье - яркость. Цвет в этой модели независим от используемых технических средств. Есть несколько вариантов модели, называемых разными терминами, но означающих одно и то же. Чаще других встречается модель HSB, в которой каждый цвет описывается цветовым тоном - Hue, насыщенностью - Saturation и яркостью - Brightness. Модель HSB не зависит от оборудования и удобна для восприятия человеком, поэтому с ней часто работают различные программы, в дальнейшем преобразуя цвета в модель RGB для показа на экране монитора или в модель CMYK - для печати на принтере. Кроме того, модель HSB удобно использовать при редактировании рисунков. Например, вы хотите заменить зеленый лист на желтый в редактируемой фотографии. Достаточно поменять только цветовую составляющую используемых цветов, не меняя яркость и насыщенность. Рисунок при этом не изменится, но примет иной оттенок. Есть и иные модели представления цвета, но в подавляющем большинстве случаев используется перечисленные выше. Часто для описания оттенка используются фиксированные палитры, то есть список заданных цветов. В результате исследований определяют наиболее часто используемые цвета и помещают их в палитру. Имеется множество палитр, применяемых в производстве разноцветных предметов. Широко распространены палитры PANTONE. Указав, какая палитра используется и номер цвета в этой палитре, можно однозначно определить нужный цвет. Использование фиксированных палитр облегчает выбор необходимых красителей.
<< назад содержание вперед >>


2. Знакомство с CorelDRAW 10

Особенностью последних версий CorelDRAW можно назвать высокую степень интерактивности. Интеллектуальный интерфейс, меняется в зависимости от ситуации, и для выполнения практически любой операции требуется минимальное количество действий. У некоторых людей такая технология вызывает определенные трудности, им больше нравится более консервативный интерфейс Adobe Illustrator или Macromedia FreeHand, но я надеюсь, что после прочтения книги вы привыкните к интерактивному интерфейсу и вам понравится работа с графическим редактором векторной графики CorelDRAW 10.

2.1 Новое в десятой версии редактора

Если вы работали с предыдущими версиями CorelDRAW, вам понравятся новые возможности редактора. С каждой следующей версией CorelDRAW, пользователи получают дополнительные средства для работы с векторной графикой. Также модифицируется и улучшается интерфейс программы. В CorelDRAW 10 реализовано множество усовершенствований. Дальнейшее развитие получила возможность настройки интерфейса. Все команды можно поместить в меню или убрать из него, добавить кнопки на панели инструментов или убрать их. Вы можете сохранить все настройки, чтобы после загрузить их и восстановить внешний вид окна редактора. Теперь лучше реализована отмена и возврат последних действий. Вам доступно больше заготовок, поддерживается большее количество форматов файлов. Кроме простых фигур вы легко можете создавать автофигуры - готовые объекты, сгруппированные в нескольких категориях. Нож и ластик теперь работают с растровыми объектами, вставляемыми в иллюстрацию. Существенно улучшена работа с текстами. Лучше поддерживаются многочисленные языки, добавлены возможности форматирования текста. Существенно улучшился пользовательский интерфейс при работе с цветом. Теперь работа с разноцветными иллюстрациями станет проще, и вы сможете получить более качественные результаты. Улучшена поддержка разработки рисунков для Интернета. CorelDRAW поможет вам создать не только рисунки, но и сгенерировать WWW - страницу и даже разместить ее в Интернете. Автоматизированы некоторые популярные действия, например создание кнопок, меняющихся при подведении указателя мыши и при щелчке мышью.
<< назад содержание вперед >>


2.2. Понятие объекта в CorelDRAW

Любое изображение в векторном формате состоит из множества составляющих частей, которые редактируются независимо друг от друга. Главными кирпичиками, из которых составляется изображение, являются, так называемые, объекты. Понятие объекта является основным понятием в редакторе CorelDRAW 10. Объектом называется элемент изображения: прямая, круг, прямоугольник, кривая, замкнутая кривая, многоугольник и другие. Так как с помощью комбинации нескольких объектов можно создавать новый объект, то объекты могут иметь довольно замысловатый вид. Кроме того, CorelDRAW 10 может создавать группы объектов для дальнейшего редактирования группы как единого объекта. Вне зависимости от внешнего вида, любой векторный объект CorelDRAW имеет ряд общих характеристик. Поясним это на простом примере (Рис. 2.1). Любой объект имеет некоторое количество точек или узлов, соединенных прямыми или кривыми линиями - сегментами. Координаты узлов и параметры сегментов определяют внешний вид объекта. Область внутри объекта можно закрасить или залить одним цветом, смесью цветов или узором. Эту область принято называть заливкой. Сегменты объекта образуют контур, который также имеет свой цвет. Толщину контура можно изменять. Различают замкнутые и разомкнутые контуры. У одного объекта не может быть различных заливок или соединительных линий различной толщины и разных цветов. Для создания сложных изображений требуется использовать множество объектов.

Рис. 2.1. Пример объекта

Мы подробно рассмотрели понятие объекта, потому что вся работа в CorelDRAW 10 ведется именно с объектами. В дальнейшем вы достаточно часто будете встречать в книге упоминания об узлах, сегментах, контуре и заливке объектов. Изменение этих составляющих частей объекта и приводит в результате к созданию требуемого изображения в редакторе векторной графики. Одним из важных объектов CorelDRAW являются плавно изогнутые кривые, с помощью которых можно построить любой произвольный контур. Эти кривые называются кривыми Безье. Математик Пьер Безье (Pierre Bezier) открыл, что произвольную кривую можно задать с помощью двух векторов, находящихся в начале и конце кривой. Это положение легло в основу описания кривых Безье в CorelDRAW. Кроме положения начальной и конечной точки (то есть узлов кривой), внешний вид кривой определяется кривизной, то есть ее изогнутостью между двумя узлами. Кривизна определяется двумя параметрами кривой в каждом узле, которые графически представлены с помощью отрезков, выходящих из узлов. Эти отрезки называются манипуляторами кривизны (Рис. 2.2).

Рис. 2.2. Кривая Безье

Первым параметром, определяющим кривизну, является наклон кривой при ее входе в узел. Наклон манипулятора кривизны и показывает наклон кривой. Кривая как магнитом притягивается к манипуляторам кривизны. Вторым параметром является степень кривизны, то есть, то, как быстро при удалении от узла кривая расходится с прямой, проведенной через узел с тем же наклоном. Степень кривизны определяется длиной манипулятора кривизны. Таким образом, координаты узлов, наклон и длина манипуляторов кривизны определяют внешний вид кривой Безье. Если манипуляторы кривизны с обеих сторон сегмента имеют нулевую длину, то сегмент будет прямым. Увеличение длины манипулятора кривизны превратит сегмент в кривую. Из множества кривых Безье можно составить любую кривую. В CorelDRAW 10 можно использовать растровые изображения, вставляя их в графически документ. При этом каждый растровый рисунок является отдельным объектом, и вы можете редактировать его независимо от других объектов. Хотя CorelDRAW 10 предназначен для работы с векторной графикой, средства для работы с растровыми рисунками у него не хуже, чем у многих редакторов растровой графики.
<< назад содержание вперед >>


2.3. Основные принципы работы с CorelDRAW 10

Перед началом работы с CorelDRAW 10 вам надо получить общие представления о возможностях CorelDRAW 10, средствах для их реализации и основных приемах работы с редактором. Как отмечалось выше, основным понятием в CorelDRAW 10, как и в любом другом редакторе векторной графики, является понятие объекта. Работа над любой иллюстрацией заключается в создании объектов, их редактировании и расположении в нужных местах. При этом сначала создается приблизительная форма объектов, после чего форма уточняется путем добавления, удаления и перемещения узлов контура. После создания необходимой формы объекта задается цвет контура и выбирается заливка объекта. Создать в редакторе можно как стандартные фигуры: прямоугольники, эллипсы, многоугольники, автофигуры, спирали и решетки, так и произвольные фигуры, состоящие из прямых и кривых линий. Среди стандартных фигур есть достаточно сложные рисунки. Средствами работы с текстом CorelDRAW 10 приближается по возможностям к текстовому редактору. Богатые возможности форматирования позволяют прямо в редакторе создавать небольшие текстовые документы, оформленные рисунками. Применение оригинальных эффектов поможет создать красивый рисунок из простых объектов. Каждый рисунок, созданный в редакторе, состоит из одного или нескольких объектов, которые могут накладываться и полностью или частично закрывать друг друга. В качестве объектов могут использоваться растровые рисунки, подготовленные ранее с помощью любого редактора растровой графики и импортированные в CorelDRAW 10. Так как в поставку CorelDRAW 10 включен набор готовых картинок, называемый clipart, часто работа над иллюстрациями сводится к вставке нескольких готовых рисунков, их небольшому редактированию и добавлению текста. В заключении еще раз перечислим основные приемы работы с CorelDRAW 10.

• Создание простых геометрических фигур или произвольных кривых и ломаных, замкнутых и разомкнутых. Вставка и форматирование текста.

• Редактирование любого объекта, изменение цвета контура и заливки, изменение формы объекта.

• Вставка готовых картинок или ранее созданных вами иллюстраций в документ.

• Применение разнообразных художественных эффектов.

• Размещение всех объектов в нужных местах, определение порядка взаимного перекрытия объектов.


2.4. Элементы рабочего окна редактора

Рабочее окно программы CorelDRAW 10 не сильно отличается от окон других графических редакторов. Запустите CorelDRAW 10. На экране появится начальный диалог программы, если вы ранее не отменили данный режим. Отменить режим можно, убрав флажок Show this Welcome Screen at startup (Показывать это окно при запуске). Выберите вариант New Graphic (Создать), щелкнув мышью на соответствующем рисунке (Создать) чтобы создать новый документ. Начальный диалог закроется, и вы сможете начать работу над иллюстрациями, но вначале уделим немного времени настройке программы. Если рабочее окно занимает не весь экран, нажмите кнопку закрыть расположенную в заголовке программы. Теперь, когда рабочее окно занимает весь экран, работать с CorelDRAW 10 станет удобнее.

Примечание: Чтобы были видны все кнопки в панелях инструментов, создаваемое изображение хорошо просматривалось и на экране оставалось бы место для дополнительных управляющих элементов, рекомендуем использовать размеры экрана не менее чем 1024 на 768 точек, а лучше 1280 на 1024.

Если у вас установлено меньшее разрешение, измените его. Познакомимся теперь с основными элементами рабочего окна редактора векторной графики CorelDRAW 10 (Рис. 2.3). Как и в любой другой программе, работающей в среде Windows, в верхней части окна расположены заголовок окна и меню. Остальные элементы характерны для CorelDRAW 10. Внешний вид рабочего окна у вас может несколько отличаться от нашего, так как CorelDRAW 10 предоставляет пользователю достаточно большие возможности по изменению интерфейса.

Рис. 2.3. Рабочее окно программы

В центре окна программы расположен рисунок листа бумаги, называемый рабочей областью. Вы можете рисовать как внутри рабочей области, так и вне ее, но при выводе на печать будет напечатано только то, что находится внутри рабочей области. Полосы прокрутки позволяют передвигаться по изображению, а измерительные линейки - точно позиционировать элементы рисунка и измерять их размеры. Для работы с цветом в правой части окна расположена палитра цветов. В строке состояния выводится различная информация, существенно облегчающая работу с редактором. Основные средства для работы расположены в так называемых панелях инструментов. Кнопки в этих панелях позволяют быстро и легко выполнять любые операции в редакторе. Особенно интересна панель Property Bar (Панель свойств). Кнопки на этой панели появляются и пропадают, в зависимости от ваших действий. В любой момент времени вы найдете на панели свойств самые полезные в текущей ситуации инструменты. Чтобы расположить панель инструментов в произвольном месте, надо перетащить ее с помощью мыши. Панели можно расположить рядом с любой стороной окна или в произвольном месте рабочего окна. Кстати, меню тоже является панелью, и вы можете изменить его местоположение. Вы можете показать или убрать любую панель инструментов. Щелкните правой кнопкой мыши на свободном месте в любой панели инструментов, и рядом появится вспомогательное меню (Рис.2.4). Галочками в нем отмечены видимые панели. Выберите команду Standard (Основная) во вспомогательном меню, если напротив ее не стоит галочка, чтобы разместить на экране основную панель. Если вы не видите на экране меню, выберите команду Menu Bar (Панель меню), и меню появится в окне программы. Аналогично разместите Property Bar (Панель свойств), панель Toolbox (Графика) и Status Bar (Строка состояния) и уберите все прочие панели. Возможно, у вас и так видны именно эти панели, и вам не надо выполнять никаких действий.

Рис. 2.4. Вспомогательное меню

При работе вы будете использовать различные инструменты, расположенные на панели наборов инструментов, называемой Toolbox (Графика). Можете познакомиться с этими инструментами. Последовательно выберите все инструменты панели Toolbox (Графика), щелкая на них мышью. Обратите внимание, что содержимое панели Property Bar (Панель свойств) меняется для каждого инструмента. Также будет меняться информация в строке состояния. Во время работы с различными инструментами мы будем активно пользоваться полями панели Property Bar (Панель свойств). После небольшой настройки редактора вы готовы к началу работы над рисунками и можете начать с создания различных векторных объектов.


3. Создание векторных объектов

Самые сложные рисунки создаются в CorelDRAW 10 из множества простых объектов, поэтому необходимо уметь создавать разнообразные векторные объекты, чтобы в дальнейшем редактировать их, создавая произвольные композиции. Любой объект создается в редакторе аналогичным способов, и освоив создание простых объектов, вы без труда сможете работать с более сложными векторными объектами.

3.1. Создание простых фигур К простейшим геометрические объектам, создаваемым в CorelDRAW 10, можно отнести прямоугольники и эллипсы, многоугольники и спирали, прямые и кривые линии. Большинство сложных объектов состоит из множества простых, поэтому важно научиться рисовать их. Наши эксперименты мы начнем с создания прямоугольника. Выберите инструмент "Rectangle Tool" в панели инструментов Toolbox (Графика), расположенной в левой части окна программы. Изображение кнопки при этом изменится, она будет, как бы зафиксирована в нажатом состоянии. Это говорит о том, что вы находитесь в режиме создания прямоугольников. Она останется нажатой, пока вы не выберите другой инструмент. Установите указатель мыши в любом месте изображения листа бумаги, то есть на рабочем поле. При этом указатель изменится на крестик. Нажмите левую кнопку мыши, и, не отпуская ее, начинайте передвигать мышь. На экране появится прямоугольник, размеры которого будут меняться вместе с передвижением мыши. Отпустите левую кнопку мыши, и прямоугольник останется на экране (Рис. 3.1).

Рис. 3.1. Вновь созданный прямоугольник

Вокруг созданного объекта мы видим черные прямоугольники, в центре перекрестие, а в вершинах - контурные прямоугольники. Все эти управляющие элементы предназначены для редактирования объекта, и мы расскажем об их использовании в следующих разделах. Точно так же рисуется и эллипс. Выберите инструмент "Ellipse Tool"в панели инструментов Toolbox (Графика) и подведите указатель мыши к свободному месту в рабочей области. При этом указатель изменится на крестик с овалом. Нажмите левую кнопку мыши, и, не отпуская ее, передвигайте мышь. На экране появится эллипс, размеры и форма которого будут меняться вместе с передвижением мыши. Отпустите кнопку мыши, и эллипс останется на экране. Теперь мы создадим правильные фигуры: окружность и квадрат. Подведите указатель мыши к свободному месту рисунка. Нажмите и не отпускайте клавишу Ctrl. после чего нажмите левую кнопку мыши, и, не отпуская ее, передвигайте мышь. Отпустите кнопку мыши, после чего отпустите клавишу Ctrl. . Окружность останется на экране. Выберите инструмент "Rectangle Tool" в панели инструментов Toolbox (Графика), нажмите и не отпускайте клавишу Ctrl.. после чего, описанным выше способом, нарисуйте квадрат и отпустите клавишу Ctrl. При рисовании объектов, они создаются между начальным и конечным положением указателя мыши. Однако иногда требуется создать объект, точно задав его центр. Для этого следует воспользоваться возможностью создания объектов из центра. Подведите указатель мыши к месту, где вы хотите расположить центр создаваемого объекта. Нажмите клавишу Shift и, не отпуская ее, создайте прямоугольник. Его центр точно совпадет с начальным положением указателя. Точно так же, как прямоугольники и эллипсы, создаются и другие простые фигуры, причем при их создании также можно использовать клавиши Ctrl и Shift Выберите инструмент "Polygon Tool" в панели инструментов Toolbox (Графика). Мы готовы рисовать многоугольники, но в зависимости от настроек многоугольники могут получиться самыми разными, поэтому вначале выполним настройку. В поле с заголовком звезда в панели Property Bar (Панель свойств) устанавливается количество вершин многоугольника. Введите в поле 5, чтобы создать пятиугольник. Если в панели Property Bar (Панель свойств) вы видите нажатой кнопку звезда, нажмите расположенную рядом кнопку "Polygon Tool" Если же с самого начала в панели нажата кнопка и, то ничего делать не надо. Мы выбрали создание многоугольника, а не звезды. Подведите указатель мыши к свободному месту в рабочей области. При этом указатель изменится на крест с пятиугольником. Нажмите левую кнопку мыши, и, не отпуская ее, передвигайте мышь вниз и вправо. На экране появится пятиугольник, размеры и форма которого будут меняться вместе с передвижением мыши. Отпустите кнопку мыши, и пятиугольник останется на экране Нарисуйте рядом пятиугольник передвигая мышь не вниз, а вверх. Форма пятиугольника будет при этом иной . Нажмите клавишу Delete и последняя созданная вами фигура будет удалена. Вы можете пользоваться этим способом, если с первого раза у вас не получается создать нужный объект. Далее мы создадим еще один многоугольник, предварительно настроив его параметры. Нажмите кнопку звезда панели Propery Bar (Панель свойств), чтобы создать звезду. В поле звезда панели с Property Bar (Панель свойств) введите количество вершин 11. С помощью ползунка на панели Property Bar (Панель свойств) отмеченного значком заштрихованного треугольника установите значение в поле 4. Сегменты соединят узлы через четыре, то есть каждая пятая вершина звезды будет соединена друг с другом. Нажмите и не отпускайте клавишу Ctrl. после чего описанным выше способов нарисуйте многоугольник и отпустите клавишу Ctrl.. Мы создали правильную одиннадцатиконечную звезду, каждая пятая вершина которой соединена друг с другом. С помощью ползунка закрашенного треугольника панели Property Bar (Панель свойств) установите значение в поле 2. Звезда изменит свой вид. Теперь соединение пропускает не по четыре, а по две вершины. Следующей созданной нами фигурой будет спираль, но перед ее рисованием рассмотрим принципы работы с кнопками панели инструментов Toolbox (Графика). Нажмите кнопку "Polygon Tool" в панели инструментов Toolbox (Графика) и удерживайте ее нажатой несколько мгновений. Рядом с кнопкой появится вспомогательная панель, которая содержит несколько кнопок . Нажмите кнопку "Spiral Tool" вспомогательная панель закроется и вид кнопки в панели инструментов Toolbox (Графика) изменится на крест. Снова нажмите и удерживайте кнопку "Spiral Tool" и в появившейся вспомогательной панели нажмите кнопку пятиугольник Внешний вид кнопки панели Toolbox (Графика) снова изменится на пятиугольник.

Примечание:

Следует отметить, что все кнопки инструменты, у которых в правом нижнем углу находится маленький черный треугольник, имеют вспомогательную панель. Если просто щелкнуть мышью на таком инструменте, то можно выбрать его для рисования или редактирования. Если нажать кнопку инструмент и подержать ее нажатой несколько мгновений, появится вспомогательная панель.

Далее мы не будем так подробно описывать эту процедуру, а лишь скажем “Выберите инструмент "Spiral Tool" во вспомогательной панели инструмента "Poligon Tool"”. А теперь приступим к созданию спиралей, но перед этим немного настроим параметры спирали. В поле "Spiral Tool" панели Property Bar (Панель свойств) введите количество вершин 6, чтобы создать спираль из шести витков. Нажмите кнопку спираль панели Property Bar (Панель свойств) для создания симметричной спирали, расстояние между соседними витками которой постоянно. Подведите указатель мыши к свободному месту в рабочей области. При этом указатель изменится на крест со спиралью. Таким же способом как и другие фигуры, создайте спираль . Нажмите кнопку "Spiral Tool" панели Property Bar (Панель свойств). Теперь вы можете создать логарифмическую спираль, расстояние между витками которой увеличивается. С помощью ползунка "Spiral Tool" введите в поле значение 75. Мы определили коэффициент расширения спирали, то есть насколько сильно она расширяется с каждым витком. Аналогично другим фигурам, нарисуйте логарифмическую спираль . В панели Toolbox (Графика), во вспомогательной панели инструмента "Spiral Tool" выберите инструмент"Graf Paper Tool". Теперь мы создадим решетку. Установите в поле панели Property Ваг (Панель свойств) количество ячеек по горизонтали равное 4, а в поле количество ячеек по вертикали равное 3. Так же, как и другие фигуры, создайте решетку . Мы научились создавать разнообразные фигуры. Все они создаются однообразно, и работа с ними не должна вызвать никаких трудностей. Еще раз напоминаем, что при создании любой фигуры можно воспользоваться клавишей Ctrl для создания правильных фигур или клавишей Shift для создания объектов из центра. Можно воспользоваться и обоими клавишами, чтобы создавать правильные объекты из центра.


3.2. Рисование линий

Теперь приступим к построению различных линий: прямых и кривых, замкнутых и разомкнутых, и начнем с построения простейших линий. Выберите инструмент "Freehand Tool" в панели Toolbox (Графика) для построения линии в режиме произвольных кривых. Поместите указатель мыши на рабочее поле. При этом указатель изменится на крест с линией. Нажмите левую кнопку мыши и, не отпуская ее, начинайте передвигать мышь. На экране будет рисоваться кривая линия, повторяющая передвижения мыши. Отпустите левую кнопку мыши, и кривая останется на экране. Практически эта процедура не отличается от традиционного рисования или черчения, в котором вместо карандаша применяется мышь. Если у вас имеется графический планшет с пером, то создание кривой еще больше будет походить на традиционное рисование. Графическое перо существенно облегчает создание произвольных кривых. Далее мы нарисуем прямую линию. Установите указатель мыши на свободное место. Щелкните мышью и, не оставляя кнопку нажатой, начните передвигать мышь. На экране появится отрезок, размер и направление которого будут меняться вместе с передвижением мыши. Щелкните мышью еще раз, и отрезок останется на экране. Чтобы нарисовать строго вертикальную или горизонтальную линию, во время рисования следует нажать и держать нажатой клавишу Ctrl, в этом случае отрезок в процессе рисования будет поворачиваться с дискретным шагом в пятнадцать градусов. Проверьте это обстоятельство самостоятельно. Теперь, когда мы научились рисовать прямые отрезки, перейдем к рисованию ломаных линий, состоящих из прямых и кривых частей . Для этого конечную точку каждого отрезка следует отмечать не одинарным, а двойным щелчком мыши, а в последней точке следует один раз щелкнуть мышью. Установите указатель мыши на свободное место и щелкните мышью, после чего начните передвигать мышь. На экране появится отрезок, размер и направление которого будут меняться. Дважды щелкните мышью, чтобы создать вершину ломаной линии. Первый щелчок мыши заканчивает рисование отрезка прямой, а второй щелчок начинает рисование следующего отрезка из той же самой точки. Передвиньте мышь в новое место и щелкните мышью один раз. Мы получили ломаную линию, состоящую из двух отрезков. Отведите указатель мыши в сторону от созданного объекта. Подведите указатель мыши к концу только что созданной ломаной. Указатель изменится на крест со стрелкой. Это означает, что при рисовании будет продолжено создание предыдущего объекта, а не создаваться новый объект. Нажмите кнопку мыши, и, не отпуская ее, передвиньте мышь, после чего отпустите кнопку. К двум прямым сегментам добавится кривая. Щелкните мышью в конце кривой, передвиньте мышь и еще раз щелкните мышью. Мы добавили еще один отрезок. Подведите указатель мыши к концу последнего отрезка, нажмите кнопку мыши и переместите указатель в начало первого отрезка ломаной, после чего отпустите кнопку. Контур создаваемого объекта будет замкнут. Описанным только что способом можно создавать объекты любой сложности. Единственным ограничением является неразрывность линий. Если вы разорвали линию, то будет создано несколько объектов. Теперь рассмотрим рисование кривых Безье. Перед тем как проделать следующий эксперимент, прочитайте его до конца. В панели Toolbox (Графика), во вспомогательной панели инструмента "Freehand Tool" выберите инструмент растянуть. Теперь мы нарисуем кривую Безье. Установите указатель мыши на рабочее поле. При этом указатель изменится на крест с линией. Нажмите левую кнопку мыши и, удерживая ее, передвиньте мышь. На экране появится пунктирная линия, длина и направление которой меняется с передвижением мыши. Эта пунктирная линия называется манипулятором кривизны, который определяет степень кривизны кривой в точке. Отпустите кнопку мыши и передвиньте мышь, после чего снова нажмите кнопку мыши и удерживайте ее. Появится вторая пунктирная линия. Не отпуская кнопки, подвигайте мышь, и вы увидите, как меняется внешний вид кривой при изменении направления и размера пунктирной линии. Отпустите кнопку мыши, и рисование участка кривой будет закончено. Щелкните мышью на свободном пространстве. Конец кривой будет соединен линией с новым узлом. Щелкните мышью на свободном месте, и будет нарисована прямая линия, так как вы не настраивали кривизну в узлах. Передвиньте мышь, нажмите кнопку мыши, и, удерживая ее, настройте манипулятор кривизны, после чего отпустите кнопку мыши. Мы добавили еще один участок кривой. Щелкните мышью в точке, в которой вы начали рисование и получите замкнутую фигуру. Обратите внимание, что при установке указателя мыши на начальную точку он изменится на крест со стрелкой. С помощью описанных средств вы можете нарисовать произвольную фигуру, состоящую из множества различных линий. Однако CorelDRAW 10 предоставляет вам значительно больше средств, облегчая создания различных специфических объектов.
<< назад содержание вперед >>


3.3.Основы работы с текстом

В графическом редакторе CorelDRAW 10 существует возможность работы с двумя разновидностями текстовых объектов: с фигурным (Artistic) и обычным (Paragraph) текстом. Фигурный текст представляет собой графический объект, с которым можно работать как с любым другим объектом CorelDRAW 10. Обычный же текст представляет собой массив текста в рамке, вставленный в рисунок. Вы можете менять границы рамки обычного текста или придавать ей замысловатую форму, но внутри текст будет располагаться точно так же, как и в любом текстовом редакторе, например, в Word. Фигурный текст используется для ввода небольшого текста от одного символа до нескольких слов. Обычный текст предназначен для ввода больших объемов текстовой информации и часто используется при создании рекламных листовок. Начнем знакомство с ввода фигурного текста. Выберите инструмент “Text tool” в панели инструментов Toolbox (Графика). Панель Property Ваг (Панель свойств) теперь похожа на панель форматирования текстового редактора. Установите указатель мыши на том месте, где вы собираетесь ввести текст. При этом указатель примет вид “крест и Text tool ”. Щелкните мышью, и на месте щелчка появится мигающая вертикальная черта -текстовый курсор, который указывает, куда будет вставлен следующий символ при вводе с клавиатуры. Выберите в списке шрифтов панели Property Bar (Панель свойств) шрифт Arial и установите его размер, равный 24. С помощью клавиатуры введите любой текст. Как только вы введете его, через несколько секунд вокруг текста появятся маркеры выделения, чтобы вы могли работать с текстом, как с любым другом объектом (Рис. 3.2).

Рис. 3.2. Фигурный текст вместе с манипуляторами выделения

можности форматирования текста, присущие хорошему текстовому редактору. Вы можете выбрать шрифт, установить его размер и начертание, задать выравнивание текста. Форматировать можно как отдельные символы, так и слова или предложения. Проще всего выполнять форматирование с помощью панели Property Bar (Панель свойств), которая при работе с текстом содержит кнопки форматирования. Дополнительные возможности по форматированию текста можно получить в специальном диалоге, который вызывается с помощью кнопки “Format text” панели Property Bar (Панель свойств). Возможности форматирования не отличаются от форматирования в текстовом редакторе. Если вы знакомы, например, с работой в Word, то вам будет несложно работать с текстом в CorelDRAW 10. Если выделен текстовый объект целиком, изменится форматирование всех символов. При выбранном инструменте “Text tool” можно выделить часть текста, и поменять только его форматирование. В списках панели Property Bar (Панель свойств) выбирается шрифт и его размер. Особенностью CorelDRAW является то, что вы можете установить дробный размер шрифта, например 11,263. Размер шрифта, как это принято при работе с текстом, устанавливается в пунктах. Правее в панели Property Bar (Панель свойств) расположены кнопки выбора начертания. Кнопка "B" изменяет шрифта на полужирный, кнопка "I" установит начертание курсивом, а с помощью кнопки " U " можно подчеркнуть текст. При этом допускается нажатие нескольких кнопок одновременно, для получения различных комбинаций начертания. Отжав кнопку, вы отмените соответствующее начертание символов. С помощью списка, расположенного правее кнопок начертания, можно задавать выравнивание строк текста. Рисунок на кнопке “Horizontal Alignment” означает, что не используется никакого выравнивания. Открыв список, вы можете установить выравнивание по правому или левому краю, по середине или по обеим сторонам. При выборе выравнивания по обеим сторонам различают два варианта. Выбрав Force Full (Сильно полное), вы выровняете по обоим краям все, без исключения, строки текста, а при выборе (Полное), последняя строка не будет выравниваться, если она слишком короткая. Некоторые привыкли видеть управляющие символы в тексте, например символы конца абзаца. Нажав кнопку “Non printing Characters” вы отобразите все невидимые символы. При печати эти символы будут не видны, они предназначены только для удобства при редактировании и оформлении текста. Редактирование текста осуществляется также просто. При выбранном инструменте “Show \Hide Drop Cap”следует щелкнуть мышью перед любым символом в тексте, и на месте щелчка появится текстовый курсор. В этом режиме вы можете перемещать текстовый курсор по фигурному тексту с помощью клавиш управления курсором. Удалять символы можно с помощью клавиш "Delete" или "Backspase" Существует возможность располагать фигурный текст в несколько строк. Для перехода на следующую строку надо нажимать клавишу "Enter" Как и в текстовом редакторе, выделять фрагменты и перемещать курсор можно с помощью мыши. С фигурным текстом можно выполнять все те же действия, что и с другими графическими объектами. Немного по-другому происходит работа с обычным текстом. Перед вводом обычного текста необходимо определить область, в которой он будет размещен. Подведите указатель мыши к верхнему левому краю области, в которой вы хотите разместить текст, нажмите левую кнопку мыши, и, не отпуская ее, начните передвигать мышь. На экране появится пунктирная рамка, размеры которой меняются вместе с передвижениями мыши. Подберите нужный размер пунктирной рамки и отпустите кнопку мыши. Рамка останется на экране, а в ее начале появится текстовый курсор. Выберите в списке шрифтов панели Property Bar (Панель свойств) шрифт Arial и установите его размер равный 24. Нажмите кнопку “Show\Hide Drop Cap” панели Property Bar (Панель свойств) для получения эффекта буквицы “Horizontal Alignment” и кнопку для полного выравнивания текста по ширине. Введите несколько произвольных слов. Текст будет отформатирован выбранным способом (Рис. 3.3).

Рис. 3.3. Обычный текст вместе с обрамляющей рамкой

При работе с обычным текстом у вас есть несколько дополнительных возможностей по изменению формата. Кнопки “Decrease Indent” и “Increase Indent” панели Property Bar (Панель свойств) позволяют уменьшить и увеличить отступ текста от края рамки. Кнопка “Show\Hide Bullet”добавит маркеры списка к выделенным абзацам. Повторное нажатие кнопки уберет маркеры. Чтобы применить к абзацу эффект буквицы, следует нажать кнопку “Show \Hide Drop Cap”. Повторное нажатие удалит эффект. Вы научились создавать самые разные,достаточно сложные, объекты. Конечно, трудно нарисовать что-либо стоящее с первого раза, не имея возможности вносить исправления. Далее мы рассмотрим возможности CorelDRAW 10 по редактированию объектов.


4. Редактирование изображений

Вряд ли вы сможете создать нужный рисунок сразу, не меняя форму и расположение объектов. После создания любого объекта наступает этап редактирования, во время которого вы преобразуете объекты в соответствии с вашими требованиями. Но для того, чтобы можно было изменять форму и свойства объектов, сначала надо научиться выделять их.

4.1. Выделение объектов

Как уже отмечалось, при создании объектов вокруг них появляются черные прямоугольники, называемые маркерами выделения. То есть, вновь созданный объект уже выделен, и вы можете сразу приступать к его редактированию. Однако для выделения других объектов следует выполнить ряд действий. Во время выполнения предыдущих экспериментов мы создали множество объектов, и теперь мы научимся выделять их. Если же вы удалили их, то заново создайте несколько объектов. Чтобы выделить любой объект, надо выбрать инструмент "Pick Tool" и щелкнуть мышью на этом объекте. Если вы случайно щелкните не один, а два раза, то вместо маркеров выделения вокруг объекта появятся стрелки. В этом случае, так как пока они нам не нужны, щелкните мышью на объекте еще раз, чтобы снова появились прямоугольники. При наличии множества Перекрывающих друг друга объектов, проще их выделять, щелкая на контуре объекта. Чтобы отменить выделение объектов, надо щелкнуть мышью на свободном месте в рабочей области, на котором нет объектов. Когда выбран инструмент "Pick Tool" и не выделен ни один объект, в панели Property Bar (Панель свойств) видна кнопка "Treat as Filled". Если она нажата, то выделять объекты можно с помощью щелчка в любом месте объекта, а если кнопка не нажата, то выделяются объекты только после щелчка на контуре. В CorelDRAW 10 можно выделить объекты, если указатель мыши имеет вид стрелки. Следует отметить, что указатель мыши (черный) и указатель мыши (прозрачный) это разные указатели. Если же указатель имеет вид, отличный от указатель мыши(черный), это означает, что вы работаете с другим инструментом, и для выделения следует сначала нажать кнопку "Pick Tool". Выберите инструмент "Pick Tool" в панели Toolbox (Графика), чтобы продолжить работу с объектами. Щелкните мышью на свободном месте в рабочей области, чтобы отменить выделение всех объектов и нажмите кнопку "Treat as Filled" панели Property Bar (Панель свойств), если она еще не нажата. Попробуйте самостоятельно выделить различные объекты, созданные нами ранее, щелкая на них мышью. Иногда бывает необходимо выделить все объекты сразу. Дважды щелкните мышью на кнопке "Pick Tool". Все объекты будут выделены. Выделение группы объектов обозначается маркерами выделения, расположенными вокруг них (Рис. 4.1, слева). Щелкните мышью на свободном месте в рабочей области, чтобы отменить выделение всех объектов. Давайте выделим группу из нескольких произвольных объектов. Сначала выделите первый объект. После этого нажмите клавишу Shift и, не отпуская ее, выделите остальные объекты, щелкая мышью последовательно на контуре каждого объекта. Обратите внимание, что в строке состояния выводится информация о выделенных объектах. Например, строка 3 Objects selected (Выделено объектов: 3) сообщает о том, что выделено три объекта. Отпустите клавишу Shift. Снова нажмите клавишу Shift. и, не отпуская ее, щелкните мышью на контуре одного из выделенных объектов. Выделение только этого объекта будет отменено. Об этом можно узнать из строки состояния. Отпустите клавишу Shift. Рассмотрим еще один способ выделения объектов. Как один, так и несколько объектов можно выделить, обведя их рамкой выделения.

Рис. 4.1. Выделено несколько объектов

Подведите указатель мыши к месту, расположенному выше и левее объекта или объектов, которые вы хотите выделить. Нажмите левую кнопку мыши и, не отпуская ее, начните передвигать мышь. На экране между начальной точкой и текущим местом указателя появится пунктирный прямоугольник (Рис. 4.1). Этот прямоугольник и называется рамкой выделения. Передвиньте мышь таким образом, чтобы нужные объекты оказались внутри пунктирного прямоугольника, после чего отпустите кнопку мыши. Объекты, целиком оказавшиеся внутри пунктирного прямоугольника, будут выделены. Если во время выделения держать нажатой клавишу Alt, то выделены будут не только объекты, целиком оказавшиеся внутри пунктирного прямоугольника, но и частично попавшие в него. После выделения нескольких объектов, вы можете работать с ними, как будто они являются одним единственным объектом. Самостоятельно поэкспериментируйте с выделением разных объектов.


4.2 Изменение масштаба просмотра изображения

Возможно, вы уже заметили, как неудобно работать с мелкими объектами в режиме просмотра всей страницы целиком. CorelDRAW 10 позволяет просматривать рисунки в различном масштабе, что мы и сделаем в данном примере. При работе с графическим редактором часто приходится менять масштаб изображения, чтобы увидеть рисунок целиком или рассмотреть отдельные фрагменты . Мелкие фрагменты значительно легче редактировать при большом увеличении. Для изменения масштаба следует воспользоваться вспомогательной панелью инструмента "Zoom Tool" . Начнем с увеличения масштаба изображения. Нажмите кнопку "Zoom Tool" панели Toolbox (Графика) и поместите указатель мыши в центр рисунка. Указатель мыши примет вид увеличительного стекла со знаком “плюс” "Zoom In" Щелкните мышью, и масштаб будет увеличен. Щелкните еще раз, и масштаб снова увеличится. Щелкните правой кнопкой мыши, чтобы уменьшить масштаб. Теперь опишем другой, более точный, способ увеличения масштаба изображения, установите указатель мыши в верхний левый угол площади, которую вы хотите просмотреть в крупном масштабе. Нажмите левую кнопку мыши, и, не отпуская ее, начните передвигать мышь. При этом выделенная область будет отмечаться пунктирным прямоугольником. Подведя указатель к правой нижней границе выбранной площади, отпустите кнопку мыши. Изображение на экране будет перерисовано, при этом объекты, попавшие в пунктирный прямоугольник, будут увеличены.

Примечание:

В этом примере, как и в других, мы выделяем область от верхнего левого угла к нижнему правому. Это совсем не обязательно, и можете выделять от любого угла, который вам больше нравится, до противоположного. Результат от этого не изменится.

Коротко скажем о нескольких полезных кнопках панели Property Bar (Панель свойств) при работе с инструментом "Zoom Tool" . С помощью кнопки "Zoom To Selected" можно увеличить только выделенные объекты, а кнопка "Zoom To Object" позволяет установить такой масштаб изображения, при котором будут видны все объекты сразу. Чтобы посмотреть на рисунок в том масштабе, в котором он будет напечатан, нажмите кнопку 1:1. С помощью кнопки "Zoom To Page" можно увидеть изображение листа бумаги, то есть всей рабочей области, а с помощью кнопок "Zoom To Page Width" и "Zoom To Page Heide" увидеть весь лист по горизонтали и по вертикали соответственно. Если вам надо просмотреть участки иллюстрации, невидимые в настоящий момент, можно воспользоваться полосами прокрутки, но можно воспользоваться инструментом "Hand Tool" . Нажмите кнопку "Hand Tool" на панели Property Bar (Панель свойств) и установите указатель мыши в центре иллюстрации. Нажмите левую кнопку мыши, и, не отпуская ее, передвиньте мышь, после чего отпустите кнопку мыши. Видимая область рисунка переместится. Для перемещения по документу не обязательно использовать инструмент "Hand Tool" . Можно прокручивать рисунок с помощью полос прокрутки, как это делается в большинстве программ, работающих в Windows. Для изменения масштаба просмотра можно использовать список масштабов, расположенный в правой части панели Standard (Основная).


4.3 Отмена и возврат последних действий

Если вы следовали указаниям книги, то создали множество разнообразных объектов. Давайте научимся удалять ненужные объекты. Но перед удалением вы должны запомнить, что любую операцию в CorelDRAW 10, как и во многих других приложениях Windows, можно отменить. Для этого достаточно нажать кнопку "Undo" в панели Standard (Основная). Если вы нажмите эту кнопку несколько раз, то будут отменены несколько последних действий. Нажатие кнопки "Redo" вернет обратно отмененное действие. Если вы не изменили настройки редактора, запоминаются сто последних действий. В CorelDRAW 10 есть и более мощное средство отмены и возврата последних действий. Выберите команду меню Window Dockers Undo Docker (Окно Закрепления Закрепле-ние отмены). В правой части окна появится рамка со списком последних ваших действий (Рис. 4.2).

Рис. 4.2. Закрепление для работы с отменой действий

Такие рамки называются закреплениями (Dockers). Их название связано с тем, что они при открытии закрепляются у одной из сторон редактируемого документа. В правой части закрепления видны ярлычки, щелкая мышью на которых, можно вызвать то или иное закрепление. Большинство действий в редакторе можно выполнить с помощью закреплений, которых в CorelDRAW 10 достаточно много. Несколько закреплений могут располагаться выше и ниже, а также перекрывать друг друга. При этом для выбора конкретного закрепления следует щелкнуть мышью на его ярлычке. Нажав кнопку "Forward" расположенную в заголовке закрепления, вы свернете его в узкую полосу рядом с цветовой палитрой, а нажав кнопку "Back" - развернете обратно, убрать закрепление можно, нажав кнопку "Close" в его заголовке. В закреплении для отмены последних действий выводится список всех выполненным вами операций. Отмененные операции выделены серым фоном и расположены в нижней части списка. Негативом выделена последняя выполненная и не отмененная операция. Щелкнув мышью на любом элементе списка, вы отмените или восстановите несколько действий, от выбранного до последнего. Если вы открыли файл для редактирования и выполнили много изменений, но потом решили отказаться от них, вам следует воспользоваться другой возможностью редактора CorelDRAW 10. Выбрав команду меню File Revert (Файл Возвратиться), вы восстановите состояние документа, каким он был сохранен на диске. В диалоге вас попросят подтвердить восстановление. Нажав кнопку ОК, вы безвозвратно удалите все изменения, последовавшие после последнего сохранения файла.


4.4. Перемещение, копирование и удаление объектов

Теперь, после этого отступления, рассмотрим процедуру удаления. Удалить объект очень просто. Выделите объект или несколько объектов, которые вы хотите удалить. Нажмите клавишу Delete. Выделенные объекты будут удалены. Удалите некоторые объекты, созданные ранее, но не переусердствуйте и оставьте несколько объектов для дальнейшей работы с ними. Если же вы удалили все объекты, создайте заново несколько окружностей и прямоугольников, затем продолжайте изучение CorelDRAW 10. Теперь мы попробуем перемещать объекты. Выделите любой объект, после чего нажмите несколько раз любую клавишу управления курсором: "Вниз","Вверх","Вправо" или "Влево". Объект будет передвинут. Расстояние, на которое перемещаются объекты при каждом нажатии можно настроить, но сейчас мы не будем на этом останавливаться. Другим, более удобным, способом перемещения объектов является использование мыши. Подведите указатель мыши к центру выделенного объекта, который отмечен символом "Крестик". При этом указатель мыши примет вид "Стрелки в четыре стороны" .Нажмите левую кнопку мыши и, не отпуская кнопку мыши, начните передвигать мышь. На экране появятся тонкие контуры объекта голубого цвета . Переместите контур объекта на место, которое вы выбрали для объекта, и отпустите кнопку мыши. Объект будет перерисован в новом месте. В принципе, не обязательно устанавливать указатель на центре объекта. В большинстве случаев можно поместить указатель в любое место внутри объекта и переместить его, но при наличии множества перекрывающих друг друга объектов самым надежным способом является использование центра объекта. Если предварительно выделить группу объектов, то точно так же вы можете переместить всю группу.

Примечание:

Для перемещения объектов строго в горизонтальном или вертикальном направлении следует во время перемещения нажать и удерживать клавишу Ctrl

Если вы хотите не переместить, а скопировать объект, то выделите его и нажмите клавишу "Плюс", расположенную рядом с цифровым блоком клавиатуры. Копия объекта будет точно совпадать с исходным объектом, или находиться немного в стороне, в зависимости от настройки вашего редактора. Отодвиньте в сторону копию, нажав несколько раз клавишу "Влево" и вы увидите два абсолютно идентичных объекта. Таким же образом можно скопировать и выделенную группу объектов. Другим способом копирования, удаления и перемещения объектов является использование буфера обмена Windows. Выделите объект и нажмите кнопку "Cut" на панели инструментов Standard (Основная). Объект будет удален из рисунка и помещен в буфер обмена. Нажмите кнопку "Paste" на панели инструментов Standard (Основная) и объект будет помещен из буфера обмена в рисунок. Выделите несколько объектов и нажмите кнопку "Copy" на панели инструментов Standard (Основная). Копии выделенных объектов будут помещены в буфер обмена. Нажмите кнопку "Paste". В рисунок будут вставлены копии объектов. Так как копии располагаются точно над оригиналами, несколько раз нажмите клавишу "Вправо", чтобы увидеть новые объекты. Удалите все созданные ранее объекты, чтобы они не мешали дальнейшей работе. Естественно, через буфер обмена можно переносить рисунки между разными программами. Вы можете нарисовать рисунок в CorelDRAW 10, поместить его в буфер обмена Windows, а после этого вставить в текст документа в редакторе Word. Таким образом, вы сможете украсить любой документ Word профессиональными иллюстрациями.


4.5. Использование сетки, направляющих и измерительных линеек

При перемещении и трансформации объектов можно воспользоваться несколькими вспомогательными средствами, предлагаемыми графическим редактором CorelDRAW 10. Измерительные линейки, расположенные сверху и слева, позволяют определить размеры и местонахождение объектов, а направляющие линии и сетка позволят более точно позиционировать объекты. Рассмотрим на примерах работу с этими средствами. Если на экране нет измерительных линеек, то выберите команду меню View Rulers (Вид Линейки). Линейки появятся на экране. Единицы измерения на линейках соответствуют единицам измерения, принятым в редактируемом документе. При выбранном инструменте "Pick Tool" и не выделенном ни одном объекте, можно установить единицы измерения с помощью списка Units (Единицы) панели Property Bar (Панель свойств). Вы можете дважды щелкнуть на любой из линеек и настроить их в появившемся диалоге, но мы не будем этого делать, а сразу перейдем к их использованию. Нулевые координаты на линейках имеет левый нижний угол рабочей области, однако при необходимости вы можете сменить точку отсчета. Перетащите мышью кнопку "Общее начало двух линеек" расположенную в месте пересечения измерительных линеек. Нулевое положение на линейках теперь расположено в месте, где вы отпустили кнопку мыши. Как всегда, под словами “перетащите мышью” понимается следующая операция: подведите указатель мыши кнопке "Общее начало двух линеек" нажмите левую кнопку мыши и, не отпуская ее,передвиньте мышь, после чего отпустите кнопку мыши. Щелкните правой кнопкой мыши на кнопке "Общее начало двух линеек" и во вспомогательном меню выберите команду Grid Setup (Настройка сетки). На экране появится диалог настройки сетки (Рис. 4.3). Как многие аналогичные диалоги, он является частью общей системы настройки. Перейти к другим диалогам настройки можно, щелкнув мышью на нужной строке в левой части диалога. Однако можно и не обращать внимания на левую часть, работая только с полями правой части диалога.

Рис. 4.3. Диалог настройки сетки

Установите флажокShow grid (Показать сетку), чтобы сетка была видна, и в переключателе выберите вариант Show grid as lines (Показать сетку как линии) для выбора внешнего вида сетки. Если вы выберете вариант Show grid as dots (Показать сетку как точки), вместо сетки вы увидите только точки в местах пересечения линий. Если хотите, вы можете в этом же диалоге установить расстояние между линиями сетки. В нашем примере сетка имеет одну линию на миллиметр. С помощью переключателя, расположенного в верхней части диалога, можно выбирать между заданием частоты линий и интервалами между линиями сетки. Нажмите кнопку ОК, диалог закроется, и на экране появится сетка. Обратите внимание, что при малом масштабе просмотра не все линии сетки отображаются на экране. Теперь добавим направляющие, то есть непечатаемые линии, которые могут помочь при выравнивании объекта. Перетащите мышью вертикальную линейку вниз. На месте, где вы отпустите кнопку мыши, появится пунктирная линия. Это и есть вертикальная направляющая. Перетащите мышью горизонтальную линейку, таким способом создав горизонтальную направляющую. Подведите указатель мыши к вертикальной направляющей. Указатель изменится на "Указатель стрелки". Перетащите направляющую. Обратите внимание что направляющая, с которой вы работаете, красного цвета, а другая направляющая - черного. Нажмите клавишу Delete и вертикальная направляющая будет удалена. Щелкните мышью на оставшейся направляющей, и она изменит цвет черного с на красный. Еще раз щелкните на направляющей и рядом с ее концами появятся стрелки.Подведите указатель мыши к любой стрелке и указатель изменится на "Полукруглую стрелку". Перетащите конец направляющей, и ее наклон изменится. Таким образом, вы можете создать любое количество горизонтальных, вертикальных и наклонных направляющих. Линейки, сетка и направляющие помогут разместить объекты точно в требуемом месте.


4.6 Привязка объектов

В CorelDRAW 10 вы можете сделать так, чтобы сетка, направляющие и объекты вели себя подобно магнитам. Вновь создаваемые или редактируемые объекты притягиваются к ним для точного позиционирования. Для включения режима привязки следует выбрать инструмент "Pick Tool" в панели Toolbox (Графика), отменить выделение объектов и нажать одну из кнопок панели Property Bar (Панель свойств): "Snap To Grid" для привязки к сетке, "Snap To Grideline" для привязки к направляющим и "Snap To Object" для привязки к другим объектам. Можно нажать любую комбинацию кнопок или все кнопки сразу. Проверим их действие на примере. Выберите инструмент "Pick Tool" щелкните мышью на свободном месте для отмены выделения объектов и нажмите кнопку "Snap To Grid" Теперь объекты будут притягиваться к сетке. Создайте несколько объектов. Все они будут притягиваться к узлам сетки. Когда вы перемещаете объект при включенном режиме привязки к сетке, маркеры выделения притягиваются к ближайшему узлу сетки. Если расстояние между линиями сетки маленькое, то на экране будут видны не все линии и вам может показаться, что объекты не притягиваются к сетке. В этом случае сильно увеличьте масштаб, чтобы были видны все линии сетки, и убедитесь, что привязка к сетке работает. Выберите инструмент "Pick Tool" щелкните мышью на свободном месте для отмены выделения объектов и нажмите кнопку "Snap To Grideline". Теперь объекты притягиваются к направляющим. Когда включены оба режима привязки к сетке и привязки к направляющим, то второй режим имеет приоритет. Не имеет значения, как близко проходит направляющая от линии сетки, вы всегда можете выровнять объект по направляющей. Переместите созданные ранее объекты и убедитесь, что они притягиваются к направляющей. Щелкните мышью на свободном месте для отмены выделения объектов и нажмите кнопку "Snap To Object". Теперь включены все режимы привязки. Переместите объекты, чтобы посмотреть, как они будут притягиваться друг к другу. При этом к направляющей объекты также притягиваются. Все объекты имеют так называемые точки привязки, связанные с ними. Точное размещение этих точек зависит от типа объекта. Когда выбран режим привязки к объектам, каждая точка привязки каждого объекта имеет действие гравитации точно так же, как сетка и вспомогательные линии. Эта гравитация имеет ограниченную область, которая называется расстоянием фиксации на экране. Для очень точных привязок полезно сильно увеличить масштаб изображения. Вы можете использовать эффект гравитации точки привязки в одном объекте для изменения размера другого объекта. Вспомните об этом, когда мы будем рассматривать изменение формы объектов. Выберите команду меню View Grid (Вид Сетка), чтобы убрать сетку с экрана. Удалите все созданные ранее направляющие. Щелкните мышью на свободном месте для отмены выделения объектов и нажмите кнопки "Snap To Grid", "Snap To Grideline" и "Snap To Object" чтобы отменить привязку к сетке, направляющим и объектам.


4.7 Блокирование объектов

Часто при работе над большими иллюстрациями вы создаете и редактируете множество объектов. Иногда бывает, что созданные ранее объекты мешают работе. При этом можно случайно удалить или переместить не тот объект, что надо. Чтобы такого не произошло, вы можете заблокировать некоторые объекты. Создайте два произвольных объекта, выделите один из них и выберите команду меню Arrange Lock Object (Монтаж Заблокировать объект). Маркеры выделения вокруг объекта изменятся. Вместо черных прямоугольников они стали похожими на замки. Теперь вы не можете изменить этот объект. Попробуйте переместить этот объект, и вы убедитесь, что он недоступен для редактирования. Попробуйте выделить несколько объектов, включая заблокированный. У вас не получится его выделить. До тех пор, пока вы не разблокируете объект, вы не сможете выполнить с ним ни одного действия. Чтобы разблокировать объект, выделите его и выберите команду меню Arrange Unlock Object (Монтаж Разблокировать объект). Если вы хотите разблокировать все заблокированные объекты текущего документа, следует выбрать команду меню Arrange Unlock All Objects (Монтаж Разблокировать все объекты).


4.8 Цвет контура и заливки объекта

Пока что мы экспериментировали с черно-белыми объектами. Настало время научиться раскрашивать их. Для изменения цвета контура и заливки объекта используется цветовая палитра, расположенная в правой части экрана. В каждой ячейке палитры. Верхняя ячейка означает отсутствие цвета. Следует различать отсутствие цвета и белый Цвет. Если у объекта нет заливки, то есть цвет заливки отсутствует, то объект будет прозрачным, и под ним можно будет видеть другие объекты. Заливка белым цветом делает объект непрозрачным. Давайте немного поэкспериментируем. Нарисуйте прямоугольник. Затем над прямоугольником нарисуйте эллипс. Выделите прямоугольник и щелкните левой кнопкой мыши на черном цвете в палитре. Прямоугольник будет закрашен черным цветом. Выделите эллипс и щелкните левой кнопкой мыши на белом цвете в палитре. Эллипс будет залит белым цветом. Часть прямоугольника, закрытая эллипсом, станет не видна.

Примечание:

CorelDRAW 10 существует режим контурного просмотра, в котором цвета объектов не отображаются на экране. Если заливка объекта '' не видна, выберите команду меню View Normal (Вид Обычный). Отметим, что в режиме контурного просмотра перерисовка сложных изображений на экране происходит несколько быстрее. Щелкните правой (а не левой, как в прошлый раз) кнопкой мыши на белом цвете в палитре. Контур эллипса станет белым. Щелкните левой кнопкой мыши на красном цвете в палитре, и заливка эллипса изменит цвет. Выделите прямоугольник/ и выберите цвет заливки голубой, а цвет контура - синий. Обратите внимание, что, белый контур эллипса виден на фоне прямоугольника. Снова выделите эллипс. Чтобы убрать заливку, щелкните на ячейке "Крест" в палитре. Под эллипсом снова будет виден прямоугольник. Щелкните правой кнопкой мыши на ячейке "Крест" в палитре. Контур эллипса станет бесцветным. И теперь эллипс совсем не виден. Хотя объект полностью невидим, с ним можно выполнять все действия, как с любым объектом. Выделите и эллипс, и прямоугольник, после чего щелкните мышью на зеленом цвете в палитре. Заливка обоих объектов изменится. Если вы хотите использовать дополнительные оттенки цветов, подведите указатель мыши к нужному цвету в палитре, нажмите и не отпускайте кнопку мыши. Рядом появится вспомогательная палитра с оттенками выбранного цвета. Отпустите кнопку мыши. Щелкнув мышью на нужном вам оттенке, вы измените заливку объекта. Если вы щелкните на оттенке правой кнопкой мыши, то изменится цвет контура объекта. Есть и другой способ изменения контура и заливки объектов. Установите указатель мыши на нужном цвете в палитре, нажмите левую кнопку мыши и, не отпуская кнопку, начните передвигать мышь. Как только вы поместите указатель мыши над объектом, указатель мыши изменится на "Указатель мыши и прямоугольник" причем в прямоугольнике рядом со стрелкой будет виден выбранный Цвет. Отпустите кнопку мыши, и объект будет закрашен. Если при выполнении этой операции поместить указатель мыши на контуре объекта, указатель изменится на "Прямоугольник". Отпустив кнопку мыши в этом месте, вы измените цвет контура. Так вы можете менять заливку и контур любого объекта, вне зависимости от того, выделен он или нет.

Как видите, изменять цвет заливки и контура объекта в редакторе CorelDRAW 10 очень просто. Если нужный цвет не виден в палитре, воспользуйтесь кнопками "Вниз" и "Вверх" расположенными по краям палитры, для ее прокрутки вверх и вниз.


5. Работа с несколькими объектами

Как уже не раз отмечалось, любой рисунок в CorelDRAW 10 состоит их множества объектов. Для достижения требуемого результата чрезвычайно важно уметь располагать в нужных местах все объекты, создавать из нескольких объектов новые или одинаково менять параметры целой группы объектов.

5.1 Изменение взаимного расположения объектов

В процессе создания рисунков постоянно приходиться располагать объекты по одной линии или на равном расстоянии друг относительно друга. Например, симметричную фигуру из девяти объектов, достаточно сложно создать “на глаз”. Поэтому в графическом редакторе CorelDRAW 10 существуют специальные средства, которые существенно облегчают взаимное выравнивание объектов. Эти средства помогут расположить объекты вдоль вертикальной или горизонтальной линии. Кроме того, вы можете расположить объекты на равном расстоянии друг от друга. Эти же средства используются, если нужно разместить объекты точно в центре страницы. Создайте девять простых объектов. Для этого воспользуйтесь приемами, описанными выше. Воспользуемся выравниванием объектов для их симметричного расположения. Выделите левые три из только что созданных объектов, то есть первый столбец. Теперь приступим к выравниванию выделенных объектов. Нажмите кнопку "Aling and Distribute" панели Property Bar (Панель свойств). На экране появится диалог для настройки выравнивания объектов, открытый на вкладке Align (Выровнять). Установите флажок Center в верхней части диалога. Мы установили выравнивание объектов по их центрам в горизонтальном направлении. Обратите внимание, что рядом с каждым флажком приведено изображение - схема взаимного выравнивания объектов.

Рис. 5.1. Две вкладки диалога для настройки выравнивания объектов

Щелкните мышью на ярлычке Distribute (Распределить), чтобы перейти на одноименную вкладку диалога (Рис. 5.2, ). Установите флажок Spacing (Интервал) в левой части диалога, чтобы расположить объекты по вертикали через одинаковые интервалы. Закройте диалог с помощью кнопки ОК. Выделенные объекты будут выровнены по горизонтальной линии, которая проходит через их центр, и расположены через одинаковые интервалы. Выделите два правых объекта из верхней строки, а затем нажмите клавишу Shift и щелкните мышью на первом объекте в строке, чтобы выделить и его. Мы выделили последним первый объект, чтобы выравнивание проводилось по нему, а он не менял бы свое положение. Снова нажмите кнопку "Aling and Distribute" панели Property Bar (Панель свойств) и на экране опять появится диалог Align and Distribute (Выровнять и Распределить). Установите флажок Center (По центру) в левой части диалога, перейдите на вкладку Distribute (Распределить) и установите флажок Spacing (Интервал) в верхней части диалога, после чего закройте диалог с помощью ОК. Выделенная строка объектов будет выровнена по вертикали относительно центра первого объекта. Кроме того, объекты будут расположены по горизонтали через одинаковые интервалы. Мы расположили первый столбец и первую строку, а теперь надо выровнять по ним остальные объекты. Выделите два правых объекта из второй строки, а затем нажмите клавишу Shift и щелкните мышью на первом объекте в строке. Нажмите кнопку "Aling and Distribute" и в появившемся диалоге установите флажок Center (По центру) в левой части диалога, после чего нажмите кнопку ОК. Вторая строка выровнена по вертикали, однако, по горизонтали объекты остались не выровненными. Аналогичным образом выровняйте последнюю строку. Выделите два нижних объекта из второго столбца, а затем нажмите клавишу Shift и щелкните мышью на верхнем объекте в столбце. Нажмите кнопку "Aling and Distribute" и в появившемся диалоге установите флажок Center (По центру) в верхней части диалога, после чего нажмите кнопку ОК. Два объекта второго столбца теперь выровнены по верхнему объекту. Аналогично выровняйте объекты последнего столбца. Все наши объекты теперь расположены симметрично и на равном расстоянии друг от друга. Без средств автоматизации получить такой рисунок было бы достаточно трудно. Однако с помощью CorelDRAW 10 взаимное выравнивание объектов происходит очень просто. Выравнивать объекты можно не только друг относительно друга, но и относительно центра страницы. Выделите все девать объектов, а затем нажмите кнопку "Aling and Distribute". Установите флажок Center of Page (По центру страницы), после чего нажмите кнопку Preview (Просмотр). Все выделенные объекты будут размещены в центре страницы, друг на друге. Если вам не видны объекты из-за диалога, перетащите его в сторону, взявшись за заголовок диалога. Так как нам не нужно размещение всех объектов в одном месте, нажмите кнопку Cancel (Отмена), диалог закроется и все объекты вернуться на свои места. Чтобы выровнять не каждый объект отдельно, а все объекты как единое целое, надо объединить их в группу, о чем и будет рассказано ниже.


5.2. Объединение объектов в группы

Если вам надо работать с несколькими объектами, как с одним, вы можете просто выделить их. Но при частом выделении одних и тех же объектов теряется много времени. Кроме того, при выделении вы можете пропустить один из объектов, и дальнейшие действия будут неправильными. Поэтому для постоянной работы с несколькими объектами, как с одним, эти объекты объединяются в группу. Если объекты, созданные в прошлом опыте, не выделены, выделите их все. В строке состояния при этом появится сообщение 9 Objects Selected on Layer 1 (Выделено объектов: 9 Слой 1).

Примечание:

CorelDRAW 10 может размещать рисунки на разных прозрачных слоях, но пока вам совершенно не надо об этом думать. А сейчас просто не обращайте внимания на слово Layer (Слой).

Нажмите кнопку "Group" панели Property Bar (Панель свойств). Запись в строке состояния при этом изменится на Group of 9 Objects on Layer 1 (Группа (9) Слой 1). Щелкните мышью на свободном месте, чтобы отменить выделение, после чего щелкните на любом из объектов. Будет выделена вся группа. Выровняйте объекты по центру страницы. Теперь они не расположатся друг на друге, а просто переместятся к центру, не меняя взаимного положения. Несмотря на то, что объекты объединены в группу и обрабатываются одинаково, сохраняется возможность выделить отдельный объект в группе и отредактировать его отдельно от остальной группы. Нажмите и удерживайте клавишу Ctrl. Щелкните мышью на звезде в центре группы объектов. Вокруг звезды появятся восемь небольших черных кругов - это признак выделенного объекта. Отпустите клавишу Ctrl Выделение объекта останется. Нажмите клавишу Delete, и выделенный объект будет удален. Щелкните мышью на любом оставшемся объекте. Будет выделена вся группа. Теперь группа состоит из восьми объектов, о чем и написано в строке состояния. Разгруппируйте объекты, нажав кнопку "Ungroup" панели Property Bar (Панель свойств). При этом сообщение в строке состояния поменяется на 8 Objects Selected on Layer 1 (Выделено объектов: 8 Слой 1). В заключений отметим, что существует возможность объединить несколько групп объектов в одну группу. Чтобы разгруппировать все вложенные группы, следует нажать кнопку "Ungroup All".


5.3. Наложение объектов друг на друга

Как вы уже знаете, объекты в CorelDRAW 10 могут располагаться друг над другом. При этом верхние объекты закрывают нижние. Если верхние объекты залиты непрозрачным цветом, нижние будут не видны. Порядок наложения объектов определяется порядком их создания: в самом низу всегда находится объект, который создавался первым. Но последовательность расположения объектов друг над другом можно изменять. Именно об этом сейчас и пойдет речь. Для наших экспериментов мы создадим три простых объекта. Удалите все созданные ранее объекты. Создайте квадрат, прямоугольник, и эллипс, закрасьте их различными цветами и расположите примерно так, как на Рис. 5.2. Если вы создадите объекты в заданной последовательности, то внизу будет расположен квадрат, над ним прямоугольник, а наверху - эллипс.

Рис. 5.2. Различное взаимное расположение объектов

Выделите квадрат, который является самым нижним объектом, и нажмите комбинацию клавиш Shift + Page Up. Квадрат будет расположен поверх всех остальных объектов. Нажмите комбинацию клавиш Shift + Page Down. Квадрат снова окажется позади других объектов. Нажмите комбинацию клавиш Ctrl + Page Up . Квадрат будет расположен поверх прямоугольника/ но под эллипсом. Таким образом, комбинация клавиш Ctrl + Page Up перемещает выделенный объект наверх на один объект. Соответственно комбинация клавиш Ctrl + Page Down - на один объект вниз. Все действия по изменению порядка наложения объектов можно выполнить с помощью команд меню Arrange Order (Монтаж Порядок) или с помощью команды Order (Порядок) во вспомогательном меню, вызываемым щелчком правой кнопки мыши на объекте. Выделите прямоугольник, который сейчас находится в самом низу. Выберите команду меню Arrange Order In Front of (Монтаж Порядок Установить перед) или щелкните правой кнопкой мыши на прямоугольнике и выберите во вспомогательном меню команду Order In Front of (Порядок установить перед). Указатель мыши изменится на . Щелкните мышью на эллипсе. Прямоугольник будет размещен над эллипсом. Выберите команду меню Arrange Order Behind (Монтаж Порядок Установить за). Указатель мыши изменится на. Щелкните мышью на эллипсе. Прямоугольник будет размещен под эллипсом. Щелкните правой кнопкой мыши на прямоугольнике и выберите во вспомогательном меню команду Order To Front (Порядок Поверх всех). Прямоугольник расположится поверх всех остальных объектов. Для расположения объекта над всеми другими можно также нажать кнопку "To Front" на панели Property Bar (Панель свойств). Кнопка "To Back" расположит выделенный объект ниже всех остальных объектов документа. Перед выбором команд изменения порядка наложения можно выделять несколько объектов, например, для размещения всех выделенных объектов над каким-нибудь другим объектом. Предлагаем вам самостоятельно проверить это на практике.


5.4. Соединение объектов

Самым удобным способом создания сложных геометрических объектов является их составление из простых. Рассмотрим операцию соединения объектов. В отличие от объединения объектов в группы, при соединении получается один новый объект. При этом появляется возможность создавать объекты с отверстиями внутри (Рис. 5.3). Итак, выполним соединение нескольких объектов/ чтобы создать прямоугольное отверстие в круге.

Рис. 5.3. Объект с отверстием

Нарисуйте окружность на свободном поле документа, после чего нарисуйте прямоугольник, расположив его внутри окружности. Выделите окружность и прямоугольник. О выделении двух объектов будет говорить соответствующая надпись в строке состояния. Можете выровнять по центру объекты, чтобы получился более аккуратный рисунок. Нажмите кнопку "Quik Intersect" панели Property Bar (Панель свойств). Будет создан новый объект: круг с отверстием в виде прямоугольника. Щелкните мышью на красном цвете в палитре, чтобы закрасить объект. Переместите объект, чтобы в отверстии были видны ранее созданные объекты. Мы получили сложный объект с помощью операции соединения. Конечно, можно было бы поместить прямоугольник поверх круга и залить его белым цветом, но тогда не бьшо бы прозрачного отверстия как в результате соединения. Соединенные объекты можно разъединить. Нажмите кнопку "Quik Trim" панели Property Ваг (Панель свойств) для разъединения объектов. На экране останется только красный круг, так как прямоугольник остался под ним. Щелкните на свободном месте мышью, а затем щелкните на круге, чтобы выделить его. Нажмите комбинацию клавиш Ctrl + Page Up. Прямоугольник теперь расположен над кругом, но его плохо видно, так как оба объекта имеют одинаковый красный цвет. Создавать новые объекты на основе других можно также с помощью операций формирования объектов, о которых речь пойдет далее.


5.5. Формирование объектов из нескольких других

В графическом редакторе CorelDRAW 10 имеются три команды формирования объектов из нескольких других: объединение (Weld), исключение (Trim) и пересечение (Intersect)-Bce три операции выполняются с помощью кнопок "Quik Intersect", "Quik Trim" и "Quik Weld", расположенных в панели Property Bar (Панель свойств). Необходимо выделить объекты, над которыми вы хотите выполнить операцию формирования, после чего нажать соответствующую кнопку. Рассмотрим на примерах действие этих операций. Нарисуйте прямоугольник, эллипс и пятиугольник, расположив их так, чтобы все объекты частично перекрывали друг друга . Залейте разными цветами все объекты. Выделите все три объекта, после чего нажмите кнопку "Quik Trim" панели property Ваг (Панель свойств). В результате объединения мы имеем один объект, который объединяет все три объекта . При этом в отличие от операции соединения все внутренние элементы удаляются, и новый объект повторяет только внешние контуры объединенных объектов. Заливка нового объекта зависит от способа выделения, который вы использовали. Если вы выделили объекты, нарисовав с помощью мыши вокруг них пунктирный прямоугольник выделения, то заливка будет взята из нижнего объекта. Если же вы выделили последний объект, щелкнув на нем мышью при нажатой клавише Shift, то заливка будет взята из последнего выделенного вами объекта. Нажмите кнопку "Undo" в панели Standard (Основная), чтобы отменить объединение и выполнить с объектами другую операцию. Снова выделите три наших объекта. Нажмите кнопку "Quik Trim" панели Property Bar (Панель свойств). В результате операции исключения из исходных объектов вырезаются перекрывающиеся области. Вроде бы ничего на экране не изменилось, но теперь все невидимые части одного из объектов удалены. Растащите объекты в разные стороны, и вы увидите это. Если при выделении вы пользовались пунктирной рамкой, то обрезан будет нижний объект. Если же вы последовательно выделяли объекты, то обрезан будет Последний выделенный объект. Нажмите кнопку "Undo" в панели Standard (Основная) несколько раз, чтобы отменить перемещение объектов и операцию исключения. Выделите все три объекта, после чего нажмите кнопку "Quik Intersect" панели Property Bar (Панель свойств). В результате операции пересечения будет создан новый объект, включающий в себя область, общую для всех выделенных объектов. Если при выделении вы пользовались пунктирной рамкой, то заливка нового объекта будет аналогична заливке нижнего объекта. Если же вы последовательно выделяли объекты, то будет взята заливка последнего выделенного вами объекта. Растащите объекты в стороны. Обратите внимание, что исходные объекты остались без изменений. С помощью описанных выше операций, а также с помощью операции соединения объектов можно создавать новые объекты или удалять ненужные части из объектов. Вы можете создавать объекты сложной геометрической формы на основе простых объектов. Любое созданное изображение нужно сохранить и распечатать, поэтому далее будут рассмотрены процедуры сохранения графических документов в файлах на дисках и их печать.


6. Повседневная работа с CorelDRAW 10

Скорее всего, вы захотите сохранить на диске созданное вами изображение, чтобы в дальнейшем иметь возможность продолжить с ним работу. Чаще всего созданные иллюстрации распечатываются на принтере, и CorelDRAW 10 поможет вам сделать наилучшие отпечатки. Этим распространенным занятиям и посвящается данная глава.

6.1. Сохранение документа на диске и его загрузка в CorelDRAW 10

Сохранение документов в CorelDRAW 10 похоже на аналогичные действия в любой программе, работающей под управлением Windows. Чтобы сохранить документ на диске, нажмите кнопку "Save" на панели инструментов Standard (Основная). На экране появится диалог, в котором вы должны ввести имя файла и определить место на диске для сохранения файла (Рис. 6.1). Кроме того, вы можете указать некоторые дополнительные параметры сохранения файла.

Рис. 6.1. Диалог сохранения документа

Сначала необходимо определить диск и каталог, в котором вы хотите сохранить файл. Для выбора диска откройте список Save in (Папка) и щелкните мышью на имени нужного диска. Выбрать папку или каталог, в котором вы хотите сохранить рисунок можно, переходя из каталога в каталог. В родительский каталог верхнего уровня переходят нажатием кнопки "Open" а в подкаталог переходят двойным щелчком на его названии в большом окне диалога Save Drawing (Сохранение документа). Выберите каталог для сохранения файла. В поле File Name (Имя файла) CorelDRAW 10 предлагает в качестве имени Graphic1 (Рисунок1). Введите имя файла в поле File Name (Имя файла) и нажмите кнопку Save (Сохранить). Дополнительными параметрами в диалоге вы можете задать сохранение в формате предыдущей версии CorelDRAW или в формате иного графического редактора. Вы также можете сохранить в файле только выделенные объекты. Однако в большинстве случаев дополнительная настройка сохранения не требуется. При повторном сохранении файла при нажатии кнопки "Save" диалог не будет появляться, так как имя файла уже задано. Теперь потренируемся загружать рисунки в CorelDRAW 10 с диска, но сначала надо завершить работу редактора. Выберите команду меню File Exit (Файл Выход). Работа CorelDRAW 10 будет завершена. Снова запустите CorelDRAW 10 и откройте только что сохраненный файл. Для этого нажмите кнопку "Open" на панели инструментов Standard (Основная), и на экране появится диалог, очень похожий на диалог сохранения. Так же, как и при сохранении, выберите диск и каталог, в котором вы сохранили наш файл, после чего дважды щелкните мышью на имени файла. Возможно, что при запуске у вас на экране появится начальный диалог, тогда нажмите кнопку "Open" в этом диалоге и последний редактируемый файл будет открыт. Существует еще один более быстрый способ загружать документы, с которыми вы недавно работали. Закройте файл, выполнив команду меню File Close (Файл Закрыть). Документ будет закрыт. Откройте меню File (Файл) и щелкните мышью на мени нашего файла в самом низу меню. Как видите, в нижней части меню File (Файл), CorelDRAW 10 ведет список имен файлов с которыми вы недавно работали. Кроме того вы режете загрузить CorelDRAW 10 и начать редактировать файл, если дважды щелкните мышью в проводнике Windows на названии графического файла векторной графики.


6.2. Печать созданных изображений

В реальной работе все, что нарисовано, должно быть напечатано. Причем напечатано должно быть на листе бумаги определенного формата, обычно А4. Поэтому перед созданием рисунка важно правильно установить формат бумаги и его ориентацию. Выберите инструмент "Pick Tool" и щелкните мышью на свободном месте, чтобы ни один объект не был выделен. В первом слева списке панели Property Ваг (Панель свойств) выберите формат листа бумаги А4. Нажмите кнопку "Книжная" на панели Property Bar (Панель свойств), чтобы выбрать книжную ориентацию бумаги. Если же нажата кнопка "Альбомная" будет выбрана альбомная ориентация. Кстати, немного правее расположен список, в котором можно установить единицы измерения. Установите в этом списке millimeters (миллиметры), хотя для печати это совершенно не нужно. Чтобы распечатать изображение, нажмите кнопку "Print" на панели инструментов Standard (Основная). На экране появится диалог Print (Печать) (Рис. 6.2). Диалог настройки печати похож на аналогичные диалоги в Других программах Windows, но он имеет несколько вкладок и множество полей для настройки печати. На вкладке General (Основная) можно выбрать принтер из списка доступных и настроить его параметры/ нажав кнопку Properties (Свойства). Кроме того, можно задать количество копий при печати с помощью поля Number of copies (Количество копий). Для многостраничных документов можно распечатать только часть страниц.

Рис. 6.2. Диалог печати

Большие рисунки можно печатать по частям, установив флажок Print tiled pages (Печатать по частям) на вкладке Layout (Расположение) (Рис. 6.3, сверху). После печати вы можете склеить отдельные листы в большую иллюстрацию. Расположенные рядом поля позволяют установить ширину перекрытия и задать печать маркеров совмещения.

Рис. 6.3. Настройка расположения и цветоделение при печати

В верхней части вкладки Layout (Расположение) расположен переключатель, с помощью которого можно задать положение рисунка на печатном листе. Установив переключатель в положение As in document (Как в документе), вы распечатаете рисунок, так, как он выглядит в документе. В положении Fit to page (Растянуть на страницу) рисунок будет увеличен или уменьшен, чтобы точно вписаться в страницу. Положение переключателя Reposition images to (Изменить расположение рисунков) позволяет выбрать в расположенном рядом списке один из вариантов расположения рисунка. Можно распечатать иллюстрацию в центре листа, или с одного из краев листа бумаги. Остальные поля позволяют выполнить более точные настройки расположения рисунка.

На следующей вкладке (Рис. 6.3, снизу) можно настроить цветоделение. В полиграфии цветные рисунки получаются последовательным наложением разноцветных красок. Для каждой краски используется свои диапозитивы, с которых печатается продукция. Чтобы напечатать цветное изображение в типографии, вы должны передать им несколько черно-белых диапозитивов, соответствующих разным цветам. Установив нужные значения в полях диалога, вы получите при печати не цветной рисунок, а несколько черно-белых. Цветоделение -достаточно сложное занятие, и многие предпочитают выполнять этот процесс в специализированных фирмах. Если у вас есть опыт цветоделения, вы без труда сможете настроить его. На вкладке Prepress (Предварительная обработка) (Рис. 6.4, сверху) также расположены поля настройки печати для последующей передачи отпечатков в типографию. Вы можете напечатать негативное изображение или зеркально отраженное. Кроме того, вы можете добавить печать специальных маркеров и Других элементов, которые используются в полиграфии. На вкладке Misc (Разное) (Рис. 6.4, снизу) можно задать качество печати и ограничить печать некоторыми группами объектов. В большинстве случаев на этой вкладке ничего менять не надо. Если при генерации печатной версии документа возникли ошибки/ о них можно узнать на последней вкладке диалога. Надпись на ярлычке этой папки No Issues (Никаких проблем) означает, что ошибок нет. В противном случае на ярлычке указывается количество ошибок. Перейдя на вкладку, вы можете прочитать описание ошибок. В некоторых случаях можно пренебречь ошибками, а иногда требуется изменить параметры печати.

Рис. 6.4. Дополнительные настройки печати

В диалоге Print (Печать) можно сделать огромное количество настроек, особенно для печати цветных изображений. Об этом диалоге можно написать отдельную книгу, но чаще всего вам не придется ничего настраивать. Не меняя настроек, нажмите в диалоге кнопку Print (Печать). Начнется процесс печати. Для сложных рисунков подготовка к печати и собственно печать может занять очень много времени. Если вы хотите просмотреть образец перед печатью, а в небольшом поле предварительного просмотра не видны некоторые детали, можно вызвать просмотр рисунка в отдельном окне. Нажав в диалоге кнопку Print Preview (Просмотр перед печатью), вы перейдете в режим просмотра. Нажав кнопку Close (Закрыть), вы вернетесь к диалогу печати.


6.3. Использование шаблонов

Для быстрого создания стандартных документов, вы можете воспользоваться шаблонами, включенными в состав поставки пакета программ CorelDRAW 10. Вместе с редактором поставляется множество красивых шаблонов, объединенных в несколько групп. Достаточно легко найти шаблон, помогающий в создании определенных рисунков. Например, если вы хотите сделать обложку для компакт - диска, достаточно выбрать соответствующую заготовку и добавить несколько надписей (Рис. 6.5). Конечно, при создании реальной обложки, вы добавите больше надписей и измените стандартные рисунки, чтобы получить уникальную обложку диска.

Рис. 6.5. Пример использования заготовки

Для создания нового документа на основе заготовки выберите команду меню File New from template (Файл Создать из шаблона). На экране появится диалог выбора шаблона (Рис. 6.6), в котором вы можете выбрать наиболее подходящую заготовку.

Рис. 6.6. Диалог New from template (Создать из шаблона),

На нескольких вкладках диалога вы можете обнаружить множество полезных шаблонов. Щелкнув мышью на любом шаблоне, вы увидите его в поле предварительного просмотра, расположенном в правой части диалога. После того, как вы выберите нужный шаблон, нажмите кнопку ОК, диалог закроется и будет создан новый документ. При этом в документе уже будут присутствовать рисунки, которые вам нужно отредактировать, чтобы получить необходимый рисунок.

Некоторые шаблоны содержат несколько страниц, на каждой из которых содержится свой рисунок. Все рисунки на различных страницах оформлены в едином стиле, и вы можете на их основе разработать свой фирменный стиль. О работе с многостраничными документами будет рассказано ниже.

Рассмотренные приемы работы с CorelDRAW позволяют создавать рисунки, сохранять и печатать их. Этого должно хватить при работе над простыми иллюстрациями. Однако для более сложных работ потребуется воспользоваться большим набором возможностей редактора. Об этом и пойдет речь в следующей части книги.


II. Профессиональная работа в CorelDRAW 10

Вы уже знаете, как создавать различные объекты, перемещать и копировать их, а также выполнять некоторые другие несложные операции. Однако CorelDRAW 10 предоставляет значительно больше возможностей по редактированию объектов, что позволяет создавать профессиональные иллюстрации за короткое время.

7. Изменение формы объектов

Очень часто возникает потребность в изменении формы созданных ранее объектов. Вы можете изменить не только размеры и пропорции объектов, но и контур объекта, отредактировав узлы и сегменты, его составляющие. Но вначале следует познакомиться с простейшими преобразованиями объектов CorelDRAW.

7.1. Трансформация объектов

Начнем знакомство с трансформацией объектов с изменения размера. Выделите один из объектов, созданных ранее. Выделенный объект обрамляется черными прямоугольниками, называемыми маркерами выделения. Подведите указатель мыши к нижнему правому маркеру выделения. Внешний вид указателя мыши при этом изменится с обычного на двунаправленную стрелку. Нажмите левую кнопку мыши, и, не отпуская ее, начните передвигать мышь. При этом у объекта появится тонкая голубая контурная копия. Передвиньте мышь правее и ниже, после чего отпустите кнопку мыши. Объект будет увеличен, при этом будут сохранены его пропорции, то есть соотношение его ширины и высоты. Для изменения размера с сохранением пропорций можно воспользоваться не только правым нижним маркером выделения, но и любым другим, расположенным в одном из углов рамки обрамления. Следует отметить, что если в процессе изменения размера объекта нажать и удерживать клавишу Shift. то изменение размера будет происходить относительно центра объекта. Давайте убедимся в этом. Нажмите и удерживайте клавишу Shift. Один из объектов уже выделен. Подведите указатель мыши к нижнему правому маркеру. Внешний вид указателя мыши при этом изменится на "двунаправленную стрелку". Нажмите левую кнопку мыши, и, не отпуская ее, начните передвигать мышь. У объекта появится контурная копия, которая будет уменьшаться или увеличиваться во все стороны от объекта, а не только в сторону нижнего правого угла как в предыдущем эксперименте. Отпустите левую кнопку мыши и затем клавишу Shift. Измененный объект останется в документе. Для изменения размера объекта только по горизонтали или только по вертикали следует выполнить аналогичные действия с маркерами выделения, расположенными посредине сторон обрамляющей рамки. Схематически соответствие различных прямоугольников обрамления разным действиям. При этом стрелки показывают направление, в котором можно менять размер с помощью соответствующего маркера выделения. Попробуем изменить ширину объекта, не меняя его высоты. Подведите указатель мыши к среднему маркеру выделения на правой стороне. Внешний вид указателя мыши при этом изменится на "двунаправленную стрелку". Нажмите левую кнопку мыши, и,не отпуская ее, начните передвигать мышь. Передвиньте мышь левее, после чего отпустите кнопку мыши. Ширина объекта будет уменьшена, при этом высота останется без изменений. Точно так же можно изменить и высоту, используя средний маркер выделения в нижней или верхней части обрамления. Если уменьшать размер объекта до нуля, и, не останавливаясь, передвигать мышь дальше, через границу объекта, как бы выворачивая его, то можно получить зеркальное отображение объекта. Чтобы при зеркальном отображении сохранить размеры исходного объекта, нажмите и не отпускайте клавишу Ctrl во время операции. При нажатой клавише Ctrl масштабирование происходит с дискретным шагом в 100%. С помощью копирования объектов и зеркального отображения легко создавать такие узоры. Попробуйте самостоятельно получить зеркальное отображение любого объекта. Теперь мы рассмотрим перекос объектов. Что такое перекос, показано на Рис. 7.1. Одна из сторон объекта остается на месте, а противоположная сторона перемещается. Возможен перекос как в горизонтальном, так и в вертикальном направлении. Последовательное выполнение нескольких перекосов может сильно исказить любой объект. Перекос часто используется в создании иллюстраций. Например, перекос прямоугольников может быть использован для рисования открытых папок и книг. Кстати, фигурный текст на обложке книги был тоже перекошен и повернут.

Рис. 7.1. Исходный прямоугольник и результат операции перекоса

Если применить перекос к более сложным объектам, результат получится еще более экзотический. Различают вертикальный (Рис. 7.1, в центре) и горизонтальный (Рис. 7.1, справа) перекос. Как уже отмечалось ранее, щелчок мыши на выделенном объекте приведет к тому, что маркеры выделения поменяются на стрелки (Рис. 7.2). Эти стрелки означают, что в данном режиме можно выполнять перекос и поворот объекта. Для начала выполним горизонтальный перекос объекта. Выделите любой объект, после чего щелкните мышью на его контуре еще раз, чтобы вокруг объекта появились стрелки. Подведите указатель мыши к верхней стрелке. Указатель изменится на другой. Нажмите левую кнопку мыши, и, не отпуская ее, начните передвигать мышь. У объекта появится тонкая голубая копия. Установите нужное положение пунктирной рамки и отпустите кнопку мыши. Перекос объекта завершен. Точно так же можно выполнить вертикальный перекос. При этом следует использовать стрелку, а указатель мыши примет другой вид .

Рис. 7.2. Стрелки вокруг объекта

Теперь перейдем к повороту объекта вокруг центра вращения. Кстати, центр вращения обозначен символом в центре объекта. Для поворота используются стрелки поворота расположенные по углам объекта. Безразлично, какая из них используется, результат будет один и тот же. Подведите указатель мыши к стрелке. Указатель изменится на другой. Нажмите левую кнопку мыши, и, не отпуская ее, начните передвигать мышь. Голубой контур объекта начнет вращаться. Установив нужное положение, отпустите кнопку мыши, и объект будет повернут. Если при повороте нажать и удерживать клавишу Ctrl. то поворот будет выполняться на угол, кратный пятнадцати градусам. Для более сложного поворота можно изменить расположение центра вращения. Перетащите с помощью мыши значок центра в другое место. Поверните объект, чтобы увидеть, что теперь поворот осуществляется иначе. Как и в других операциях CorelDRAW 10, перекос, вращение, изменение размеров и зеркальное отображение можно применить к группе объектов. CorelDRAW 10 позволяет выполнять и более сложные преобразования объектов, о которых речь пойдет ниже.


7.2. Изменение формы стандартных объектов

Очень легко в редакторе CorelDRAW 10 выполняется закругление углов прямоугольника, создание дуг и секторов из эллипсов. Можно также произвольно изменять форму кривых линий, изменять форму многоугольников и других фигур. Как в любом редакторе векторной графики, объекты CorelDRAW 10 состоят из узлов и сегментов, которые соединяют эти узлы. Изменение формы объектов, в основном, связано с изменением взаимного расположения и количества узлов, а также кривизны сегментов. В зависимости от способа редактирования, объекты в редакторе можно разделить на две группы. Первая группа - это все объекты, которые состоят из кривых линий. Объекты этой группы можно редактировать произвольно, достигая самых замысловатых форм. Вторая группа - это стандартные объекты: прямоугольники, эллипсы и многоугольники, а также автофигуры. Форму этих объектов можно изменять только в соответствии с предопределенным алгоритмом. Например, у прямоугольников можно только закруглить углы, а из эллипсов - создавать только сектора или дуги. Другими словами, из эллипса нельзя сразу создать форму груши, для этого сначала необходимо преобразовать эллипс в кривые линии. Возможно, вам покажется странным такой подход, но, последовательно выполняя все эксперименты, вы поймете, что в редакторе CorelDRAW 10 все хорошо продумано. Спирали являются обычными кривыми линиями, и никаких особенностей редактирования этих объектов нет. Решетки состоят из множества прямоугольников, сгруппированных в единое целое. Пока вы не разгруппировали их, ничего с ними сделать нельзя, а после разгруппировки можно скруглить углы каждого прямоугольника. Но пора приступать к опытам, и для начала мы рассмотрим закругление углов прямоугольника. Удалите все объекты, созданные в предыдущих примерах, чтобы они не засоряли рабочую область. С помощью инструмента "Restangle Tool" панели Toolbox (Графика) нарисуйте прямоугольник на свободном месте рабочей области окна программы. Подведите указатель мыши к одному из узлов, расположенных в вершинах прямоугольника и отмеченных маленькими рамками. Указатель примет другой вид (Рис. 7.3, слева). Теперь вы можете переместить узел. Нажмите левую кнопку мыши , не отпуская ее, начните передвигать мышь. Вместе с указателем мыши начнут передвигаться узлы, причем каждый из них раздвоится (Рис. 7.3 справа).

<

Рис. 7.3. Закругление углов прямоугольника

Переместив узлы на нужное расстояние, отпустите кнопку мыши, углы прямоугольника останутся закругленными. Таким образом, мы легко получили новую симметричную фигуру (Рис. 7.4, слева).

Рис. 7.4. Фигуры, полученные из прямоугольника.

Из прямоугольника можно создать и несимметричную фигуру, по-разному меняя кривизну углов. С помощью инструмента "Restangle Tool" панели Toolbox (Графика) нарисуйте еще один прямоугольник. Отожмите кнопку "Round Corners Togever " в правой части панели Property Ваг (Панель свойств), чтобы рисунок на ней изменился на открытый замок "Round Corners Togever ".Мы разрешили независимое изменение кривизны узлов. Введите различные значения в четыре поля панели Property Bar (Панель свойств), обозначенные рисунками "Left Rectangle Corner Roundness","Right Rectangle Corner Roundness". В каждом поле настраивается один из углов прямоугольника. Кривизна углов прямоугольника изменится в разной степени (Рис. 7.4, справа). Нажмите кнопку "Round Corners Togever ", и поменяйте значение кривизны одного из узлов. Кривизна остальных изменится автоматически. Рассмотрим пример редактирования эллипса. С помощью инструмента "Ellipse Tool" нарисуйте эллипс. Подведите указатель мыши к узлу, расположенному в верхней части эллипса. Указатель примет другой вид (Рис. 7.5, слева).

Рис. 7.5. Создание сектора эллипса

Нажмите левую кнопку мыши, и, не отпуская ее, начните передвигать мышь, не выводя указатель мыши за границу эллипса. Вместо одного узла появятся два, причем один начнет передвигаться вместе с мышью. Оба узда будут соединены с центром эллипса (Рис. 7.5, в центре). Отпустите кнопку мыши, и из эллипса получится сектор (Рис. 7.5, справа). Перетащите новый узел обратно, чтобы он объединился с верхним узлом. Мы снова получили эллипс.

Рис. 7.6. Создание дуги из эллипса

Снова перетащите узел, но при этом указатель мыши должен находиться за пределами эллипса (Рис. 7.6, слева). Отпустите кнопку мыши и вместо эллипса вы увидите дугу (Рис. 7.6,справа). Следует отметить, что описанный выше способ не позволяет изменить форму эллипса произвольным образом, так как для этого сначала его следует преобразовать в кривые. Для создания из эллипса сектора можно также нажать кнопку "Pie" на панели Property Bar (Панель свойств) и ввести в расположенные рядом поля "Starting and Ending Angles" значения углов наклона начала и конца сектора. Нажав кнопку "Ars" вы создадите дугу. Чтобы превратить дугу или сектор в эллипс, надо нажать кнопку "Ellipse". Еще один вид стандартных объектов, который может значительно изменить форму - это многоугольники. С помощью инструмента "Polygon Tool" панели Toolbox (Графика) нарисуйте пятиугольник (Рис. 7.7,слева).

Рис. 7.7. Исходный многоугольник и варианты, изменения его формы

Так же, как при работе с прямоугольником и эллипсом, перетащите любой из узлов. С помощью этих действий можно получить экзотические фигуры (Рис. 7.7, в центре и справа). Вы можете менять количество вершин многоугольников, превращать их в звезды и обратно. Это делается точно так же, как и при их создании,о чем было рассказано выше. Есть еще одна особенность изменения формы многоугольников. Вы можете добавлять узлы в контур, что мы сейчас и сделаем. Создайте еще один пятиугольник, после чего выберите инструмент "Shape Tool" в панели Toolbox (Графика). Этот инструмент предназначен для работы с узлами. Дважды щелкните мышью на одной из сторон пятиугольника, примерно посередине между узлами. На месте щелчка, а также в аналогичном месте на всех остальных сторонах пятиугольника, появятся новые узлы (Рис. 7.8, слева).

Рис. 7.8. Добавление узла в многоугольник и его перемещение

Перетащите ближе к центру добавленный узел, чтобы получить что-то вроде пропеллера (Рис. 7.8, справа). Хотя многоугольники сильно меняют форму при перемещении узлов, наибольших результатов можно добиться при изменении узлов кривых линий.


7.3. Редактирование автофигур

При выделении большинства автофигур вы можете увидеть один или несколько ромбиков, расположенных в разных частях объектов. Перемещая их с помощью мыши, вы можете менять форму автофигур. С помощью инструмента "Basic Shapes" создайте рисунок улыбающегося лица. Ромбик в этом рисунке помещается в середине рта (Рис. 7.9, слева).

Рис. 7.9. Редактирование автофигуры.

Подведите указатель мыши к ромбику. Указатель примет вид треугольного указателя. Нажмите левую кнопку мыши, и, не отпуская ее, начните передвигать мышь. Вместе с ромбиком начнет передвигаться линия рта, меняя при этом изгиб (Рис. 7.9, в центре) Переместив указатель мыши немного вверх, отпустите кнопка мыши, и линия рта в рисунке изменит свой изгиб. Так из улыбающегося лица мы получили грустное (Рис. 7.9, справа). В некоторых автофигурах нет ромбиков, и вы не можете изменить их форму. Если в автофигуре есть один или два ромбика, вы можете менять расположение и кривизну линий, перетаскивая мышью связанные с ними ромбики. Кроме изменения формы, вы можете изменить размер автофигуры, выполнить перекос или повернуть ее. Все эти операции выполняются так же, как и для любого другого объекта. В результате вы можете получить самый необычный объект, но иногда этого бывает недостаточно. Для создания произвольного контура может потребоваться полноценное редактирование узлов контура объекта. При этом автофигуры, эллипсы, прямоугольники и другие стандартные фигуры должны быть предварительно преобразованы в произвольные кривые линии.


8. Редактирование контура и заливки

Изменение формы объекта только часть возможностей CorelDRAW 10. При создании различных иллюстраций вам наверняка потребуется настраивать контур объектов и использовать самую разнообразную заливку, совсем не обязательно одноцветную.

8.1. Толщина контура, стиль линий и различные типы стрелок

Во всех предыдущих примерах толщина контура создаваемых объектов оставалось постоянной. Все вновь создаваемые объекты имели очень тонкий контур. Однако иногда возникает потребность в изменении толщины контура. Рассмотрим этот процесс в CorelDRAW 10. Создайте прямоугольник или воспользуйтесь ранее созданным объектом. Пока он имеет тонкий контур. Нажмите кнопку "Outline Tool" на панели инструментов Toolbox (Графика). Появится вспомогательная панель инструментов, предназначенных для установки различных атрибутов контура объекта (Рис. 8.1).

Рис. 8.1. Вспомогательная панель работы с контуром

Нажмите кнопку "No Outline" во вспомогательной панели, и контур объекта будет удален, то есть его толщина станет равной нулю. Повторно откройте вспомогательную панель с помощью кнопки "Outline Tool" затем нажмите кнопку "24 Point Outline". Контур объекта станет очень толстым. Попробуйте установить разную толщину контура с помощью кнопок "Hairline Outline", других линий, во вспомогательной панели (Рис. 8.2).

Рис. 8.2. Разная толщина контура

В CorelDRAW 10 имеется возможность устанавливать толщину контура более точно. Для этого нажмите кнопку "Outline Pen Dialog" вспомогательной панели инструментов работы с контуром объекта, и на экране появится диалог Outline Pen (Атрибуты контура) (Рис. 8.3). В этом диалоге вы можете установить множество характеристик контура, в том числе и его толщину. В поле Width (Толщина) расположено число, означающее толщину контура. Рядом, в открывающемся списке, выбираются единицы измерения. Откройте список рядом с полем Width (Толщина) и выберите строку millimeters (миллиметры). При этом изменится число, показывающее толщину линии. Теперь указано значение в миллиметрах. Поменяйте значение толщины, для чего щелкните мышью в поле и введите новое значение. Кратко рассмотрим назначение остальных полей диалога. В поле Color (Цвет) можно установить цвет контура, выбрав его из палитры, а в списке Style (Стиль) выбирается стиль контура: непрерывная линия или прерывистая, состоящая из отрезков. Также можно выбрать пунктирную, штрих - пунктирную и иную линию контура.

Рис. 8.3. Диалог Outline Pen (Атрибуты контура)

Переключатели Comers (Углы) и Line caps (Концы линий) позволяют выбрать один из вариантов углов и окончания линий. Флажок Behind fill (Под заливкой) располагает контур под заливкой. Если же он не установлен, контур будет расположен над заливкой. При расположении под заливкой половина контура не видна. Это особенно часто применяется при работе с текстом. Если установлен флажок Scale width image (Сохранять пропорции), то при изменении размеров объекта пропорционально будет меняться и толщина контура. В противном случае толщина контура останется неизменной при увеличении и уменьшении объекта. В группе полей Arrows (Наконечники) выбираются стрелки, которые расположатся на начале и конце линии. В нашем случае, когда контур объекта замкнут, стрелки располагать негде. Группа полей Calligraphy (Каллиграфия) определяет наклон и форму пера формирующего контур. Эта возможность осталась от старых версий и сейчас практически не используется, а при необходимости создания каллиграфического контура используется художественное перо. Установите флажок Scale width image (Сохранять пропорции) для изменения толщины контура при изменении размеров объекта. Выберите закругленные углы и увеличьте толщину линий контура. Нажмите кнопку ОК. Диалог закроется, и толщина контура выделенного объекта будет изменена. Кроме того, контур в углах станет немного скругленным (Рис. 8.4). Закругление контура отличается от закругления углов прямоугольника.

Рис. 8.4. Толстый контур со скругленными углами

Сильно уменьшите прямоугольник, и вы увидите, что толщина контура также уменьшилась. Кроме цвета и толщины контур объекта может быть пунктирным или штриховым, то есть разного стиля. Более того, для незамкнутых линий существует возможность выбирать символ для начала и конца линии, то есть создавать наконечники или стрелки. Под стрелками мы подразумеваем самые разные рисунки, вне зависимости от их внешнего вида, которые располагаются на концах линий (Рис. 8.5). Чтобы нарисовать линии различного стиля со стрелками или без них, можно воспользоваться диалогом Outline Pen (Атрибуты контура), с которым вы уже знакомы. Но мы рассмотрим использование панели Property Bar (Панель свойств). С помощью инструмента "Freehand Tool" панели Toolbox (Графика) нарисуйте прямую линию. В центре панели Property Ваг (Панель свойств) вы увидите три списка с рисунками, с помощью которых можно поменять внешний вид линий. Список в центре предназначен для задания стиля линий: непрерывная/ пунктирная, штрих - пунктирная или какая-либо другая линия. Правее и левее расположены списки для установки стрелок в начале и конце линии. Открывающийся список "Outline Pen Dialog" , расположенный правее, позволяет выбрать толщину линий, причем вариант Hairline (Волосяная) означает самую, насколько это возможно, тонкую. Выберите в списке "Outline Pen Dialog" более толстую линию. Толщина созданного нами отрезка увеличится. Откройте левый список выбора окончаний стрелок, и рядом появится список шаблонов стрелок, которые вы можете поставить на конце линии (Рис. 8.6, сверху). С помощью полосы прокрутки просмотрите список, затем выберите какой-либо символ, для чего щелкните на рисунке этой стрелки мышью. Список закроется, а рисунок выбранной стрелки появится на начале линии. Кроме того, рисунок выбранной , стрелки появится на левой кнопке. Аналогично выберите для окончания линии с помощью правого списка рисунок стрелки какой-либо рисунок. Рисунок появится на кнопке, а на начале и конце нарисованного вами отрезка появятся выбранные вами стрелки: суммарный рисунок. Если вы не видите изменений, увеличьте масштаб просмотра изображения. Выберите другие стрелки. Стрелки на выделенном отрезке изменятся. Самостоятельно поэкспериментируйте с разными видами стрелок. В нижней части списка стрелок расположена кнопка Other (Другие). Если нажать ее, появится диалог для рисования произвольной стрелки. Вы можете сами попробовать создать свою стрелку.

Рис. 8.6. Список стрелок и линий

Откройте список, расположенный между двумя списками, с которыми мы только что работали. На экране появится список стилей линий (Рис. 8.6, снизу). С помощью полосы прокрутки пролистайте список/ после чего выберите стиль пунктира, для этого щелкните мышью на изображении данной линии. Список закроется, стиль линии поменяется, а рисунок выбранного стиля линии появится на кнопке. Нарисуйте еще несколько линий и самостоятельно измените их внешний вид. Если нажать кнопку Other (Другие), расположенную в списке, то можно самостоятельно разработать нестандартный стиль линий. Для изменения атрибутов нескольких объектов, следует выделить их, после чего вызвать диалог Outline Pen (Атрибуты контура). Как уже отмечалось, цвет контура можно выбрать, щелкнув правой кнопкой мыши на палитре цветов или установив его в диалоге Outline Реп (Атрибуты контура). В диалоге цвет также выбирается из палитры. Однако CorelDRAW 10 имеет более мощные средства работы с цветом. Если вы нажмете кнопку "Outline Color Dialog", расположенную во вспомогательной панели инструмента "Outline Tool" то на экране появится диалог настройки цвета контура. Так как он ничем не отличается от диалога настройки однородной заливки, который мы рассмотрим при описании заливок, то мы не будем на нем останавливаться, а перейдем к работе с заливками. Еще одним способом настройки контура является использование специального закрепления. Нажав кнопку "Color Docker Window", во вспомогательной панели инструмента "Outline Tool" вы откроете закрепление настройки цвета. О нем также будет рассказано ниже.


8.2. Однородная заливка

Простейшим способом заливки объекта является использование палитры, расположенной в правой части окна CorelDRAW 10. Таким способом можно закрасить объект однородным цветом, выбранным из цветов, имеющихся в палитре. Если же вы хотите использовать нестандартный цвет, которого нет в палитре, или применить узор либо переход цветов, то вам следует использовать другие средства графического редактора. Есть множество способов настройки заливок, и выбор того или иного способа обусловлен только вашими пристрастиями. Так как все способы похожи друг на друга, не все они будут рассмотрены одинаково подробно. Создайте произвольный прямоугольник. Далее мы будем заливать его разными цветами и узорами. Нажмите кнопку "Fill Tool" расположенную на панели инструментов Toolbox (Графика). Рядом с кнопкой появится вспомогательная панель с инструментами/ предназначенными для различной заливки объектов (Рис. 8.7).

Рис. 8.7. Вспомогательная панель для работы с заливками

Кнопка "No Fill" во вспомогательной панели инструментов убирает заливку объекта, делая внутреннюю область объекта прозрачной. Все остальные кнопки добавляют разнообразные заливки. Самой простой и распространенной является однородная заливка с помощью одного единственного цвета. Нажмите левую кнопку "Fountain Fill Dialog" во вспомогательной панели. На экране появится диалог настройки заливки Uniform Fill (Однородная заливка) (Рис. 8.8).

Рис. 8.8. Диалог Uniform Fill (Однородная заливка)

Для работы с этим диалогом следует понимать основы моделей цвета, о которых рассказывалось в начале нашей книги. В списке, расположенном в верхней части диалога, выбирается модель цвета. Для любой модели вы можете выбрать цвет, указав соотношение в нем базовых цветов. Давайте выберем цвет, введя значения в поля диалога. Выберите в списке Model (Модель) значение CMYK для работы с данной моделью представления цвета. Введите в поле С значение 20, в поле М значение 80, в поле Y значение 0, а в поле К значение 20. В поле New (Новый цвет) вы увидите образец выбранного цвета, а в поле Name (Имя) его название - Purple (Пурпурный). Выберите в списке Model (Модель) значение RGB. Теперь вы можете узнать соотношения цветов в этой модели для выбранного цвета: R - 152, G - 68 и В - 121. В CorelDRAW 10 имеется возможность поиска цвета по его названию. Введите в поле Name (Имя) слово forest green (моховой), и нужный цвет вы увидите в поле New (Новый цвет) Открыв список Name (Имя), вы увидите множество названий разнообразных цветов. Есть и другой способ получения требуемого оттенка цвета для однородной заливки. Перейдите на вкладку Mixers (Смесители диалога, щелкнув мышью на соответствующем ярлычке. Поля этой вкладки позволяют смешивать цвета для получение оттенков (Рис. 8.9). В зависимости от настроек, вкладка можт' иметь разный вид.

Рис. 8.9. Диалог смешивания цветов

В одном варианте (Рис. 8.9, справа) оттенки показаны в сетке и являются результатом смешения четырех заданных цветов, расположенных в полях по краям сетки. В другом варианте (Рис. 8.9, слева) оттенки для цветового круга выбираются из смешения нескольких цветов, взятых по самым разнообразным алгоритмам. Переключиться между вариантами можно, нажав кнопку Options (Параметры), во вспомогательном меню выбрав команду Mixers (Смесители) и один из вариантов: Color blend <(Цветовой переход) или Color harmonies (Гармоники цвета). Попробуйте поэкспериментировать с выбором цветов в полях диалога. Результат подбора цвета можно увидеть в поле New (Новый цвет). В диалоге Uniform Fill (Однородная заливка) вы также можете выбрать цвет из любой палитры, имеющейся в CorelDRAW 10. Чтобы перейти в режим работы со стандартными палитрами, перейдите на вкладку Palettes (Палитры). Содержимое диалога изменится (Рис. 8.10). Если вы создаете рисунки не для себя, а для производства, то вам необходимо думать о том, чтобы все цвета были стандартными. Имеется множество стандартных палитр, из которых можно выбрать практически любой цвет. Выберите в списке Type (Тип) название палитры PANTONE® Process Color System. Эта одна из стандартных палитр, поставляемых вместе с программой CorelDRAW 10. Щелкните мышью на любом цвете в появившейся палитре. Таким образом, вы можете установить любой стандартный цвет из выбранной палитры.

Рис. 8.10. Работа с палитрами

Как бы вы не выбрали цвет, нажмите кнопку ОК, диалог закроется, и прямоугольник будет залит выбранным цветом. Не обязательно вызывать диалог для настройки цвета заяивки. Можно для этой цели воспользоваться специальным закреплением. Нажмите кнопку "Color Docker Window" во вспомогательной панели инструмента "Fill Tool" и на экране появится закрепление для работы с цветом (Рис. 8.11). Конкретный вариант закрепления выбирается с помощью кнопок, расположенных справа сверху.

Рис. 8.11. Закрепление работы с цветом

При выборе цвета из палитры (Рис. 8.11) или из цветового квадрата (Рис. 8.11), использование закрепления не отличается от выбора цвета в диалоге, описанном выше. Если вам больше нравится устанавливать значения цветовых составляющих, выбрав предварительно одну из моделей цвета, вам покажется удобным установка соответствующих значений с помощью ползунков (Рис. 8.11). Цветные полосы, по которым передвигаются ползунки, меняют оттенок, в зависимости от выбранного цвета. Цвет этих полос помогает при установке нужного цвета для графического объекта. Если замок в кнопке, расположенной в нижней части закрепления, открыт то после установки нужного цвета следует нажать соответствующую кнопку. Кнопка Fill (Заливка) установит цвет заливки выделенного объекта, а кнопка Outline (Контур) цвет контура. Нажмите кнопку замок и рисунок на ней изменится на запертый замок . Теперь, если вы нажмете кнопку Fill (Заливка) или Outline (Контур), она останется нажатой. После этого вы можете менять цвет с помощью полей закрепления, и каждое изменение в любом поле будет менять цвет выделенного объекта. Этот прием удобен, когда вы хотите подобрать нужный оттенок, и желаете видеть изменение оттенков непосредственно в создаваемом рисунке. На практике вам вряд ли понадобится все многообразие возможностей работы с цветом. Чаще всего для однородной заливки достаточно просто щелкнуть мышью на цвете в палитре, расположенной в правой части окна редактора. Но иногда однородная заливка не обеспечивает необходимого эффекта, и объект заливается более сложными заливками.


8.3. Градиентная заливка

Красивого результата можно добиться, используя плавные переходы от одного цвета к другому. Такие переходы цвета в CorelDRAW 10 называются градиентными заливками. Имеется несколько вариантов градиентных заливок: линейная, радиальная, коническая и квадратная (Рис. 8.12). Познакомимся с ними на примере, залив созданный ранее прямоугольник.

Рис. 8.12. Различные варианты градиентных заливок

Нажмите кнопку "Fill Tool" и во вспомогательной панели нажмите кнопку "Fountain Fill Dialog". На экране появится диалог Fountain Fill (Градиентная заливка) (Рис. 8.13). В списке Type (Тип) вы можете выбрать необходимый вариант заливки. Выберите Square (Квадратная). Образец заливки в правой части диалога изменит свой вид. Подведите указатель мыши к образцу заливки в правом верхнем углу диалога. Указатель изменит свой вид на перекрестие. Нажмите кнопку мыши и, не отпуская ее, перетащите перекрестие ближе к правому нижнему углу образца, после чего отпустите кнопку мыши. Вы сместили центр градиентной заливки. Того же результата можно добиться путем ввода числовых значений в группу полей Center offset (Сдвиг центра).

Рис. 8.13. Диалог Fountain Fill (Градиентная заливка)

В поле Edge pad (Сдвиг края) введите значение 20 процентов. Теперь край рисунка будет закрашен не переходом цветов, а одним цветом. Переход начнется лишь на расстоянии от края, равном 20 процентам размера объекта. В поле Angle (угол) введите значение 45 градусов. Квадраты разных цветов, образующие градиентную заливку, теперь располагаются под углом 45 градусов. В поле образца вы можете увидеть, как изменился внешний вид градиентной заливки (Рис. 8.14). В группе полей Options (Параметры) имеется еще одно поле: Steps (Шагов), однако вы не можете поменять в нем значение, так как оно заблокировано. Давайте разблокируем его и изменим значение. Нажмите кнопку "Round Corner Together" расположенную правее поля. Теперь вы можете изменить содержимое поля. Введите значение 7 в поле Steps (Шагов). Теперь переход цветов заливки менее плавный и состоит всего из семи оттенков.

Рис. 8.14. Измененная заливка

Теперь изменим цвета, использующиеся в заливке. Для этого следует воспользоваться управляющими элементами, расположенными рядом с заголовками From (От) и То (К). Откройте список From (От). Рядом появится палитра, в которой вы можете выбрать цвет (Рис. 8.15).

Рис. 8.15. Вспомогательная палитра

Нажмите кнопку Others (Другие), и на экране появится диалог выбора цвета, не отличающийся от диалога Uniform Fill (Однородная заливка), описанного выше. Выберите модель цвета CMYK и установите значения базовых цветов С - О, М - 20, Y - 60, К - 20, после чего нажмите кнопку ОК. Диалог закроется, и в качестве начального цвета градиентной заливки будет выбран золотистый цвет. Откройте список То (К), и во вспомогательной политре выберите любой цвет . В поле Mid - Point выберите значение 25, нажмите кнопку залить, OK, диалог закроется.

Рис. 8.16 Удачный пример заливки.


8.4 Заливка с помощью узоров

Для использования в качестве узора произвольных растровых изображений переключатель следует установить в положение Bitmap (Растровый). С помощью полей дополнительной настройки заполнения вы можете существенно изменить внешний вид заливки, но мы не будем этим заниматься. Установите переключатель узора в положение 2-color (Двухцветный). Щелкните мышью на элементе с образцом двухцветного узора, и рядом с ним появится список доступных узоров (Рис. 8.16).

Рис. 8.16. Список узоров

Выберите в списке изображение кирпичной стены. Теперь этот узор вы видите в качестве образца заливки. Путем изменения значения полей группы Size (Размер) можно добиться наилучшего размера узора. Но узнать, какой размер лучше, можно после заливки объекта. Щелкните мышью списке с названием Back (Фоновый) и выберите красный кирпичный цвет во вспомогательной палитре. Теперь узор стал похож на кирпичную кладку. Вы можете изменить как фон, так и основной цвет узора. Нажмите кнопку ОК, и диалог закроется, а прямоугольник будет залит выбранным узором. Вы можете самостоятельно поэкспериментировать с различными видами узоров. Работа с полноцветными и растровыми узорами ничем не отличается от работы с заливкой двухцветным узором. Конечно, цветные рисунки в качестве узора смотрятся значительно красивее.


8.5. Заливка текстурой

Для заливки объектов CorelDRAW 10 предлагает так называемые процедурные текстуры. Это не что иное, как изображения, созданные с помощью специальных алгоритмов и генераторов специальных чисел. Такие изображения часто напоминают некоторые природные явления, такие, как облака, минералы, воду, вспышки света, или вообще имеют фантастический вид (Рис. 8.17).

Рис. 8.17. Примеры, текстур

Чтобы залить созданный ранее прямоугольник текстурой, нажмите кнопку "Fill Tool" и в появивщейся вспомогательной панели нажмите кнопку "Texture Fill Dialog" На экране появится диалог Texture Fill (Текстурная заливка) (Рис. 8.19). Из списка Texture library (Библиотека текстур) выберите Styles (Стили). Вместе с CorelDRAW 10 поставляется несколько библиотек текстур, которые содержат множество оригинальных процедурных текстур. В списке Texture list (Список текстур) выберите вариант Satellite Photography (Спутниковая съемка). В поле просмотра образца вы увидите рисунок, похожий на съемку земли с космического аппарата. Нажмите кнопку Preview (Просмотр), и рисунок изменится. Так как изображение генерируется с помощью случайных чисел, то, много раз нажимая кнопку Preview (Просмотр), вы будете получать каждый раз новые изображения.

Рис. 8.19. Диалог Texture Fill (Текстурная заливка)

Для каждой текстуры имеется множество параметров, которые можно изменять: набор используемых цветов, плотность, мягкость, контрастность, яркость, облачность, четкость и тому подобные. При этом каждая текстура обладает своим набором параметров. Если вы хотите, чтобы параметр автоматически менялся при каждом нажатии кнопки Preview (Просмотр), то следует нажать кнопку замок расположенную правее поля соответствующего параметра. Рисунок на кнопке изменится на открытый замок. При отжатой кнопке параметр не будет автоматически меняться. Измените параметры текстуры и проследите за изменениями образца. Не забывайте после изменения параметров нажимать кнопку Preview (Просмотр). Как только вы получите в поле предварительного просмотра подходящий вариант, нажмите кнопку ОК, диалог закроется, и выбранная текстура заполнит внутреннюю область выделенного объекта.


8.6. Дополнительные возможности заливки

Во вспомогательной панели инструмента "Fill Tool" есть еще кнопка, с помощью которой можно настроить так называемую PostScript заливку. Это заливка узором, разработанная с помощью специального языка PostScript. Некоторые заливки достаточно сложны, и для их прорисовки на экране потребуется значительное время. В некоторых режимах просмотра заливка PostScript не будет отображаться на экране. Нажмите кнопку "Fill Tool" и во вспомогательной панели нажмите кнопку "Post Script Fill Dialog". На экране появится диалог PostScript Texture (Текстура PostScript) (Рис. 8.20).

Рис. 8.20. Диалог настройки заливки PostScript текстурой

Выберите в списке заливку Honeycomb (Соты) и установите флажок Preview fill (Просмотр заливки). Вы увидите в поле предварительного просмотра вариант заливки (Рис. 8.21).

Рис. 8.21. Заливка в виде сот

В группе полей Parameters (Параметры) можно настроить параметры заливки, как и в случае с заливкой текстурой. Нажмите кнопку ОК, диалог закроется, и выбранная текстура заполнит внутреннюю область выделенного объекта.


9. Интерактивная заливка

Как отмечалось выше, последние версии CorelDRAW отличаются высокой степенью интерактивности. В них появились инструменты интерактивной работы с заливками. Хотя к этим инструментам нужно привыкнуть, при умелом использовании они существенно облегчат создание сложных заливок.

9.1. Основные инструменты интерактивной заливки

Выберите инструмент интерактивной заливки "Interactive Fill Tool" в панели инструментов Toolbox (Графика). В списке вариантов заливки, расположенном в левой части панели Property Bar (Панель свойств), выберите вариант Bitmap Pattern (Заливка растровым узором) чтобы работать с этим типом заливки. Большинство управляющих элементов панели Property Bar (Панель свойств) при использовании инструмента интерактивной заливки совпадают с элементами соответствующих диалогов настройки заливок. В списке, расположенном правее в панели Property Bar (Панель свойств), выберите рисунок плетеной деревянной поверхности. Выделенный прямоугольник будет залит выбранным узором. Кроме того, появятся управляющие вектора для настройки заливки (Рис. 9.1,).

Рис. 9.1. Редактирование интерактивной заливки

Точно так же с помощью управляющих элементов панели Property Bar (Панель свойств) и редактирования векторов заливки,можно залить градиентом, текстурой или PostScript -заливкой. Количество и расположение элементов различно для разных типов заливок. Можно залить объект и однородной заливкой, но в этом случае никакого вектора заливки нет. При работе с любым типом заливки вы можете нажать кнопку "Paintbacket Tool" панели Property Bar (Панель свойств) и отредактировать ее с помощью диалогов настройки заливок, описанных нами ранее. Попробуйте разные типы заливок и отредактируйте их, перетаскивая управляющие элементы. При работе с инструментом интерактивной заливки вы можете скопировать заливку из одного объекта в другой. Для этого выделите объект, заливку которого хотите изменить, после чего нажмите кнопку "Interactive Fill Tool" панели Property Bar (Панель свойств). Указатель мыши изменится на другой. Установите указатель мыши на объекте, заливку которого вы хотите использовать, после чего щелкните мышью. Заливка первого объекта изменится.


9.2. Использование ранее созданных заливок

Опишем еще один, чрезвычайно удобный и простой инструмент работы с цветом. Если вы удалили созданный ранее прямоугольник, создайте новый и залейте его узором из растрового изображения. Выберите инструмент "Eyedropper Tool" в панели инструментов Toolbox (Графика). Указатель мыши примет вид пипетки "Eyedropper Tool". Нажмите кнопку в панели Property Bar (Панель свойств). Щелкните мышью на местах с разными оттенками внутри прямоугольника, залитого узором. Цвет, выбираемый для заливки объектов, будет меняться в соответствии с цветом заливки в месте щелчка. Вы можете увидеть выбранный цвет в правой части строки состояния. Нажмите кнопку "Eyedropper Tool", и повторите процедуру выбора цвета. Теперь для заливки будет выбираться усредненный цвет нескольких точек в месте щелчка. При выборе кнопки "Eyedropper Tool" область для получения цвета будет еще больше. Если вы нажмете кнопку "Eyedropper Tool" то сможете самостоятельно выделить область, цвета из которой будут смешаны для получения цвета заливки. Установите указатель мыши в угле области, нажмите кнопку мыши, и, не отпуская ее, переместите указатель в противоположный угол области, после чего отпустите кнопку мыши. Все цвета, попавшие в указанную область, вне зависимости от того, к каким объектам они относятся, будут учтены при определении цвета заливки. Так можно определить не только однородную заливку, но и любую другую, а также получить цвет из контура. Нажмите кнопку "Eyedropper Tool" в панели Property Bar (Панель свойств). Установите указатель мыши внутри залитого узором объекта. Указатель примет другой вид. Щелкните мышью, и в панели инструментов вы увидите копию заливки объекта. Подведите указатель мыши к контуру объекта. Указатель изменится. Щелкните мышью и вы получите цвет, установленный для контура. Чтобы использовать полученную заливку, выберите инструмент "Interactive Fill Tool" во вспомогательной панели инструмента "Eyedroper Tool". Установите указатель мыши внутри любого объекта. Указатель изменится на "Paintbucket Tool" Щелкните мышью, и заливка объекта изменится на заливку, полученную с помощью пипетки. Установите указатель мыши на контуре объекта. Указатель изменится на "Paintbucket Tool". Щелчок мышью изменит цвет контура.


9.3. Настройка заливки объектов

Можно настроить заливку для вновь создаваемых объектов. Выберите инструмент "Pick Tool" и щелкните мышью на свободном месте, чтобы ни один объект не был выделен. Выберите инструмент интерактивной заливки "Interactive Fill Tool". В списке вариантов заливки, расположенном в левой части панели Property Bar (Панель свойств), выберите Texture Fill (Заливка текстурой). На экране появится диалог выбора категорий объектов (Рис. 9.2).

Рис. 9.2. Диалог выбора категорий объектов для заливки

В диалоге вы можете указать, какие вновь создаваемые объекты будут залиты текстурой: Graphic (Графика), Artistic Text (Фигурный текст) и Paragraph Text (Обычный текст). Кстати, аналогичный диалог появляется при попытке изменения любых параметров объектов, если ни один объект не выделен. С его помощью вы можете, например, установить толщину и цвет контура для вновь создаваемых объектов. Установите в диалоге все три флажка и нажмите кнопку ОК. Диалог закроется. Создайте несколько новых объектов. Все они будут залиты текстурой. Снова отмените выделение объектов и установите для вновь создаваемых объектов No Fill (Нет заливки).

Наверное, вы обратили внимание, что при некоторых операциях на экране появляется закрепление для работы со стилями цветов (Рис. 9.3). Если у вас на экране не видно этого закрепления, выберите команду меню Window Dockers Color Styles (Окно Закрепления Стили цветов), и закрепление будет открыто.

Рис. 9.3. Стили цветов

В список, расположенный в закреплении, попадают все цвета, использованные вами в документе. Дважды щелкнув на любом цвете из списка, вы измените заливку выделенного объекта. С помощью кнопок, расположенных в верхней части закрепления, можно изменить цвета в списке. Использование цветовых стилей поможет создавать, иллюстрации, оформленные в едином цветовом решении. Надо только добавить нужные цвета в список, после чего использовать исключительно цвета из списка.


9.4. Сетчатая заливка

Рассмотрим еще один, чрезвычайно оригинальный, способ заливки. Создайте эллипс на свободном месте рабочей области. Выберите инструмент "Interactive Mesh Fill Tool" во вспомогательной панели инструмента "Interactive Fill Tool"'. Этот инструмент предназначен для создания сетчатых заливок. Внутри эллипса появится сетка предназначенная для настройки заливки. Установите в полях панели Property Bar (Панель свойств) количество вертикальных и горизонтальных ячеек сетки: 3 и 4. Двенадцать ячеек сетки (три на четыре) будут расположены внутри нашего эллипса (Рис. 9.4,). Сетку можно редактировать так же, как и любой объект CorelDRAW 10. Вы можете удалять и добавлять узлы/ изменять их местоположение и настраивать манипуляторы кривизны. Отредактируйте узлы сетки, чтобы получить примерно такой результат (Рис. 9.4,). Обратите внимание, что мы удалили несколько узлов. Теперь назначим цвета разным ячейкам сетки.

Рис. 9.4. Сетчатая заливка

Установите указатель мыши на зеленом цвете в палитре, нажмите кнопку мыши и, не отпуская ее, переместите указатель в центр одной из ячеек, после чего отпустите кнопку мыши. Ячейка будет закрашена выбранным цветом. Аналогично перетащите мышью желтый цвет из палитры в соседнюю ячейку. На месте границы между ячейками появится переход цветов (Рис. 9.5).

Рис. 9.5. Цвет в сетчатой заливке

 Нажмите клавишу Shift и, не отпуская ее, щелкните мышью последовательно на всех узлах сетки, расположенных по контуру эллипса, после чего отпустите клавишу. Мы выделили все периферийные узлы. Нажмите клавишу Ctrl и, не отпуская ее, щелкните несколько раз на синем цвете в палитре. С каждым щелчком область рядом с выделенными узлами будет приобретать все более густой синий оттенок. Отпустите клавишу Ctrl. Выделяя различные узлы, вы можете добавлять в заливку разнообразные оттенки. Удалите контур эллипса, и мы получим объект с оригинальной и нестандартной заливкой (Рис. 9.5,). На этом закончим с рассмотрением всевозможных заливок. В дальнейшем мы научимся использовать заготовки, созданные профессиональными художниками, в наших иллюстрациях.


10. Вставка готовых рисунков

Существенно ускорить разработку иллюстраций можно с помощью готовых рисунков, созданных профессиональными художниками. Множество таких рисунков поставляется вместе с CorelDRAW 10. Вы можете использовать как простейшие рисунки, так и достаточно сложные высокохудожественные работы.

10.1. Использование библиотеки графических символов

Библиотека символов представляет собой собрание большого количества профессионально нарисованных символов, охватывающих такие различные темы, как бизнес, окружающая среда, наука, транспорт и прочие. После вставки символов в документ CorelDRAW 10 вы можете их редактировать подобно любому другому объекту. Выберите команду меню Tools Symbols and Special Characters (Инструменты Символы и специальные знаки) и на экране появится закрепление Symbols and Special Characters (Символы и специальные знаки) (Рис. 10.1).

Рис. 10.1. Закрепление Symbols and Special Characters (Символы, и специальные знаки)

В списке, расположенном в верхней части закрепления, выберите библиотеку Webdings. Эта библиотека поставляется вместе с Windows и должна присутствовать на вашем компьютере. Библиотеки символов - это шрифты. Как Windows, так и CORELDRAW 10 устанавливает множество шрифтов с полезными рисунками. Перетащите мышью изображение пожарной машины из закрепления на свободное место рабочей области, и новый выделенный объект готов для редактирования.

Щелкните мышью на черном цвете в палитре, чтобы залить этим цветом объект. Символ вставлен в наш рисунок, и далее вы можете работать с ним, как с любым другим объектом. Вы можете менять его форму, добавлять и удалять заливку, а также редактировать контур объекта. Кроме вставки единственного символа вы можете создать мозаику из выбранного рисунка.

Удалите только что вставленный объект. Откройте вспомогательное меню с помощью кнопки далее закрепления Symbols and Special Characters (Символы и специальные знаки) и выберите команду Tile symbol/Special character (Мозаика из символов/специальных знаков). В списке, расположенном в верхней части закрепления, выберите библиотеку Wingdings.

В поле Symbol Size (Размер символов) вы можете задать размер символов, а выбрав во вспомогательном меню кнопки далее команду Tile Options (Параметры мозаики), вы можете в появившемся диалоге настроить параметры создаваемого узора. Проделайте это самостоятельно, а мы продолжим дальше.


10.2. Работа с заготовками

Вместе с пакетом программ CorelDRAW 10 поставляется набор из множества готовых рисунков, которые вы можете использовать при создании собственных иллюстраций. Кроме того, на рынке имеется множество наборов рисунков, предлагаемых различными фирмами. Работа с графическим редактором значительно упрощается при использовании заготовок, созданных ранее профессиональными художниками. Заготовки называются ClipArt, и ниже мы рассмотрим их использование. Для выполнения примера вам понадобится компакт - диск с заготовками, входящий в комплект поставки CorelDRAW 10, или любой другой набор заготовок. Вставьте компакт - диск с заготовками в устройство чтения компакт - дисков. Выберите команду меню Tools Scrapbook Browse (Инструменты Библиотека заготовок Просмотр). В правой части окна программы появится закрепление Scrapbook (Библиотека заготовок). Щелкните мышью на значке "Cliper" с именем CD 10 ClipArt, и редактор перейдет к работе с набором векторных заготовок. Если в дисководе компакт - дисков нет диска с векторными заготовками, который поставляется в комплекте CorelDRAW 10, вам будет выдано соответствующее сообщение .

Для работы с заготовками, поставляемыми вместе с пакетом CorelDRAW 10, вставьте требуемый компакт-диск и нажмите кнопку ОК. Если же вы хотите работать с другими заготовками, нажмите кнопку Cancel (Отмена) и перейдите в папку, в которой находятся нужные заготовки. В любом случае, в появившемся закреплении Scrapbook (Библиотека заготовок) вы можете выбрать папку с интересующими вас заготовками. Рисунки, помещенные в каждую палку, вы можете просмотреть в свитке, не загружая их в редактируемое изображение. Чтобы поместить в рабочую область нужную заготовку, следует выполнить ряд действий. Установите указатель мыши на выбранном вами рисунке. Нажмите и не отпускайте левую кнопку мыши. Оставляя нажатой левую кнопку мыши, переместите указатель мыши на рабочую область редактируемого документа. Отпустите кнопку мыши, и выбранная вами заготовка будет вставлена на заданное место. Так как закрепление осталось открытым, вы можете аналогично вставить еще нужное количество рисунков.

Рис. 10.2. Закрепление Scrapbook (Библиотека заготовок)

Если вы дважды щелкните мышью на любой заготовке, то выбранная вами заготовка будет помещена во вновь созданный документ. Нажав кнопку рядом с кнопкой открытия файла расположенную в верхней части закрепления вы можете получить рисунки из Интернета, конечно, если вы к нему подключены. Кнопками, расположенными над списком рисунков в закреплении можно менять внешний вид этого списка. Сверните или закройте все закрепления, чтобы они не занимали место на экране.

Примерно так же, как и с векторными заготовками, следует работать с другими видами заготовок. Следует только выбрать иной значок после в начале работы с закреплением, и будет открыта другая библиотека.


10.3. Импорт и экспорт рисунков

В редакторе CorelDRAW 10 имеется возможность использовать готовые рисунки самых разных графических форматов. Для их размещения в документе используется операция импорта. Нажмите кнопку "Import" в панели Standard (Основная), и на экране появится диалог Import (Импорт) (Рис. 10.6), похожий на любой диалог открытия файла в Windows.

Рис. 10.3. Диалог Import (Импорт)

Установите флажок Preview (Просмотр), чтобы иметь возможность предварительного просмотра выбранных заготовок. В списке Files of type (Тип файлов) выберите All File Formats (Все форматы файлов), чтобы вы могли вставить рисунок любого формата. Используйте для опыта любые рисунки, имеющиеся у вас. Выберите папку, в которой содержатся заготовки. Щелкните мышью на названии рисунка. В поле предварительного просмотра вы увидите его/ а в поле File format (Формат файла) - тип выбранного рисунка. Нажмите кнопку Import (Импорт), диалог закроется, и указатель мыши изменится на Рисунок1.bmp, причем в указателе будет имя вставляемого файла. Если щелкнуть мышью в документе, рисунок будет вставлен в месте щелчка, при этом сохранив исходные размеры. Однако вы можете изменить размеры вставляемого изображения. Подведите указатель мыши к верхнему левому углу области, куда вы хотите вставить рисунок, нажмите и не отпускайте клавишу мыши. Начните передвигать мышь, указатель изменится наРисунок1.bmp и на экране появится пунктирная рамка, отмечающая место вставки иллюстрации. Как только пунктирная рамка совпадет с местом, куда вы хотите вставить рисунок, отпустите кнопку мыши, и выбранный рисунок будет вставлен в ваш документ. Вы можете далее преобразовывать рисунок, как любой объект CorelDRAW 10. Правда, если в качестве заготовки вы выбрали рисунок растровой графики, то вы не сможете выполнить на нем операции обработки векторной графики. Мы советуем вам использовать готовые рисунки при создании собственных иллюстраций. Это значительно ускорит процесс их создания и повысит их качество. Иногда может возникнуть потребность сохранения изображения, созданного с помощью графического редактора CorelDRAW 10, в файле другого графического формата. Наиболее часто сохраняются изображения в каком-либо формате растровой графики. Такая операция называется экспортом изображения. Нажмите кнопку "Export" панели инструментов Standard (Основная). На экране появится диалог Export (Экспорт), похожий на диалог сохранения файла. В нем вы должны ввести имя файла и выбрать место, где хотите его сохранить. Важной операцией при работе с диалогом Export (Экспорт) является выбор формата файла, в котором будет сохранен рисунок. Вы должны выбрать в открывающемся списке Files of type (Тип файла) один из графических форматов, который поддерживается CorelDRAW 10. Для некоторых форматов, поддерживающихсжатие информации, можно установить вид сжатия в поле Compression type (Тип сжатия)

Рис. 10.4. Диалог Export (Экспорт)

Если вы установите флажок Selected only (Выделенные объекты), то в файл будут экспортированы не все объекты изображения/ а только те, которые были выделены перед нажатием кнопки "Export" При установленном флажке Do not show filter dialog (He выводить окно фильтра) изображение будет экспортировано с параметрами, которые применялись при последнем экспорте. Диалог изменения параметров не появится. Выберите папку, в которой вы хотите сохранить файл, и введите имя создаваемого файла в поле File Name (Имя файла). Убедитесь, что флажок Do not show filter dialog (He выводить окно фильтра) не установлен, чтобы иметь возможность изменения параметров преобразования вашего изображения в выбранный графический формат. Выберите в списке Files of type (Тип файла) вариант JPG — JPEG Bitmaps, чтобы сохранить файл в этом формате. При выборе этого формата качество рисунка несколько ухудшится, но зато файл займет меньше места на диске. Нажмите кнопку Export (Экспорт) и на экране появится диалог настройки экспорта, рисунка в графический файл (Рис. 10.5). Он несколько различается для экспорта в разные графические форматы. Рассмотрим наиболее типичный диалог.

Рис. 10.5. Диалог настройки экспорта изображения

В группе полей Color (Цвет) вы устанавливаете количество цветов, которое будет получено в результате преобразования. Понятно, что при большем количестве цветов качество рисунка увеличивается, но также растет и размер файла. Если вы выберете рисунок с малым количеством цветов, до двухсот пятидесяти шести, то станет доступным поле Dithered (Смешанный). Если установить флажок в этом поле, цвет, который отсутствует в палитре, будет достигаться смешением нескольких имеющихся цветов. То есть, вместо точек одного цвета в итоговом рисунке на том же месте могут быть несколько разноцветных точек.

В группе полей Size (Размер) вы устанавливаете размер итогового рисунка в точках. Если вы выберите размер Custom (Специальный), то с помощью полей Width (Ширина) и Height (Высота) вы можете задать конкретные размеры. Кнопка замок заставляет сохранять пропорции исходного изображения, а если на кнопке рисунок замок то вы можете менять произвольно ширину и высоту. Переключение вариантов выполняется нажатием кнопки.

В группе полей Resolution (Разрешение) задается разрешение рисунка в точках на дюйм. Если вы выберите в качестве разрешения< Custom (Специальное), то с помощью полей Horizontal (По горизонтали) и Vertical (По вертикали) вы можете задать нестандартное разрешение. Кнопка делает вертикальное и горизонтальное разрешение идентичными, а кнопка замок позволяет использовать разное разрешение по вертикали и горизонтали. Флажок Anti-aliasing (Сглаживание) предназначен для создания более гладких изображений путем удаления изломов из исходного рисунка. Флажок Transparent Background (Прозрачный фон) создает прозрачный фон рисунка, но это доступно не для всех форматов файлов. Ожидаемый размер файла при установленных параметрах без учета сжатия будет показан в нижней части диалога. Если выбранный формат поддерживает сжатие, то реальный размер полученного файла будет значительно меньше.

Установите параметры сохранения рисунка, которые вас наиболее удовлетворяют. Нажмите кнопку ОК. В некоторых случаях сразу будет создан графический файл в соответствии с выбранными вами параметрами. Для некоторых форматов, например для JPEG, потребуется дополнительная настройка. На экране появится диалог, в котором вам предлагается определить дополнительные параметры сохраняемого файла.

Для данного формата графических файлов требуется задать степень сжатия в поле Compression (Сжатие) и некоторые дополнительные параметры. Нажав кнопку Preview (Просмотр), вы сможете увидеть потери качества изображения при выбранных параметрах. Для иных форматов графических файлов потребуются другие настройки. При настройке параметров нужно найти оптимальное соответствие между качеством рисунка и объемом графического файла. Установив нужные параметры, нажмите кнопку ОК, чтобы закрыть диалог и создать новый файл с экспортированным изображением.

Рис. 10.6. Настройка дополнительных параметров экспорта

Экспортированные таким образцом изображения можно дальше обрабатывать любым другим редактором растровой графика После обработки можно импортировать результат в CorelDRAV 10. Таким способом можно применить к частям иллюстрации оригинальные эффекты, реализованные в других программах.


10.4. Получение изображений со сканера и цифровой фотокамеры

В CorelDRAW 10 вы можете вставить в графический документ растровый рисунок, получив его непосредственно со сканера или из цифровой фотокамеры. Конечно, данные устройства должны быть подключены к компьютеру и установлены Windows. Если на вашем компьютере установлено несколько фотокамер сканеров, сначала следует выбрать, с каким сканером или какой камерой вы хотите работать. Выберите команду меню File Acquire Image Select Source (Файл Получть изображение Выбрать источник). На экране появится диалог выбора устройства для получения изображения (Рис. 10.7).

Рис. 10.7. Выбор устройства получения изображений

Выберите нужное устройство, дважды щелкнув на нем мышью Диалог закроется и вы можете приступать к получению рисунка. Выберите команду меню File Acquire Image Acquire (Файл Получить изображение Получить).

Рис. 10.8. Пример диалога сканирования

На экране появится диалог работы с выбранным устройством. При работе со сканером, скорее всего, сначала необходимо выполнить предварительное сканирование и выделить область, которую вы хотите получить в качестве растрового рисунка. Далее устанавливается нужное качество рисунка и производится сканирование. По окончании сканирования диалог закроется, и рисунок будет вставлен в редактируемый графический документ.

Если вы работаете с цифровой фотокамерой, принцип работы будет немного иным. В диалоге работы с устройством вы можете выполнить некоторые настройки камеры, а также просмотреть снятые ранее фотографии. В некоторых случаях можно сфотографировать непосредственно во время работы с диалогом. Выбрав интересующие вас снимки, запустите процесс передачи снимка, и через некоторое время снимки будут получены и вставлены в редактируемый документ. Рисунки, полученные со сканера или с цифровой фотокамеры, ничем не отличаются от других растровых обектов, полученных иным путем. Вы можете редактировать их в редакторе CorelDRAW 10.


11. Профессиональная работа с текстом

Как уже отмечалось, по возможностям работы с текстом CorelDRAW 10 не уступает многим текстовым редакторам. Однако дополнительно вы можете выполнять сложное оформление текста и создавать оригинальные рисунки из символов. Дополнительные возможности форматирования текста помогут создать документ любой сложности.

11.1. Форматирование и редактирование текста

Хотя удобнее редактировать текст непосредственно в графическом документе, иногда это бывает достаточно сложно выполнить. Если вы применили к тексту некоторые эффекты, отредактировать его можно в специальном диалоге. Выделив текстовый объект и нажав кнопку "Edit Text" панели Property Bar (Панель свойств), вы откроете диалог редактирования текста (Рис. 11.1). Работа в этом диалоге не отличается от работы с простым текстовым редактором.

Рис. 11.1. Диалог редактирования текста

Вводите и редактируйте текст, выделяйте фрагменты и меняйте их форматирование с помощью кнопок, расположенных в верхней части диалога. Вы можете вставить текст из документа, созданного текстовым редактором. Нажмите кнопку Insert (Вставка) и на экране появится диалог открытия файла. В нем вы можете выбрать файл в формате одного из распространенных текстовых редакторов. В результате ваш файл будет вставлен в редактируемый текстовый объект. Закончив редактирование и форматирование текста, нажмите кнопку ОК в диалоге, чтобы вернуться в основной режим работы с графическим документом. Как уже отмечалось, проще всего выполнять форматирование текста с помощью панели Property Bar (Панель свойств), которая при работе с текстом содержит кнопки форматирования. Дополнительные возможности по форматированию текста можно получить в специальном диалоге (Рис. 11.2), который вызывается с помощью кнопки "Format Text" панели Property Bar (Панель свойств). Этот диалог содержит несколько вкладок, позволяющих настроить форматирование символов и абзацев, установить табуляцию и размеры колонок текста, а также применить некоторые текстовые эффекты.

Рис. 11.2. Форматирование символов

Если кнопка замок в нижней части диалога нажата, и на ней нарисован закрытый замок, то изменения форматирования вступят в силу сразу после ввода значений в поля диалога. Отжав кнопку замок, вы измените рисунок на ней. Теперь замок открыт. В этом случае следует нажать кнопку Apply (Применить) после изменения форматирования, чтобы изменения вступили в силу. Вы можете изменить форматирование нескольких объектов, выделяя их и настраивая различное форматирование. При этом диалог остается открытым. Чтобы закрыть диалог, следует нажать кнопку ОК. На первой вкладке диалога настраивается форматирование символов (Рис. 11.2). На этой вкладке можно выбрать шрифт, его размер и начертание, а также используемый языковой профиль. Поля в правой части диалога позволяют использовать более оригинальные способы форматирования. В списках Underline (Подчеркивание), Sinkethru (Зачеркивание) и Over-line (Надчеркивание) выбирается тип линий для расположения под текстом, по тексту или над текстом соответственно. Доступно использование тонких и толстых, одинарных и двойных линий. Подчеркнуть можно как весь текст, включая пробелы, так и только слова. Вы можете использовать несколько линий одновременно, например, расположив тонкую двойную линию под текстом и одинарную толстую - над текстом. Нажав кнопку, расположенную правее любого списка, вы можете настроить толщину и расположение линий. В списке Uppercase (Регистр) можно установить малые прописные или все прописные буквы. В списке Position (Позиция) выбирается верхний и нижний индекс. Эти возможности есть и в текстовых редакторах. В нижней части диалога расположены поля, с помощью которых можно выполнить форматирование, недоступное текстовым редакторам. Чтобы эти поля стали доступными, следует выделить один или несколько символов в тексте. Далее вы можете задать вертикальное и горизонтальное смещение, а также угол поворота для выделенных символов. С помощью поворота и смещения отдельных символов, а также при использовании подчеркивания и надчеркивания одновременно, вы можете получить необычное форматирование текста, которое возможно только в CorelDRAW 10 (Рис. 11.3)

Рис. 11.3. Пример форматирования отдельных символов

На второй вкладке диалога настраивается форматирование абзацев (Рис. 11.4). Некоторые поля доступны только при форматировании обычного текста. Например, вы не можете установить отступы для фигурного текста.

Рис. 11.4. Форматирование абзацев

В списке Alignment (Выравнивание) выбирается один из способов выравнивания. Некоторые варианты выравнивания допускают дополнительную настройку. Диалог настройки вызывается расположенной рядом кнопкой Settings (Установки). Нажав кнопку Hyphenation Settings (Установки переносов), вы можете в появившемся диалоге настроить расстановку автоматических переносов слов. В группе полей Spacing (Интервалы) задаются интервалы между соседними символами, между словами и строками, а также до и после абзаца. В группе полей Indents (Отступы) задаются отступы справа и слева. Задав отступ первой строки, вы получите эффект красной строки. Все эти отступы и интервалы позволяют оформить большие фрагменты текста не хуже, чем в мощном текстовом редакторе. На следующей вкладке диалога расставляются позиции табуляции (Рис. 11.5). Вы можете добавить, удалить табулятор. Также можно изменить положение любого табулятора. С помощью удобно расположенных позиций табуляции легко создавать большие списки.

Рис. 11.5. Настройка табуляции

Обычный текст в CorelDRAW 10 можно расположить в несколько колонок. Текст в нескольких колонках обычно используется в газетах и журналах. Если вы хотите создать с помощью CorelDRAW 10 иллюстрированную брошюру, вам понадобится эта возможность редактора. Настроить количество и ширину колонок можно на следующей вкладке диалога форматирования (Рис. 11.6).

Рис. 11.6. Настройка колонок текста

В поле Number of columns (Количество колонок) задается количество колонок в тексте. Если вы установите флажок Equal column width (Равная ширина колонок), то будут созданы колонки равной ширины, убрав флажок, вы сможете задать разную ширину для различных колонок. Ширина устанавливается в полях, расположенных в центре диалога. В правой части диалога расположен рисунок, показывающий примерный вид текста, расположенного в несколько колонок. В списке Vertical justification (Вертикальное выравнивание) задается вертикальное выравнивание обычного текста относительно рамки. Оно не зависит от количества колонок. Особо следует отметить полное выравнивание, при котором рамка заполняется текстом от начала до конца. Это достигается увеличением межстрочных интервалов. Если у вас слишком мало текста и много пустого места, не рекомендуется выравнивать его таким способом. На последней вкладке диалога настройки форматирования текста настраиваются эффекты буквицы и маркированного списка (Рис. 11.7). Выбрать нужный эффект можно в списке, расположенном в верхней части диалога.

Рис. 11.7. Буквица и маркированные списки

Выбрав эффект буквицы, вы можете задать количество строк, занимаемых заглавной буквой в начале абзаца. Кроме того, задается расстояние буквы от остального текста. Также можно выбрать один из двух вариантов эффекта. Они проиллюстрированы рисунками в правой нижней части диалога. Если вы выбрали использование маркированного списка, то в поле Font (Шрифт) должны выбрать шрифт, а в поле Symbol (Символ) - конкретный символ для использования в качестве маркера. В остальных полях задается размер символа, его смещение и расстояние до основного текста. Кроме того, можно выбрать один из двух вариантов маркированных списков, представленных поясняющими рисунками в правой нижней части диалога. Описанные возможностей форматирования и редактирования не отличаются оригинальностью. Их можно найти в большинстве текстовых редакторов. В CorelDRAW 10 есть и другие средства работы с текстом, например проверка правописания. Неверные слова при вводе подчеркиваются красной волнистой линией. Также работает в CorelDRAW 10 и средство автозамены. Вы без труда освоите средства работы с текстом, если знакомы хотя бы с одним текстовым редактором. А мы продолжим изучение возможностей, присущих исключительно графическому редактору CorelDRAW 10.


11.2. Размещение текста вдоль кривой

Графический редактор CorelDRAW 10 позволяет разместить фигурный текст по любой заданной кривой - прямой или кривой линии, прямоугольнику, эллипсу, звезде, многоугольнику, другой букве или текстовой строке. Разместить вдоль кривой можно только текст, состоящий из одной строки. Если вы попытаетесь разместить текст, состоящий из нескольких строк, все переводы строк будут удалены. С помощью инструмента "Ellipse Tool" создайте эллипс. Выберите инструмент "Text Tool" в панели инструментов Toolbox (Графика). Подведите указатель мыши к верхней точке контура эллипса. При этом указатель изменит свой вид. Щелкните мышью, и над контуром эллипса появится текстовый курсор. Теперь вы можете вводить фигурный текст. Выберите в списке шрифтов панели Property Bar (Панель свойств) шрифт Arial, или другой шрифт, поддерживающий русские буквы. Введите несколько слов. Текст автоматически будет располагаться вдоль контура эллипса (Рис. 11.8).

Рис. 11.8. Текст, размещенной вдоль эллипса

Если же вам надо разместить уже существующий текст вдоль кривой, то следует воспользоваться несколько иной методикой. Нарисуйте еще один эллипс и создайте на свободном месте строку фигурного текста. Выделите созданные эллипс и фигурный текст с помощью инструмента "Pick Tool". Выберите команду меню Text Fill Text to Path (Текст Текст вдоль кривой). Текст будет расположен вдоль кривой, как и в предыдущем случае. Вне зависимости от способа размещения текста вдоль кривой, вы можете редактировать и форматировать его, как и любой другой текстовый объект. Также вы можете менять размещение текста относительно кривой с помощью элементов управления панели Property Bar (Панель свойств). Рассмотрим более подробно эти элементы. В первом слева списке панели Property Ваг (Панель свойств) можно выбрать одну из заготовок, которая описывает множество параметров расположения текста. Выбрав заготовку, вы сильно измените внешний вид текста. Остальные поля позволяют настроить внешний вид текста вручную. Во втором списке панели Property Bar (Панель свойств) расположены варианты ориентации букв по отношению к кривой. Рисунки в списке поясняют каждый вариант: "Text Orientation" вращает буквы по ходу кривой, "Text Orientation" вертикально сдвигает текст на искривленной части кривой. Сдвиг увеличивается вместе с наклоном кривой. Вариант "Text Orientation" горизонтально сдвигает текст на искривленной части кривой. Вариант "Text Orientation" сохраняет символы вертикальными, пока текстовая строка следует по кривой. В третьем списке определяется вертикальное размещение текста по отношению к кривой. Рисунки вариантов понятны без комментариев: "Vertical Plasiment". Еще один вариант позволяет вручную перемещать текст перпендикулярно кривой. Список с элементами "Text Placiment" появляется в панели Property Bar (Панель свойств), когда вы размещаете текст по замкнутым кривым. С помощью этого списка вы можете определить место замкнутого контура/ в котором будет располагаться текст. Чтобы разместить текст на противоположной стороне кривой с сохранением всех других установок/ следует нажать кнопку "Place On Other Side". Попробуйте изменить размещение текста с помощью управляющих элементов панели Property Bar (Панель свойств) (Рис. 11.9).

Рис. 11.9. Варианты размещения текста вдоль эллипса

Рис. 11.10. Перемещение текста

Вы можете также перемещать текст в направлении, перпендикулярном кривой, в интерактивном режиме следующим образом. Выделите с помощью инструмента "Pick Tool" текстовый объект, который был размещен по кривой. Так как текст уже связан с кривой, вы должны нажать клавишу Ctrl, а затем, не отпуская клавишу, щелкнуть мышью на текстовом объекте, чтобы его выделить. Подведите указатель мыши к перекрестию, которое расположено в центре объекта. Указатель изменится на другой. Нажав и удерживая левую кнопку мыши, перемещайте указатель мыши вверх. Появится соединяющая линия, один конец которой установлен на кривой, а другой связан с текстом. Эта линия позволяет устанавливать расстояние, на котором текст будет расположен от кривой. Вы можете перемещать текст в нужное место над или под кривой. Если вы остановите перемещение мыши и при этом не отпустите левую кнопку, то на месте конца соединительной линии появится точная копия кривой с текстом. Эта копия представляет собой опорную линию текста и показывает, в каком месте будет размещен текст относительно кривой (Рис. 11.10). Отпустите кнопку мыши, и текст займет новое положение. Перемещать текст также можно, устанавливая цифровые значения в полях, расположенных в правой части панели Property Bar (Панель свойств). Выберите инструмент "Pick Tool" нажмите клавишу Shift, и, не отпуская ее, щелкните на контуре эллипса. Вы снова выделили два объекта и можете продолжить эксперименты с размещением текста. Теперь мы отделим текст от эллипса. Выберите команду меню Arrange Break Text Apart (Монтаж/Отделить текст). Хотя внешне ничего не изменилось, текст теперь не связан с эллипсом. Выделите только текст. Для этого щелкните мышью на пустом месте, чтобы снять выделение, а затем щелкните мышью на тексте. Выберите команду меню Text Straighten Text (Текст/ Вьпрямить текст), и текст снова примет свой первоначальный вид. С помощью инструмента "Frehand Tool" нарисуйте произвольную незамкнутую кривую. Выделите нарисованную кривую и фигурный текст и выберите команду меню Text Fill Text to Path (Текст вдоль кривой). Теперь текст размещен вдоль разомкнутой кривой и в третьем списке панели Property Bar (Панель свойств) можно выбрать положение текста относительно кривой. Вы можете разместить текст по началу кривой по центру или в конце кривой линии. Выберите в третьем списке панели Property Bar (Панель свойств) различные варианты. Выравнивание текста будет меняться в соответствии с вашим выбором. Если вы измените форму кривой, по которой размещен текст, то текст автоматически будет менять свое положение. Выберите инструмент "Shape Tool" и измените форму кривой. По окончании изменений текст автоматически расположится вдоль новой кривой. С помощью инструмента "Pick Tool" выделите текст и кривую. Выберите команду меню Arranged Break Text Apart (Монтаж Отделитъ текст). Теперь текст и кривая не связаны. Выделите только кривую и удалите ее. Внешний вид текста остался неизменным, хотя кривая, по которой он был размещен, отсутствует. Далее мы продолжим преобразования фигурного текста.


11.3. Изменение расположения символов текста

С помощью инструмента "Shape Tool" вы можете изменить расстояние между соседними символами. Эта операция называется кернингом. Кернинг можно применять как к обычному, так и к фигурному тексту. Кернинг перемещает соседние символы ближе или дальше друг от друга. Создайте объект фигурного текста. Чтобы выделить символы для кернинга, выберите инструмент "Shape Tool". Вы заметите, что рядом с каждым символом появятся маленькие контурные квадратики или узлы (Рис. 11.11). Чтобы выделить символы, которые вы хотите подвинуть, надо выделить эти узлы. Стрелки управления, также используются для регулировки интервалов.

Рис. 11.11. Изменение размещения символов фигурного текста

Установите указатель мыши на узле, находящемся слева от символа, который вы хотите переместить, а дальше, нажимая и

удерживая левую кнопку мыши, переместите указатель мыши на новую позицию. Вместе с указателем мыши будут сдвинуты и символы (Рис. 11.11,). Вы можете выделить несколько узлов и передвинуть их вместе. Чтобы выполнить кернинг строки текста с помощью стрелок управления, перетащите с помощью мыши соответствующую стрелку. При использовании стрелки будет изменяться расстояние между всеми символами текста, а при использовании стрелки, они будет меняться расстояние между строками. Редактирование узлов текстового объекта с помощью инструмента "Shape Tool" похоже на работу с узлами других типов объектов, и вы можете применять приемы, описанные нами ранее. Выберите инструмент "Pick Tool". Текстовый объект будет выделен. Выберите команду меню Text/Straighten Text (Текст/Выпрямить текст). Текст примет свой первоначальный вид. Похожая команда Text Align/To Baseline (Текст/Выровнять по опорной линии) только выравнивает текст по опорной линии, то есть отменяет все вертикальные смещения символов. Опорной линией называется воображаемая линия, по которой выравниваются все символы в строке текста. Команда Text/Straighten Text (Текст/Вьпрямитъ текст), кроме того, отменяет горизонтальные смещения и повороты отдельных символов. На этом мы закончим работу с фигурным текстом и перейдем к экспериментам с обычным текстом.


12. Создание рисунков для Интернета

Любой созданный с помощью CorelDRAW 10 рисунок вы можете экспортировать в формат, принятый в Интернете. Чаще используются форматы графических файлов JPEG и GIF, несколько реже PNG. Однако есть несколько дополнительных средств, облегчающих создание иллюстраций для Интернета. Кроме того, CorelDRAW 10 может не только экспортировать рисунки, но и создать текст документа для использования в Интернете, сгенерировав код на языке HTML.

Однако в большинстве случаев удобнее воспользоваться другими средствами создания WWW - страниц, используя графический редактор CorelDRAW 10 для вспомогательной работы и для создания рисунков. Поэтому создание документов для Интерната будет рассмотрено в этой книге не слишком подробно.

12.1. Вставка объектов Интернета

Кроме рисунков и текста на WWW - страницах часто располагаются специальные объекты: списки/ кнопки, поля ввода и прочие объекты. Редактор CorelDRAW 10 позволяет вставлять все эти объекты. Выберите команду меню Edit Insert Internet Object (Правка Вставить объект Интернета) и выберите в появившемся меню нужный вам объект. Например, выбрав команду Submit Button (Кнопка подтверждения) и щелкнув мышью в нужном месте экране, вы вставите в документ кнопку (Рис. 12.1).

Рис. 12.1. Кнопка подтверждения

С помощью полей панели Property Bar (Панель свойств) можно изменить параметры Интернет - объектов. Например, введя в поле Value (Значение) любое слово, вы измените текст на кнопке. Для умелого использования объектов Интернета требуется опыт создания гипертекстовых документов, но для создания простой страницы, содержащей только рисунки и текст, никаких специальных знаний не надо.

Чтобы добавить в создаваемый документ ссылку, выделите текст или рисунок, который должен указывать на другую страницу, и щелкните на нем правой кнопкой мыши. В появившемся контекстном меню выберите команду Properties (Свойства), чтобы открыть закрепление работы со свойствами объектов. В этом закреплении перейдите на вкладку гиперссылок, щелкнув мышью на ярлычке "Internet". В закреплении появятся поля для ввода адреса ссылки (Рис. 12.2).

Рис. 12.2. Добавление гиперссьики

Введите в поле URL адрес, на который должна указывать ссылка. В остальных полях устанавливаются некоторые дополнительные характеристики гиперссылки.


12.2. Создание анимированных кнопок

Графические ссылки на WWW - страницах значительно лучше воспринимаются, если они меняют свой вид при наведении на них мыши и при щелчке мышью. В CorelDRAW 10 создание таких объектов автоматизировано.

В качестве примера создадим кнопку, которая меняет свой внешний вид. Вначале следует создать заготовку, из которой будут сделаны все варианты нажатой и не нажатой кнопки. Создайте прямоугольник с закругленными краями и залейте его черным цветом. Создайте копию прямоугольника, немного сдвинув его левее и выше, после чего залейте копию белым цветом. Поместите сверху надпись, установите для текста черный контур и залейте его белым цветом. Кнопка в не нажатом состоянии готова (Рис. 12.3, слева). Далее из нее следует сделать динамический объект.

Рис. 12.3. Различные фазы. кнопки

Выделите рисунок кнопки и выберите команду меню Effects Rollover Create Rollover (Эффекты Нажимаемые кнопки Создать нажимаемые кнопки). Внешне ничего не изменится, но теперь вместо нескольких объектов в документе имеется нажимаемая кнопка в обычном состоянии, о чем говорит надпись в строке состояния Rollover [NORMAL] (Нажимаемая кнопка [ОБЫЧНЫЙ]).

Для изменения рисунка в других режимах щелкните правой кнопкой мыши на объекте и выберите в появившемся вспомогательном меню команду Edit Rollover (Редактировать нажимаемую кнопку). Все рисунки, кроме редактируемой кнопки, станут невидимыми, и на экране появится дополнительная панель инструментов Internet (Интернет). Если вы часто создаете рисунки для Интернета, следует постоянно поместить ее в окне программы. Если панель инструментов Internet (Интернет) все время видна, то для создания кнопки можно не выбирать команду меню, а нажать в панели кнопку "Create Rollovers". Переход в режим редактирования осуществляется нажатием кнопки "Edit Rollover".

После перехода в режим редактирования вы должны создать рисунки для двух других положений кнопки. Выберите в списке, расположенном в левой части панели Internet (Интернет), вариант OVER (Над). Вы перешли к редактированию кнопки, когда на нее установлен указатель мыши. Ранее в списке был выбран вариант NORMAL (Обычно), что указывает на обычный вид кнопки. Удалите контур текста и залейте его черным цветом. Так будет выглядеть кнопка при прохождении над ней указателя мыши (Рис. 12.3, в центре).

Выберите в списке вариантов рисунка значение DOWN (Нажать). Теперь осталось нарисовать нажатую кнопку. В качестве заготовки предлагается первый вариант. Сделайте черным текст и уберите его контур. Подвиньте текст и белый прямоугольник ниже и правей, а черный прямоугольник - в противоположную сторону. Теперь кнопка выглядит нажатой (Рис. 12.3, справа).

Нажмите кнопку "Finish Editing Rollover" чтобы закончить редактирование кнопки и вернуться в обычный режим работы редактора. Теперь можно посмотреть, что у нас получилось. Нажмите кнопку "Edit Rollover". панели Internet (Интернет). Вы можете попробовать, как работает анимация кнопки. Установите указатель мыши на созданной вами кнопке, и рисунок на ней изменится. Нажмите кнопку мыши, и не отпускайте ее. Пока вы нажимаете кнопку мыши, на созданной кнопке нарисован третий рисунок. Отпустите кнопку мыши и отведите указатель мыши в сторону. На кнопке вновь появится начальный рисунок. Не беспокойтесь, если изменения рисунка происходят слишком медленно. При реальной работе в Интернете все будет происходить значительно быстрее. Отожмите кнопку "Finish Editing Rollover " чтобы вернуться в режим редактирования.

Если вы после выделения анимационной кнопки нажмете кнопку "Extract Rollover Object" панели Internet (Интернет), то все фазы будут выделены в отдельные объекты, расположенные друг на друге. Вы можете перетащить их мышью в сторону, чтобы убедиться в этом. Чтобы подготовить созданный рисунок для публикации в Интернете, нажмите кнопку "Internet" панели Internet (Интернет) и на экране появится диалог, в котором настраивается формат Интернет - документа. При сохранении будут созданы не только рисунки, но и необходимый код, позволяющий менять внешний вид объектов при просмотре WWW - страницы. Рассмотрим этот диалог подробнее.


12.3. Публикация документов в Интернете

Подготовив документ для публикации в Интернете, нажмите кнопку "Internet" панели Internet (Интернет) или выберите команду меню File/Publish to The Web HTML (Файл Публиковать в Web HTML). На экране появится диалог настройки публикации документа в Интернете. В этом диалоге много вкладок, но в большинстве случаев вам понадобятся только поля/ расположенные на первой вкладке диалога (Рис. 12.4).

Рис. 12.4. Диалог публикации в Интернете

Вы указываете место на вашем компьютере или в сети, где хотите расположить файлы. В списке HTML Layout Method (Метод генерации HTML) выбирается способ построения документа. Лучше всего использовать вариант Styles (Стили), который совместим со всеми современными браузерами и позволяет создавать компактный код. Остальные варианты имеют ограниченную совместимость или не могут использоваться для создания качественных документов. Установив флажок FTP Upload (Загрузка по FTP) и настроив дополнительные параметры, вы можете закачать файлы в нужное место с помощью протокола передачи файлов FTP. Однако, лучше сначала сгенерировать страницу и протестировать ее на своем компьютере. Переключателем Export Range (Диапазон экспорта) можно задать часть документа, используемую при публикации. Нажав кнопку Browser Preview (Просмотр в браузере), вы можете просмотреть созданную страницу в браузере, установленном в вашей системе. Некоторые дополнительные параметры устанавливаются на вкладке Advanced (Расширенный) (Рис. 12.5,)

Рис. 12.5. Другие вкладки диалога

Важно убедиться, что установлен флажок Generate JavaScript for roll-overs (Генерировать JavaScript для анимированных кнопок), чтобы был создан программный код, позволяющий анимировать кнопки, созданные с помощью CorelDRAW 10. Остальные флажки важны в специальных областях, и будут понятны специалистам.

На вкладке Summary (Резюме) (Рис. 12.5, снизу) можно прочитать основные параметры вновь создаваемого HTML документы. Эта информация приводится для справки. Если при генерации документа возникли ошибки, о них можно узнать на последней вкладке диалога. Надпись на ярлычке этой папки No Issues (Никаких проблем) означает, что ошибок нет. Нажмите кнопку OK, диалог закроется и в указанном месте будет создав Web - документ. Вы можете поместить его в Интернете, чтобы другие люди смогли увидеть ваше творение.

С помощью CorelDRAW 10 создается достаточно эффективный код HTML, занимающий мало места, что чрезвычайно важно для Интернета. Если вы имеете представление о языке HTML, то можете исправить и доработать документ вручную, взяв за основу этот.


13. Создание электронной документации

Широкое распространение устройств для записи компакт-дисков позволяет распространять большие документы в электронном виде. При этом чаще всего используются форматы файлов HTML и PDF. Первый формат используется в Интернете, и выше рассказывалось, как создать такой документ. Очень удобен формат PDF. Документы в этом формате можно просмотреть программой Acrobat Reader. С помощью CorelDRAW 10 вы легко создадите электронный документ в формате PDF.

При создании электронных документов вам понадобятся мощные возможности редактора по работе с текстом. Также вам потребуется создать многостраничный документ и экспортировать его в формат электронного документа. О работе с текстом рассказывалось ранее, так что остановимся на остальных особенностях создания документов.

13.1. Особенности работы с многостраничными документами

Графический редактор CorelDRAW 10 позволяет работать с многостраничными документами. Для обычных иллюстраций эта возможность не слишком нужна, но при создании разнообразных электронных документов использование множества страниц просто необходимо.

При создании нового документа в нем всегда имеется только одна страница. Чтобы добавить дополнительную страницу в документ, выберите команду меню Layout/ Insert Page (Разбивка/Вставить страницу). На экране появится диалог вставки новой страницы в документ (Рис. 13.1).

Рис. 13.1. Диалог добавления страницы.

В поле Insert (Добавить) вводится количество новых страниц. Если переключатель под полем установлен в положение Before (Перед), то страницы будут вставлены перед, а если After (После), то после страницы, номер которой введен в поле Page (Страницы). В остальных полях диалога определяется размер и ориентация добавляемых страниц. Эти параметры можно изменить после добавления страниц. Нажмите кнопку ОК, и страницы будут добавлены в графический документ. Если вы хотите удалить одну или несколько страниц, выберите команду меню Layout/Delete Page (Разбивка/Удалить страницу). В появившемся диалоге (Рис. 13.2, сверху) вводится номер удаляемой страницы. Если вы хотите удалить несколько страниц, следует установить флажок Through to page (До страницы) и ввести в расположенное правее поле номер последней из удаляемых страниц. Нажмите кнопку ОК, и указанные страницы будут удалены. Страницы удаляются без повторного предупреждения, но удаление страниц, как и любую другую операцию в CorelDRAW 10 можно отменить. В случае ошибочного удаления страниц вы сможете восстановить их.

Чтобы перейти со страницы на страницу, требуется просто щелкнуть мышью на ярлычке нужной страницы, расположенном левее нижней полосы прокрутки. Выбрав команду Layouts/Rename Page (Разбивка/Переименовать страницу), вы можете переименовать текущую страницу. В появившемся диалоге (Рис. 13.2, в центре) вводится имя, после чего нажимается кнопка ОК.

Рис. 13.2. Диалоги работы со страницами

Если страниц в документе много, то, выбрав команду меню Layout/Go To Page (Разбивка/Перейти на страницу), вы откроете диалог, облегчающий переход к нужной странице (Рис. 13.2, снизу). Введя номер страницы, вы должны нажать кнопку ОК, чтобы перейти к ней.

Работать с многостраничным документом следует точно так же, как и с одностраничным. Рисунки, размещаемые на разных страницах, независимы. Если вы поместите рисунок вне границ страницы, он будет виден при редактировании всех страниц, но не войдет в документ при его публикации. Внешними полями можно пользоваться, чтобы перемещать объекты с одной страницы на другую. Вы можете переместить объекты с одной страницы документа на поля, затем перейти к редактированию другой страницы, после чего переместить объекты с полей на рабочее поле. Аналогично можно скопировать объекты на поля, чтобы использовать их на разных страницах. Фактически поля документа могут использоваться как замена буфера обмена Windows, в котором может располагаться множество объектов.

Для смены альбомной ориентации на книжную и наоборот, выберите команду меню Layout/ Switch Page Orientation (Разбивка/ Переключить ориентацию страницы). Более сложные настройки страниц документа выполняются в диалоге, вызываемом командой меню Layouts/Page Setup (Разбивка/ Настройка страницы) (Рис. 13.3, сверху).

Рис. 13.3. Настройка страниц

Кроме ориентации и размеров листа бумаги, вы можете задать разрешение создаваемых рисунков. Можно изменить как все страницы документа, так и только одну текущую страницу. Переключателем в верхней части диалога можно выбрать обычную бумагу, если установить его в положение Normal Paper (Обычная бумага). По умолчанию используется именно эта настройка. Если же вы установите переключатель в положение Labels (Этикетки), то вам будет предложено создать лист этикеток (Рис. 13.3, снизу). В списке, расположенном слева, выбирается тип стандартных этикеток, на которых вы хотите распечатать свой рисунок. Пример листа этикеток показан правее.

Выбрав этикетки, вы должны нарисовать один небольшой рисунок, который должен поместиться на одну этикетку. При печати CorelDRAW 10 автоматически размножит рисунок и распечатает его на каждой из этикеток, входящих в лист. Так, например, можно создать визитные карточки, если вы используете при печати одну из стандартных заготовок карточек. Кроме того, в продаже имеются самоклеящиеся этикетки для струйной и лазерной печати. Используя средства CorelDRAW 10 для печати этикеток, вы сможете легко распечатать множество одинаковых наклеек.

Вы можете добавить фоновый рисунок к создаваемым электронным документам. Неяркий рисунок может украсить любой электронный документ. Для этого выберите команду меню Layouts/Page Background (Разбивка/Фон страницы). На экране появится диалог настройки фонового рисунка (Рис. 13.4)

Рис. 13.4. Настройка фонового рисунка

Если в диалоге выбрать вариант No Background (Нет фона), то фоновый рисунок будет убран. Установив переключатель Solid (Однородный), можно выбрать однородный цвет фона с помощью расположенного рядом элемента. Если установить переключатель в положение Bitmap (Растровый рисунок), то можно выбрать рисунок для фона. Нажав кнопку Browse (Просмотр), вы в диалоге можете указать файл с рисунком, который хотите использовать. Вы можете изменить размер фонового рисунка. Если размер рисунка меньше размеров страницы, он будет повторяться как узор. Если убрать флажок Print and Export Background (Печатать и экспортировать фоновый рисунок), фон будет виден только при просмотре, а при печати и экспорте фона не будет. Установив флажок, вы добавите фоновые изображения при печати и экспорте. Нажмите кнопку ОК для закрытия диалога и изменения фона документа. Выбранный фон будет автоматически добавляться ко всем страницам документа.


13.2. Публикация в формате PDF

Создав многостраничный документ, добавив текст, рисунки и задав фон, вы можете приступить к сохранению его в формате PDF. Для этого выберите команду меню File/ Publish to PDF (Файл/Публиковать в PDF). Откроется обычный диалог сохранения файла, в котором дополнительно появятся несколько полей. В списке PDF Style (Стиль PDF) можно выбрать один из вариантов формата, а, нажав кнопку Settings (Настройки), вы откроете диалог настройки публикации. Если вы не желаете менять настройки, определите папку и введите имя файла, после чего сохраните документ. Однако иногда могут потребоваться дополнительные настройки. После нажатия кнопки Settings (Настройки) на экране появится диалог с множеством вкладок с полями настройки сохранения документа в формате PDF. Наиболее важные поля находятся на вкладке General (Основные) (Рис. 13.5, сверху). В группе полей Export range (Область экспорта) можно установить, какие страницы из документа следует использовать в публикации. В списке Compatibility (Совместимость) указывается версия файла. Также можно указать автора документа и ввести ключевые слова.

Рис. 13.5. Настройка публикации документа

На вкладке Objects (Объекты) (Рис. 13.5, снизу) определяется способ хранения текстов и рисунков. Вы можете установить метод и степень сжатия рисунков, а также указать, требуется ли включать используемые шрифты в документ. Поэкспериментировав с установками, вы найдете компромисс между размерами файла и качеством получаемого документа. На вкладке Document (Документ) (Рис. 13.6, сверху) задаются параметры всего документа в целом. Среди прочего, вы можете задать, как будет выглядеть документ при его открытии.

Рис. 13.6. Дополнительные настройки публикации

На вкладке Advanced (Расширенный) (Рис. 13.6, снизу) настраиваются некоторые дополнительные параметры, которые используются опытными пользователями. Если при генерации документа возникли ошибки, о них можно узнать на последней вкладке диалога. Надпись на ярлычке этой папки No Issues (Никаких проблем) означает, что ошибок нет. При наличии ошибок на ярлычке указывается их количество.

Созданный документ PDF можно просматривать на любом компьютере, где установлена распространенная программа Acrobat Reader. В последнее время компьютерная документация все чаще поставляется именно в этом формате. Вместо отпечатанного тома документации, вам предлагается компакт-диск с файлом в формате PDF.


14. Повышение удобства работы

С помощью описанных выше приемов можно создать любую, сколь угодно сложную, иллюстрацию. Однако в CorelDRAW 10 результата можно добиться разными способами, и некоторые дополнительные средства позволят облегчить работу с редактором и упростить создание графических документов. Опробовав различные варианты работы, выберите тот, который наиболее подходит именно вам. В редакторе операции можно выполнить следующими способами:

• С помощью перетаскивания мышью маркеров.

• Выбором команд меню.

• С помощью контекстного меню.

• Настройкой полей в специальном диалоге.

• Настройкой полей в закреплении.

• Настройкой полей в панели Property Bar (Панель свойств).

Выбор способа работы зависит исключительно от ваших предпочтений. Часто принципы работы совершенно одинаковы, например одна и та же команда содержится в меню программы и в контекстном меню, вызываемом с помощью правой кнопки мыши. Многие поля в панели Property Bar (Панель свойств), в закреплении и диалоге не отличаются друг от друга. Чаще всего описывалось использование перетаскивания мышью и полей панели Property Bar (Панель свойств). Если вам больше нравятся другие способы выполнения операций, вы без труда их освоите. Кроме того, в редакторе доступны некоторые дополнительные средства для повышения эффективности и удобства работы. Рассмотрим дополнительные возможности CorelDRAW 10 по повышению эффективности и удобства работы, а также некоторые альтернативные средства редактирования объектов.

14.1. Контекстные меню и копирование свойств объектов

Щелкнув правой кнопкой мыши на любом объекте, вы откроете контекстное меню, в котором находятся наиболее часто используемые команды. Эта особенность редактора уже использовалась при выполнении некоторых операций. Набор команд может несколько различаться, в зависимости от типа объекта и его параметров, но в большинстве случаев вы увидите такое меню (Рис. 14.1, сверху).

Рис. 14.1. Контекстное меню

Команда Convert To Curves (Преобразовать в кривые) преобразует стандартный объект CorelDRAW 10 в произвольную кривую, а команда Break Apart (Разделить) позволяет разделить объект на несколько простых объектов. Команда Wrap Paragraph Text (Обтекание объектов текстом) задает обтекание объекта обычным текстом. Далее идут команды отмены, работы с буфером обмена и блокирования объекта. Следующую команду следует выделить особо. Если в графический документ вставлен растровый объект, то, выбрав команду Save Bitmap As (Сохранить растровый рисунок как), вы можете сохранить этот объект в файле на диске.

Часто используется команда Order (Порядок). В появляющемся рядом вспомогательном меню содержатся команды взаимного расположения объектов. Вы можете поместить любой объект над другими или под ними. Выбрав команду Styles (Стиль), вы откроете меню стилей. В нем можно сохранить выбранный вариант контура и заливки как новый стиль или использовать ранее созданный стиль для вашего объекта. Часто используется также команда Properties (Свойства), вызывающая закрепление с полями настройки разнообразных свойств объекта. Другое контекстное меню вызывается при перетаскивании объекта правой кнопкой мыши. Подведите указатель мыши к объекту, нажмите правую кнопку мыши, и, не отпуская ее, подведите указатель мыши к другому объекту, после чего отпустите кнопку мыши. На экране появится контекстное меню (Рис. 14.1, снизу). С помощью команды PowerClip Inside (Поместить в контейнер) можно поместить один объект в другой. Команды Move Here (Переместить сюда) и Copy Here (Скопировать сюда) позволяют переместить или скопировать объект в заданное место. Выбрав команду Сору Fill Here (Скопировать сюда заливку) или Copy Outline Here (Скопировать сюда контур), вы скопируете заливку или контур первого объекта, изменив соответствующие параметры объекта, на котором была отпущена кнопка мыши. Команда Сору Аll Properties (Скопировать все свойства) скопирует все параметры объекта. Так, например, можно скопировать параметры шрифта для текстового объекта.


14.2. Информация о документе CorelDRAW 10

Иногда бывает полезно узнать некоторые сведения о редактируемом документе. Выбрав команду File Document Info (Файл Информация о документе), вы откроете диалог с многочисленной полезной информацией о редактируемом документе (Рис. 14.2). Установив отдельные флажки в правой части диалога, можно заказать только выборочную информацию. Установив все флажки, вы получите всю возможную информацию о графическом документе. Вы можете узнать имя и местонахождение файла, количество страниц документа и их размер, многочисленные сведения об объектах данного документа. Вы получите сведения об использованных стилях, заливках и контурах, а также о примененных к объектам эффектах. Иногда эта информация может быть очень полезной.

Рис. 14.2. Получение информации о графическом документе

Нажав кнопку Save As (Сохранить как), вы можете сохранить информацию в файле для последующего использования. С помощью кнопки Print (Печать) можно распечатать информацию на принтере. Чтобы закрыть диалог, следует нажать кнопку Close (Закрыть).


14.3. Использование скриптов

В CorelDRAW 10 вы можете использовать последовательности действий, разработанные профессиональными художниками. Такие последовательности называются скриптами. С помощью скриптов, например, можно из окружности сделать шар или кнопку, а также создать табличку из фигурного текста (Рис. 14.3). Некоторые скрипты реализуют оригинальные заливки. Часто скрипты включают в себя несколько эффектов. При выборе скрипта CorelDRAW 10 повторяет все действия, которые выполнял разработчик этого скрипта. Вам не надо выполнять все его действия для достижения аналогичного результата, достаточно выбрать нужный скрипт.

Рис. 14.3. Использование скриптов

Удобнее работать со скриптами с помощью специального закрепления. Выберите команду меню Window Dockers Corel Scripts Manager (Окно Закрепления Диспетчер скриптов Corel) и закрепление появится на экране (Рис. 14.4). В закреплении предлагаются все доступные скрипты, причем все они сопровождаются небольшими эскизами. Рассмотрим использование скриптов на простом примере. Создайте эллипс, после чего щелкните мышью на скрипте, создающем кнопку. Этот скрипт так и называется: Button (Кнопка). Объект и скрипт выделены, можно приступать к изменению объекта. Нажмите кнопку следующий, расположенную в нижней части закрепления. После этого начнет выполнятся скрипт. Это займет некоторое время, по окончании которого ваш эллипс будет преобразован в кнопку. Аналогично вы можете преобразовать любой объект. После преобразования вы можете продолжить редактирование объекта, например, поменять цвет или убрать ненужные детали. Часто требуется разгруппировать результат, чтобы отредактировать некоторые части. Обратите внимание, что в списке скриптов есть несколько папок, перейдя в которые вы найдете дополнительные скрипты. С их помощью можно применить к объекту распространенные заливки и менять контур.

Рис. 14.4. Закрепление для работы со скриптами

Графический редактор CorelDRAW 10 поддерживает скрипты, написанные на языке программирования Visual Basic. Если вы знакомы с этим языком, то можете создавать собственные скрипты и менять существующие. Однако в большинстве случаев эти возможности редактора не используются.


14.4. Дополнительные возможности работы с объектами

Иногда бывает трудно выделить нужный объект, так как он закрыт другими объектами. Кроме того, при большом количестве объектов бывает трудно разобраться, какой из них вам нужно изменить, а какой не надо. В этом случае полезно воспользоваться закреплением со списком всех объектов документа. Выберите команду меню Tools/ Object Manager (Сервис/Диспетчер объектов) и закрепление появится на экране (Рис. 14.5).

Рис. 14.5. Диспетчер объектов

В списке, занимающем все закрепление, перечислены все объекты, описаны их параметры и примененные эффекты. Некоторые вложенные группы объектов скрыты. Чтобы раскрыть списки, следует щелкнуть мышью на значке плюс в заголовке группы. Значок изменится на и. Щелкнув мышью на значке минус, вы свернете список вложенных объектов. Чтобы выделить любой объект, нужно щелкнуть мышью на строке с его описанием в диспетчере объектов. Последовательность перечисления в списке соответствует порядку следования объектов. Самые нижние объекты расположены в нижней части списка. Объекты из верхней части списка располагаются над другими. Для изменения взаимного следования объектов можно перетащить строки с помощью мыши в новое место. Например, перетащив верхнюю строку в нижнюю часть списка, вы поместите связанный с ней объект под другими. Нажав кнопку, расположенную в нижней части закрепления, вы можете создать дополнительный слой. Все взаимные перемещения объектов выполняются в одном слое, и дополнительный слой может понадобиться при создании сложных графических документов, содержащих десятки тысяч объектов. В подавляющем большинстве случаев вам хватит и одного слоя. Для изменения свойств объектов служат разные инструменты и поля в диалогах, панелях инструментов и закреплениях. Однако иногда бывает удобнее воспользоваться одним закреплением, на нескольких вкладках которого содержатся все свойства объекта. Щелкните правой кнопкой мыши на любом объекте и выберите в контекстном меню команду Properties (Свойства). На экране появится закрепление для настройки свойств объекта. В зависимости от типа объекта, оно может содержать разное количество вкладок. Рассмотрим все вкладки этого важного закрепления. На любой вкладке вы устанавливаете соответствующие свойства объекта. Если кнопка замок в нижней части закрепления нажата, и на ней нарисован закрытый замок, то изменения сразу вступят в силу. Отжав кнопку-замок, вы измените рисунок на ней. Теперь замок открыт. В этом случае следует нажать кнопку Apply (Применить) после изменения свойств объекта, чтобы эти изменения вступили в силу. На первой вкладке закрепления (Рис. 14.6, сверху) настраивается заливка объекта. Кнопки, расположенные в верхней части вкладки, позволяют выбрать однородную или градиентную заливку, заливку узором или текстурой. Также можно выбрать заливку PostScript или удалить заливку объекта. В зависимости от выбранного типа заливки, в закреплении появляются разные поля диалога. Работа с заливками не отличается от аналогичной работы с полями панели Property Bar (Панель свойств) или диалогов настройки цвета. Выбрав нужную заливку и нажав кнопку Edit (Редактировать) в закреплении, вы откроете диалог настройки заливки, в котором доступны дополнительные возможности задания параметров заливок.

Рис. 14.6. Основные вкладки закрепления для настройки свойств объектов

Вторая вкладка диалога (Рис. 14.6, в центре) позволяет настроить контур объекта. В поле Width (Толщина) устанавливается толщина контура, ниже выбирается тип линий и стрелки на концах линий. Важный флажок Scale with image (Масштабировать с изображением) задает автоматическое изменение толщины контура при изменении размеров объекта. На третьей вкладке (Рис. 14.6, снизу) выводится некоторая полезная информация об объекте. Кроме того, в верхнем списке вкладки вы можете задать обтекание объекта текстом и выбрать тип этого обтекания. Рядом расположено поле, в котором можно установить расстояние обтекающего текста от объекта. Кроме того, в списке можно выбрать стиль объекта. Если вы не меняли стили в документе, то вам будет предложено выбрать из нескольких стандартных стилей. На следующей вкладке (Рис. 14.7, сверху) располагается полезная информация о размере выделенных объектов, координатах центра выделения и координатах центра вращения выделенных объектов. Эта информация приводится для справки, и изменить на этой вкладке вы ничего не сможете.

Рис. 14.7. Информация и настройка документов для Интернета

Следующие две вкладки (Рис. 14.7, в центре и снизу) предназначены для настройки документов, используемых в Интернете. Вы можете указать адрес гиперссылки, связать объект с методом отсылки информации и выполнить некоторые другие действия. Выше рассматривались особенности создания документов для Интернета. Для использования этих полей следует иметь представление о языке HTML и принципах создания гипертекстовых документов.

Последняя вкладка в закреплении может иметь самый разный внешний вид, в зависимости от типа объекта, с которым вы работаете. При работе с автофигурами на вкладке располагается ползунок, позволяющий изменить расположение ромбика, отвечающего за форму автофигуры. Если в автофигуре два ромбика, то в закреплении вы увидите два ползунка. Перетаскивая мышью ползунки вправо и влево, вы можете изменить форму автофигуры.

Рис. 14.8. Свойства автофигур, текста и кривых

При работе с текстом, в закреплении появятся поля настройки шрифта (Рис. 14.8, сверху). Можно выбрать шрифт, его размер и начертание. Также устанавливается выравнивание текста. В списке Scripts (Язык) выбирается языковая часть шрифта. Для открытия диалога настройки форматирования нажмите кнопку "Format Text" в закреплении. При работе с обычным текстом в списке Range (Диапазон) выбирается, какой именно фрагмент текста будет форматироваться. Можно форматировать одинаково весь текст в рамке, текст во всех связанных рамках или только выделенный фрагмент текста. При работе с кривыми линиями в закреплении выводится информация о количестве узлов и сегментов кривой (Рис. 14.8, снизу). Установив флажок Close Curve (Замкнутая кривая), вы можете превратить разомкнутый контур в замкнутый. Остальная информация носит справочный характер. Если вы работаете с прямоугольниками, то в закреплении имеется возможность настроить закругление углов этой фигуры (Рис. 14.9, слева). Вводя значения в четыре поля, вы устанавливаете кривизну закруглений соответствующих углов. убрав флажок Round All Corners (Закругление всех углов), вы сможете ввести различный радиус закруглений для разных углов.

Рис. 14.9. Свойства прямоугольников, эллипсов и многоугольников

Если вы выделили эллипс, то поля на вкладке закрепления позволят преобразовать его в дугу или сектор (Рис. 14.9, в центре). Кнопками, расположенными в верхней части вкладки, выбирается вид объекта. Если вы выбрали дугу или сектор, то с помощью расположенных ниже полей можете задать начальный и конечный углы этого объекта. При работе с многоугольниками поля вкладки позволяют настроить вид этих стандартных фигур (Рис. 14.9, снизу). Кнопкой выбирается многоугольник или звезда. В расположенном ниже поле устанавливается количество вершин объекта, а ползунком задается тип соединения вершин друг с другом.


14.5. Некоторые полезные закрепления

Мы уже рассмотрели множество закреплений, помогающих при повседневной работе с графическим редактором CorelDRAW 10. Познакомимся еще с несколькими закреплениями. Все операции, выполняемые с их помощью, можно выполнить и без них, но иногда использование закреплений предпочтительнее. Все закрепления вызываются с помощью команд вспомогательного меню, вызываемого командой Window Dockers (Окно Закрепления). Если вы работаете с большими иллюстрациями и часто меняете масштаб просмотра, вам может понадобиться закрепления для работы с масштабом. Выберите команду View Manager (Диспетчер просмотра). На экране появится закрепление для изменения масштаба (Рис. 14.10).

Рис. 14.10. Закрепление для изменения масштаба

Кнопки в верхней части закрепления позволяют изменить масштаб, как и при использовании инструмента "Zoom Tool" Выбрав нужный масштаб, вы можете запомнить его, нажав кнопку плюс в закреплении. В списке масштабов появится еще одна строка с описанием установленного масштаба. В дальнейшем вы можете вернуться к этому масштабу просмотра, дважды щелкнув мышью на строке с его описанием. Выделив строку описания масштаба и нажав кнопку минус, вы удалите этот масштаб из списка. Добавленные масштабы появятся в списке масштабов панели инструментов Standard (Основная). Вы можете выбрать добавленный вами масштаб точно так же, как и любой другой масштаб из списка. Если вы привыкли выбирать цвета из палитры, расположенной в правой части окна программы, но вам не хватает стандартных цветов, вы можете использовать другую палитру, поставляемую вместе с CorelDRAW 10. Вы даже можете использовать несколько палитр одновременно. Настройка отображения палитр выполняется в закреплении, вызываемом командой Color Palette Browser (Просмотр цветных палитр) (Рис. 14.11).

Рис. 14.11. Палитры и закрепление для работы с ними

В закреплений выводится список доступных палитр. Если часть строчек скрыта, для их просмотра следует щелкнуть мышью на значке плюс, расположенном в строке заголовка группы палитр. Палитры, видимые в настоящее время на экране, обозначены галочками. Щелкнув мышью на контуре, левее описания палитры, вы поставите галочку, и выбранная палитра появится в окне программы. Повторный щелчок мыши уберет палитру. Особенно полезным является использование фиксированных палитр, если вы планируете передать созданную вами иллюстрацию в производство.


14.6. Поиск и замена графических объектов

При работе над крупными проектами ваш графический документ может содержать тысячи разнообразных объектов. Поиск нужного объекта и замена свойств нескольких объектов может превратиться в достаточно трудное дело. В этом случае вам на помощь придут мастера поиска и замены, встроенные в CorelDRAW 10. Выберите команду меню Edit/Find and Replace Find Objects (Правка /Поиск и замена Поиск объекта). На экране появится первый диалог мастера поиска объектов (Рис. 14.12).

Рис. 14.12. Первый диалог мастера поиска

Если вы установите переключатель в диалоге в положение Find objects that match the currently selected object (Найти объекты, соответствующие выделенному в настоящее время объекту), то сможете найти точно такие же объекты, как и выделенный до выбора команды меню. Положение переключателя Load a search from disk (Загрузить поиск с диска) позволяет использовать ранее созданные и сохраненные правила для поиска объектов. Однако чаще всего параметры поиска задаются непосредственно в диалогах мастера поиска. Этому варианту соответствует положение переключателя Begin a New Search (Начать новый поиск). Установив переключатель в это положение, нажмите кнопку Далее (Next), чтобы перейти к следующему диалогу мастера (Рис. 14.13).

Рис. 14.13. Второй диалог мастера поиска

В этом диалоге требуется выбрать категории, по которым будет осуществляться поиск. Например, вы собираетесь искать прямоугольники и эллипсы с градиентной заливкой. Или вас интересуют все объекты, к которым был применен эффект объема. На четырех вкладках диалога вы можете найти все типы объектов, заливок, контуров и специальных эффектов. Установив галочку левее строки с нужным описанием, вы добавите его в список. Галочка ставится с помощью щелчка мышью. Повторный щелчок уберет галочку. Вы можете задать множество категорий поиска. Выбрав все интересующие вас объекты, заливки, контуры и эффекты, нажмите кнопку Далее (Next). На экране появится следующий диалог мастера (Рис. 14.14, сверху). В зависимости от выбранных в предыдущем диалоге объектов и их свойств, диалог может выглядеть по-разному. В этом диалоге настраиваются конкретные параметры поиска. Например, вы можете задать цвет при поиске заливки, или определить размеры искомого объекта. Нажав кнопку Далее (Next), вы перейдете к следующему диалогу настройки. При поиске по многим критериям вы должны последовательно настроить все искомые параметры. Если вы выбрали, например, прямоугольник и одноцветную заливку, то два последовательных диалога предназначены для задания свойств искомых объектов. При поиске эффектов тени и объема, вы последовательно зададите нужные характеристики эффектов. Однако в этом случае следует выделить строку в левой части диалога и нажать кнопку в правой части, чтобы появился диалог настройки параметров.

Рис. 14.14. Настройка параметров поиска и заключительный диалог мастера

После того, как все параметры заданы, при нажатии кнопки Далее (Next), появится заключительный диалог мастера поиска (Рис. 14.14, снизу). В нем описаны все заданные вами параметры поиска. Если вы хотите изменить некоторые параметры, нажмите кнопку Назад (Previous) для возврата к предыдущим диалогам мастера. Вы можете вернуться на несколько шагов назад и изменить любые установки, сделанные в предыдущих диалогах. Если же все верно, нажмите кнопку Готово (Ready) для начала процедуры поиска. На экране появится панель управления поиском (Рис. 14.15) и будет выделен первый найденный объект, удовлетворяющий условиям поиска. Если таких объектов не нашлось, на экране появится предупреждающее сообщение.

Рис. 14.15. Панель поиска

Нажав кнопку Find Next (Найти следующий) в панели поиска, вы выделите следующий найденный объект. Если вы нажмете кнопку Find Previous (Найти предыдущий), то снова выделите предыдущий найденный объект. Чтобы выделить все объекты, удовлетворяющие условиям поиска, следует нажать кнопку Find All (Найти все). Выделив нужные объекты, вы можете изменить их свойства, удалить их или переместить. То есть, вы можете выполнить с этими объектами любые действия. Нажав кнопку Edit Search (Изменить поиск) в панели поиска, вы вновь вернетесь к мастеру поиска и сможете изменить настройки для поиска объектов. При работе с множеством объектов часто возникает задача однотипных изменений всех объектов. Например, вы хотите сменить цвет с зеленого на синий у множества разных объектов. Последовательно выделять все объекты и менять их цвет очень утомительно, поэтому лучше воспользоваться средством автоматической замены. Выберите команду меню Edit/Find and Replaces/ Replace Objects (Правка/Поиск и замена/Замена объекта). На экране появится первый диалог мастера замены объектов (Рис. 14.16). Переключателем в этом диалоге следует выбрать категорию свойств объектов, которую вы хотите изменить. При этом вы можете установить флажок Apply to currently selected objects only (Применять только для выделенных объектов), если предварительно выделили несколько объектов. В этом случае замене будут подвергнуты только выделенные объекты. Если флажок не установлен, то поиск для замены будет осуществлен среди всех объектов графического документа.

Рис. 14.16. Первый диалог мастера замены

Если вы выберите положение переключателя Replace outline pen properties (Изменить свойства контура) и нажмете кнопку Далее (Next), на экране появится диалог настройки изменения цвета (Рис. 14.17, сверху).

Рис. 14.17. Замена цветов и цветовых моделей

В верхнем поле выбора цвета задается искомый цвет, а в нижнем поле устанавливается цвет, на который требуется заменить исходный цвет. Если переключатель в диалоге установлен в положение Fills (Заливки), то замене подвергнуться заливки объектов. Если переключатель установлен в положение Outlines (Контуры), то будет изменен цвет контуров. Если флажки в нижней части диалога не установлены, то заменятся только однородные заливки. Установкой флажков вы можете расширить круг измененных объектов. Если установить флажок Apply to fountain fills (Применить к градиентным заливкам), то будут изменены выбранный цвет, использованный в градиентных заливках. Флажок Apply to 2-color pattern fills (Применить к заливкам двуцветным узором) позволит изменить один из цветов, примененных в двуцветном узоре. Если вы установите флажок Apply to monochrome bitmaps (Применить к монохромным растровым изображениям), то сможете изменить черно-белые растровые изображения на красно-белые, сине-белые или черно-желтые. Растровые изображения, имеющие более двух цветов, таким способом изменить нельзя.

Установив в первом диалоге мастера переключатель в положение Replace a color model or palette (Изменить модель цвета или палитру), вы откроете диалог настройки модели цвета или цветовой палитры (Рис. 14.17, справа). В переключателе, расположенном в верхней части диалога, выбирается тип поиска. Установив вариант Find any color model or color palette (Найти любую модель цвета или цветовую палитру), вы осуществите замену всех использованных в документе цветовых схем. Выбрав вариант Find a color model (Найти модель цвета) и задав конкретную модель в расположенном рядом списке, вы ограничите поиск. Аналогично можно установить переключатель в положение Find a color palette (Найти цветовую палитру) и выбрать в списке конкретную палитру. В расположенном ниже списке выбирается цветовая модель, которая должна заменить используемую ранее. Если расположенный рядом переключатель установлен в положение Fills (Заливки), то замене подвергнуться заливки объектов. Если переключатель установлен в положение Outlines (Контуры), то будет изменена цветовая схема контуров. Назначение флажков в нижней части диалога точно такое же, как и при замене цвета. Вы можете с их помощью описать замену цветовой схемы у сложных заливок. Если вы установите в первом диалоге мастера переключатель в положение Replace outline pen properties (Изменить свойства контура), то на экране появится диалог определения характеристик контура (Рис. 14.18, сверху). В нем находятся две группы полей. Поля, объединенные в группу Find (Найти), задают параметры поиска. В группе Replace (Заменить) задаются новые свойства контуров объектов. При этом совсем не обязательно устанавливать однотипные параметры для поиска и замены. Например, вы можете найти все контуры толщиной в один миллиметр и установить для них изменение толщины при увеличении и уменьшении объектов.

Рис. 14.18. Замена свойств контуров и текста

Установив флажок в поле Outline width (Толщина контура) и задав конкретные значения в расположенном рядом поле, вы установите поиск и замену толщины контура. Флажок Scale width image (Сохранять пропорции) описывает сохранение пропорций толщины контура и размера объекта при его изменении. В расположенном правее списке можно выбрать значение On (Включено) или Off (Выключено), чтобы включить или выключить использование этого свойства. Аналогично, установив флажок Outline overprint (перекрытие контура), вы можете в расположенном рядом списке включить или выключить перекрытие контуром заливки. Если вы установите в первом диалоге мастера переключатель в положение Replace text properties (Изменить свойства текста), на экране появится диалог настройки формата текста для его замены (Рис. 14.18, снизу). Как и при замене контура, он состоит из двух групп полей, в которых задаются параметры искомого и нового форматирования текста. Установив соответствующие флажки, вы можете задать в расположенных рядом с ними полях шрифт, начертание и размер символов. Установив в одном из описанных диалогов нужные параметры, нажмите кнопку Готово (Ready) для начала процедуры замены. На экране появится панель управления заменой (Рис. 14.19), и будет выделен первый найденный объект, удовлетворяющий заданным условиям. Если таких объектов не нашлось, на экране появится предупреждающее сообщение.

Рис. 14.19. Панель замены

Нажав кнопку Find Next (Найти следующий) в панели замены, вы выделите следующий найденный объект. Если вы нажмете кнопку Find Previous (Найти предыдущий), то снова выделите предыдущий найденный объект. Чтобы выделить все объекты, удовлетворяющие условиям поиска, следует нажать кнопку Find All (Найти все). Нажав кнопку Replace (Заменить) в панели замены, вы выполните замену свойств выделенного объекта. После этого будет выделен следующий найденный объект. Нажав кнопку Replace All (Заменить все), вы замените все объекты графического документа, удовлетворяющие заданным критериям поиска.


14.7. Использование различных режимов просмотра документа

В графическом редакторе CortelDRAW 10 есть несколько режимов просмотра документа, различающиеся качеством получаемого изображения и скоростью формирования рисунков. Изображение наилучшего качества получается в режиме расширенного просмотра (Рис. 14.20, сверху). В этом режиме вы видите рисунки практически такими же, как они будут выглядеть распечатанными на принтере. Мелкие детали прорисованы, переходы цвета плавные. Чтобы перейти в этот режим просмотра, выберите команду меню View /Enhanced (Вид/Расширенный). Однако в этом режиме каждое обновление изображения на экране требует значительных вычислительных мощностей. Сложные рисунки на маломощных компьютерах будут обновляться очень медленно, с большими задержками. В этом случае используйте обычный режим просмотра. Выберите команду меню View/ Normal (Вид/ Обычный). Качество изображения почти не изменится, но некоторые детали и переходы цветов будут показаны менее качественно. Зато скорость работы существенно увеличится. Если вам хочется еще больше увеличить скорость работы, выберите команду меню View Draft (Вид Черновой). Качество рисунка резко упадет, но работать с ним можно будет значительно быстрее.

<

Рис. 14.20. Различные режимы, просмотра

Вы можете не отображать заливку объектов, оставив только контуры (Рис. 14.20, снизу). Для перехода в этот режим выберите команду меню View/ Wireframe (Вид /Контурный). В режиме контурного просмотра, в котором цвета объектов не отображаются на экране, работа ускорится, но ее удобство редко снизится. Для работы в этом режиме нужен определенный навык. Есть еще один режим, вызываемый командой меню View/Simple Wireframe (Вид/Простой контурный). В нем отображение рисунка еще проще, но трудно представить себе, когда может потребоваться именно этот режим. В большинстве случаев лучше использовать режим расширенного просмотра, если ваш компьютер имеет достаточную мощность. При создании больших иллюстраций, содержащих множество объектов, можно переходить в режим обычного просмотра. Остальные режимы рекомендуется использовать только при работе на устаревших маломощных компьютерах. Если вы хотите увидеть рисунок без дополнительных элементов окна редактора, выберите команду меню View/Full-screen preview (Вид/Полноэкранный просмотр). Рисунок займет весь экран монитора. При этом никаких других элементов на экране показано не будет. Для возврата к редактированию рисунка требуется щелкнуть мышью в любом месте. Чтобы просмотреть только часть рисунка в полноэкранном режиме, выберите команду меню View/Preview Selected Only (Вид/Просмотр только выделенного). После этого выделите интересующие вас объекты и выберите команду меню View/Full-screen preview (Вид/Полноэкранный просмотр). Обратите внимание, что масштаб просмотра выделенных объектов не меняется. Чтобы при просмотре нужные объекты занимали всю площадь экрана, надо перед выбором команды полноэкранного просмотра увеличить масштаб просмотра. Повторный выбор команды меню View/Preview Selected Only (Вид/Просмотр только выделенного) отменит режим показа только выделенных объектов. Иногда при редактировании в рабочей области появляются помехи, эффекты не проявляются полностью, а часть объектов становится не видна. Если у вас возникли подобные ошибки, выберите команду меню Window/Refresh Window (Окно/Обновить окно), и все видимые объекты будут обновлены. В сложных рисунках эта операция может занять некоторое время, но по ее окончании вы получите качественное изображение созданной вами иллюстрации. Этой же командой следует пользоваться, если вы отключили автоматическое обновление экрана для ускорения работы.


14.8. Полезные настройки редактора

Графический редактор CorelDRAW 10 имеет множество настроек, позволяющих значительно изменить внешний вид рабочего окна программы. Также можно настроить некоторые особенности работы в редакторе. При рассмотрении некоторых возможностей редактора описывались диалоги их настройки. Теперь вашему вниманию предлагаются другие, достаточно полезные, настройки CorelDRAW 10. Для настройки всех возможностей CorelDRAW 10 следует выбрать команду меню Tools/ Options (Сервис/Параметры). На экране появится диалог настройки параметров (Рис. 14.21).

Рис. 14.21. Настройка параметров CorelDRAW 10

В левой части диалога находится список всех групп параметров, которые вы можете настроить. Всего доступно для настройки более полусотни групп. Все они сами объединяются в группы. Некоторые эти группы также могут быть объединены. Список групп можно развернуть или свернуть, щелкнув мышью на квадратике, расположенном левее заголовка. Работа с иерархическим списком групп параметров очень похожа на работу с папками в проводнике Windows. Чтобы выбрать нужную группу, необходимо щелкнуть на ней мышью. При этом в правой части диалога появятся поля настройки параметров. Заполнив поля, вы можете продолжить настройку, перейдя к следующей группе полей настройки. Настроив все нужные параметры, нажмите кнопку ОК. Диалог закроется, и все настройки вступят в силу. Если вы хотите отказаться от внесения изменений, нажмите кнопку Cancel (Отмена). С помощью кнопки Help (Справка) можно вызвать справочную систему CorelDRAW 10, с помощью которой узнать об особенностях тех или иных настроек. Все настройки разделяются на три больших группы. В группе Workspace (Рабочая область) настраивается внешний вид редактора и особенности его работы. Именно эта группа наиболее важна для настройки эффективной работы. В группе Document (Документ) можно настроить параметры редактируемого документа. Также вы можете установить некоторые значения по умолчанию для вновь создаваемых документов. В группе Global (Глобальные) устанавливаются параметры печати, экспорта и импорта, важные для продуктивной работы с редактором. Так как правильная настройка рабочей области позволяет более эффективно использовать все возможности CorelDRAW 10, рассмотрим настройку этой группы параметров. Щелкнув мышью на названии Workspace (Рабочая область), вы сможете выбрать ранее созданную схему настроек. В списке схем галочкой указывается схема, используемая в настоящий момент. Все изменения настроек будут применяться именно к ней. Вы можете создать новую схему, нажав кнопку New (Новая). Далее все изменения настроек будут применяться именно к ней. Если вы в дальнейшем захотите вернуться к старым настройкам, достаточно в диалоге настройки установить галочку у другой схемы. Рассмотрим разнообразные настройки рабочей области CorelDRAW 10. Если под строкой Workspace (Рабочая область) не виден список групп параметров, щелкните мышью на значке плюс, расположенном правее слова Workspace (Рабочая область). Список раскроется, и вы увидите названия разных групп. Первой в списке групп стоит General (Основные). Действительно, основные настройки сгруппированы именно здесь. Щелкните мышью на этой строке, и в правой части диалога появятся поля настройки (Рис. 14.22, сверху). Так как левая часть, заголовок и кнопки диалога не меняются при выборе разных групп, то в дальнейшем они не будут показаны в рисунках.

Рис. 14.22. Основные параметры и параметры, отображения

В верхней части диалога находятся поля настройки количества запоминаемых действий. В поле Regular (Обычные) задается число векторных преобразований, а в поле Bitmap effects (растровые эффекты) - запоминаемые растровые эффекты. Не стоит сильно увеличивать последнее значение, так как при каждом изменении растрового рисунка фактически требуется запомнить еще один рисунок такого же размера. Увеличение запоминаемых действий может привести к нехватке памяти и резкому падению быстродействия. В поле Resolution (Разрешение) задается разрешение для эффектов теней, интерактивной прозрачности и некоторых других. Устанавливая и убирая флажки в диалоге, вы можете включить или выключить некоторые функции редактора. Большинство из них не повлияют сильно на работу редактора. Например, флажком Enable sounds (Доступны звуки) включается использование звуков при работе с редактором. Вы можете настроить звуковую схему с помощью стандартных средств Windows. Конечно, со звуками работать удобнее, но и без них не возникнет критических ошибок. Аналогично, можно не обращать внимания на то, в каком месте окна программы будут появляться диалоги - по центру или нет. Группа параметров Display (Отображение) (Рис. 14.22, снизу) отвечает за особенности отображения создаваемых рисунков на экране монитора. Переключателем Preview colors (Просмотр цветов) устанавливается использование цветовой схемы Windows или схемы Corel. В группе полей Full-screen Preview (Полноэкранный просмотр) устанавливается режим полноэкранного просмотра - обычный или расширенный. Если установлен флажок Interruptible refresh (Прерываемое обновление), то вы можете прервать обновление рисунка на экране, если оно выполняется слишком долго, нажав любую клавишу или щелкнув мышью. Флажок Manual refresh (Ручное обновление) предназначен для включения режима обновления экрана по команде. Важный флажок Auto-panning (Автопанорамирование) включает прокрутку, если вы перетаскиваете объект за границу видимой области. Если вы уберете флажок Enable node tracking (Позволить работу с узлами), то при использовании инструмента "Pick Tool" с узлами объектов работать будет нельзя. Для работы с узлами придется использовать инструмент "Shape Tool". Лучше не убирать этот флажок. Установленный флажок Enable selection after drawing (Использовать выделение после рисования) позволяет выделять объекты сразу после их создания. Еще несколько флажков позволяют настроить качество просмотра. Группа параметров Edit (Редактирование) (Рис. 14.23, сверху) позволяет настроить важные параметры редактирования. В поле Constrain angle (Сдерживающий угол) задается угол дискретизации поворота при использовании некоторых команд. В поле Drawing precision (Точность рисования) задается количество разрядов в цифрах, задающих положение и размер объектов. С помощью остальных полей устанавливаются специфические параметры редактирования.

Рис. 14.23.Параметры редактирования и предупреждения

Группа параметров Warnings (Предупреждения) (Рис. 14.23, снизу) предназначена для описания действий, которые требуют подтверждения. Если убрать флажки, то потенциально опасные действия будут выполняться без подтверждений. Лучше установить все флажки, чтобы редактор предупреждал вас об опасности. Группа параметров Save (Сохранение) (Рис. 14.24, сверху) описывает принципы сохранения файлов. Если установить флажок Auto-backup every (Автосохранение каждые) и ввести количество минут в расположенное рядом поле, то каждые несколько минут будет сохраняться резервная копия редактируемого файла. Установленный флажок Make backup on save (Сохранять резервную копию) предписывает сохранять предыдущую версию документа в резервном файле при каждом сохранении. Если вы уберете флажок, резервная копия сохраняться не будет. С помощью переключателя можно выбрать место для резервной копии: та же папка, где находится основной файл или специальное место, указанное в поле диалога. Лучше сохранять резервные копии в одном месте, чтобы они не мешались в рабочих каталогах.

Рис. 14.24. Параметры, сохранения и использования памяти

Группа параметров Memory (Память) (Рис. 14.24, снизу) предназначена для настройки используемой памяти. Это очень важно для эффективной работы с редактором. В списках Swap disk (Диск для временной памяти) устанавливаются первый и второй диски, которые используются для хранения временных файлов. При работе CorelDRAW 10 создается много временных файлов, поэтому рекомендуется указать диск, на котором много свободного места. Также желательно использовать быстрый диск, чтобы работа редактора не замедлялась. В поле Memory Usage (Используемая память) вводится максимальный процент использования оперативной памяти. Чем больше процент, тем быстрее работает CorelDRAW 10, но другим программам и Windows тоже требуется память. Установив флажок Enable Compression (Допускается сжатие) вы включите использование сжатие при работе. Этим вы экономите место, но ухудшаете быстродействие. Чтобы параметры группы Memory (Память) вступили в силу, требуется выйти из CorelDRAW и запустить его заново. Группа параметров Plug-Ins (Дополнения) предназначена для добавления и удаления дополнительных художественных эффектов. Если у вас есть эффекты, совместимые с CorelDRAW 10, вы можете после подключения использовать их прямо из редактора. Группа параметров Text (Текст) (Рис. 14.25) описывает множество особенностей работы с текстом. Основные параметры расположены непосредственно в главной группе, а во вложенных группах описываются особенности работы с обычным текстом, используемые шрифты, правила автозамены и проверки правописания.

Рис. 14.25. Текстовые параметры

В главной группе важно установить флажок Edit text on screen (Редактировать текст на экране), чтобы редактировать текст непосредственно в документе, а не в специальном диалоге. Флажок Drag and drop editing (Редактировать перетаскиванием) позволяет перемещать фрагменты текста перетаскиванием их с помощью мыши, как это делается в текстовых редакторах. Кроме этого, вы можете установить некоторые параметры отображения текста. Большинство текстовых параметров лучше не менять. В группе полей Toolbox (Инструменты) настраиваются все инструменты CorelDRAW 10. Вы можете установить точность работы некоторых инструментов, задать внешний вид, создаваемых многоугольников, и указать некоторые параметры вновь создаваемых фигур. В группе полей Customization (Настройка) можно изменить внешний вид окна редактора. Вы можете изменить панели инструментов и меню, создать новые и изменить существующие. Такие преобразования лучше выполнять после получения опыта работы с CorelDRAW 10. Когда вы будете знать, какими командами чаще пользуетесь, вы сможете расположить их в удобном для доступа месте. В группе полей Document (Документ) (Рис. 14.26) содержится множество подгрупп. Все они позволяют настроить редактируемый в настоящее время документ. Установив флажки в основной группе, вы можете указать, какие из настроек следует использовать для вновь создаваемых документов. Флажок в поле Save options as defaults for new documents (Сохранить параметры как умолчания для новых документов) предназначен для указания, что вы хотите сохранить все указанные параметры.

Рис. 14.26. Настройка параметров редактируемого документа

Для редактируемого документа можно настроить страницы, сетку, направляющие и измерительные линейки. Выбирается вид просмотра документа. Настраиваются стили, описываются принципы сохранения и публикации в Интернете. Большинство этих настроек рассматривалось выше, при описании соответствующих приемов работы. В группе полей Global (Глобальные) настраиваются параметры печати, описываются особенности применения растровых эффектов и фильтров импорта - экспорта. Настройка печати позволяет учитывать особенности вашего принтера при печати иллюстраций из редактора (Рис. 14.27). Если вы не уверены в использовании тех или иных настроек, лучше ничего не меняйте. Легко ухудшить качество печати, но восстановить его после будет чрезвычайно трудно.

Рис. 14.27. Настройка печати

При настройке работы растровых эффектов полезно установить флажок Prefill dialogs with last used values (Заполнять диалоги последними использованными значениями). При вызове эффекта он будет настроен точно так же, как и при предыдущем применении. Вы можете сэкономить время, не устанавливая снова оптимальные параметры применения эффекта. Группа полей Filters (Фильтры) (Рис. 14.28,), входящая в группу Global (Глобальные), позволяют добавить или удалить фильтры для преобразования файлов растровой и векторной графики, текстовых документов и анимационных файлов. Чтобы CorelDRAW 10 смог импортировать или экспортировать документ в нужный формат, необходимо установить соответствующий фильтр. Если у вас не получается импортировать графический файл, возможно просто не установлен необходимый фильтр. Хотя, конечно, CorelDRAW 10 поддерживает не все существующие графические форматы. Справедливости ради следует отметить, что не поддерживаемые редактором форматы встречаются крайне редко.

Рис. 14.28. Настройка фильтров и ассоциаций

В группе Associate (Ассоциация) (Рис. 14.28,) устанавливается связь CorelDRAW 10 с различными графическими файлами. Если вы связали файлы какого-либо типа с редактором, то он будет запускаться автоматически, когда вы щелкните дважды мышью на файле этого типа. Связь может быть нарушена, если другая программа прописала себя для работы с одним из типов файлов. В этом случае можно восстановить связь в диалоге настройки. Кроме некоторых полезных параметров, большинство настроек CorelDRAW не рекомендуется менять. Значения, установленные по умолчанию, часто оказываются наиболее хорошими.


III. Эффекты и обработка растровых изображений

В CorelDRAW 10 вы можете использовать множество оригинальных художественных эффектов, облегчающих создание высококлассных профессиональных иллюстраций. Кроме того, CorelDRAW 10 включает мощные средства обработки растровых изображений, позволяющие существенно расширить область применения редактора. Особо следует выделить художественные эффекты растровой графики, по качеству которых CorelDRAW 10 превосходит некоторые достаточно мощные редакторы растровой графики.

15. Применение эффектов

Создав и отредактировав векторные объекты, вы можете применить к ним различные оригинальные эффекты, для получения более выразительных и красивых графических документов. Проще всего использовать для создания эффектов интерактивные средства CorelDRAW 10, однако можно работать и с помощью закреплений, открываемых командами вспомогательного меню, вызываемого командой Effects (Эффекты).

15.1. Перетекание объекта в другой и эффект подобия

Инструменты интерактивных эффектов сгруппированы во вспомогательной панели инструмента "Interactive Blend Tool" в панели Toolbox (Графика) (Рис. 15.1).

Рис. 15.1. Панель интерактивных инструментов для создания эффектов

Мы опишем все эти инструменты и начнем с эффекта перетекания одного объекта в другой. Этот эффект позволяет плавно проследить переход от одного объекта к другому через серию промежуточных форм. Перетекание может быть выполнено как кратчайшим путем, так и по заданной кривой. Перетекание может быть задано между объектами с разными контурами и заливкой, а также между открытой кривой и замкнутым объектом. С помощью инструмента "Restangle Tool" создайте квадрат. Напоминаем, что для создания правильной фигуры следует держать нажатой клавишу Ctrl. Щелкните мышью на белом цвете в палитре, чтобы закрасить созданный квадрат. С помощью инструмента "Ellipse Tool" создайте круг и закрасьте его черным цветом. Выберите инструмент "Interactive Blend Tool" панели Toolbox (Графика) и установите указатель мыши на свободном месте рабочей области. Указатель мыши примет вид. Так как под указателем нет объекта, Перетекание невозможно. Подведите указатель мыши к квадрату, и указатель изменится. Нажмите кнопку мыши, и, не отпуская ее, установите указатель мыши на круге. Кроме того, на экране появятся контуры будущего перетекания и соединительная линия с элементами управления, называемая вектором настройки перетекания (Рис. 15.2, слева). Отпустите кнопку мыши, и перетекание из одного объекта в другой будет нарисовано (Рис. 15.2, справа).

Рис. 15.2. Создание эффекта перетекания

Существует множество средств для редактирования перетекания. Рассмотрим некоторые из них. Установите в поле "Number of steps offset between blend shaped" панели Property Bar (Панель свойств) число шагов равным 10. При перетекании будет нарисовано десять промежуточных фаз. В поле введите значение поворота 180 градусов. Теперь при перетекании объект будет одновременно поворачиваться вокруг своей оси. Теперь объекты перетекают по дугообразной кривой. Обратите внимание на линию, соединяющую два объекта. Два треугольника, расположенные посередине линии, управляют скоростью изменений при перетекании. Один треугольник отвечает за скорость изменения формы, а другой -за скорость изменения цвета. Чем ближе треугольник к объекту, тем быстрее изменятся форма и цвет объекта. В обычном состоянии оба треугольника связаны друг с другом и передвигаются по соединительной линии вместе. Чтобы появилась возможность передвинуть треугольники по-разному, надо дважды щелкнуть мышью на одном из треугольников. Повторный двойной щелчок вернет режим связанного передвижения.

Дважды щелкните мышью на одном из треугольников управляющего вектора. Перетащите оба треугольника в разные стороны, чтобы изменить объект перетекания (Рис. 15.3, слева). В нашем примере перетекание имеет преимущественно черный цвет и форму квадрата. Щелкните на желтом цвете в палитре, и перетекание будет залито однородным желтым цветом. Нажмите кнопку в панели Property Ваг (Панель свойств). Теперь перетекание имеет все цвета радуги. Расположить перетекание можно также вдоль произвольной кривой. С помощью инструмента "Freehand Tool" нарисуйте кривую, соединяющую квадрат и круг. Для большей наглядности сильно изогните ее вправо и вверх. Выберите инструмент "Intractive Blend Tool" в панели Toolbox (Графика) и щелкните мышью на перетекании, чтобы выделить его. Нажмите кнопку "Shape Tool" в панели Property Bar (Панель свойств). Рядом с кнопкой появится вспомогательное меню. Выберите команду New Path (Новый путь) во вспомогательном меню. Указатель мыши примет другой вид. Щелкните мышью на только что созданной кривой. Теперь перетекание происходит вдоль кривой (Рис. 15.3, справа).

Рис. 15.3. Варианты перетекания

Эффект перетекания особенно красиво смотрится при использовании градиентной заливки одним или обоими объектами. При использовании текстуры или узора перетекание заливки не происходит. Эффект подобия похож на перетекание, но подобие применяется к одному объекту. Строится его уменьшенная или увеличенная копия и происходит перетекание объекта в копию. Создайте пятиугольник. Выберите инструмент "Intractive Countayr Tool" во вспомогательной панели интерактивных инструментов. Подведите указатель мыши к контуру пятиугольника. Указатель примет другой вид. Нажмите кнопку мыши, и не отпуская ее, передвиньте мышь ближе к центру объекта. На экране появится вектор настройки эффекта подобия и уменьшенная копия пятиугольника (Рис. 15.4, слева). Отпустите кнопку мыши, и к объекту будет применен эффект подобия (Рис. 15.4).

Щелкните мышью на черном цвете в палитре, чтобы закрасить исходный объект. Выберите белый цвет в поле заливки, панели Property Bar (Панель свойств). Теперь каждый промежуточный контур закрашен своим цветом (Рис. 15.4, справа).

Рис. 15.4. Применение эффекта подобия

С помощью остальных управляющих элементов панели Property Bаг (Панель свойств) вы можете установить количество, ширину и цвет промежуточных форм. Можно настроить эффект и с помощью редактирования вектора эффекта.


15.2. Интерактивное искажение, применение оболочек и перспективы

Эффект интерактивного искажения очень сильно меняет форму объектов и часто трудно использовать этот эффект для достижения необходимого результата. создайте квадрат и залейте его черным цветом. Выберите инструмент "Interactive Distruction Tool" во вспомогательной панели интерактивных инструментов. Нажмите кнопку "Interactive Envelope Tool" в панели Property Bar Панель свойств) для выбора варианта интерактивного искажения. Установите указатель мыши на созданном объекте, нажмите кнопку мыши, и, не отпуская ее, передвиньте мышь в сторону, после чего отпустите кнопку мыши. Квадрат будет искажен (Рис. 15.5, слева). Вариант искажения зависит от местоположения и длины вектора настройки искажения. Отмените последнее действие, а затем попробуйте выполнить другие варианты искажения, нажав кнопку в панели Property Bar (Панель свойств). Теперь искаженный объект выглядит всем иначе (Рис. 15.5, справа). Снова отмените последнее действие и нажмите кнопку "Twister Distortion" после чего опять выполните искажение. Объект опять выглядит иначе (Рис. 15.6, слева).

Рис. 15.5. Различные варианты интерактивного искажения

Применяя различные виды искажения, можно добиться оригинальных результатов, но главное, не переусердствовать и не превратить объект в абстрактное пятно. Например, трудно представить, что непонятный рисунок (Рис. 15.6, справа) получился в результате всего нескольких искажений квадратного объекта.

Рис. 15.6. Другие варианты искажений

Другим способом искажения объектов является использование оболочек. Создайте объект фигурного текста. Выберите инструмент [И] во вспомогательной панели интерактивных инструментов. Вокруг объекта появится красная пунктирная рамка с восемью узлами (Рис. 15.7, слева). Это и есть оболочка. Перетащите узлы оболочки с помощью мыши на новое место. Форма пунктирной рамки изменится, но вписанный в нее объект снова полностью заполнит оболочку. Таким образом мы поменяли форму фигурного текста с помощью оболочки (Рис. 15.7, справа). Точно так же вы можете применить оболочку к любому другому объекту CorelDRAW 10.

Рис. 15.7. Использование оболочки

Создайте объект обычного текста, после чего выберите инструмент "Interactive Envelope Tool". Вокруг текста появится оболочка. Откройте список в левой части панели Property Bar (Панель свойств). Рядом появится перечень заготовок. Выберите в списке заготовку с названием Heart envelope и щелкните на ней мышью. Оболочка такой же формы появится вокруг текста (Рис. 15.8). Обратите внимание, что оболочка изменяет рамку обычного текста, не меняя при этом символы текста.

Рис. 15.8. Оболочка из заготовки

Оболочки в CorelDRAW 10 имеют много возможностей. Вы можете редактировать их точно так же, как произвольную кривую. Можно добавлять и удалять узлы, перемещать их и настраивать манипуляторы кривизны в узлах. Все это делается абсолютно так же, как и редактирование узлов любого векторного объекта с помощью инструмента "Shape Tool". В результате вы можете получить достаточно сложную оболочку, в которую автоматически будет вписываться объект CorelDRAW 10. В редакторе имеется возможность создавать объект с иллюзией перспективы. Ощущение перспективы достигается за счет изменения длины одной или двух сторон воображаемой плоскости. При этом будет казаться, что объект на плоскости удаляется в глубину экрана или происходит искажение объекта в двух направлениях (Рис. 15.10). Работа с перспективой очень похожа на использование оболочек.

Рис. 15.9. Объект с рамкой для создания эффекта перспективы

Создайте объект фигурного текста. Выберите команду меню Effects/Add Perspective (Эффекты/Добавить перспективу). Текст будет заключен в пунктирную сетку, по краям которой расположены четыре маленьких черных квадрата (Рис. 15.9). Указатель мыши изменится .

Рис. 15.10. Различные варианты перспективы

Установите указатель мыши на одном из угловых квадратов. Указатель изменится на плюс. Нажав и удерживая левую кнопку мыши/ начните передвигать мышь. Вместе с передвижениями мыши изменяется и пунктирная сетка. Отпустите кнопку мыши, и текст будет перерисован с учетом эффекта перспективы. Таким же образом передвиньте другие черные квадраты по углам сетки. Вы можете получить самые разные результаты с помощью эффекта перспективы (Рис. 15.10). Выберите команду меню Effects/Clear Perspective (Эффекты/Удалить перспективу). Текст примет свой первоначальный вид.

Примечание:

Хотя CorelDRAW 10 позволяет перемещать квадраты на углах сетки перспективы в произвольном направлении, но наиболее красивого эффекта можно добиться при перемещении в строго горизонтальном или вертикальном направлении.

Перспектива создает некоторую иллюзию глубины, но гораздо более достоверно выглядят специально созданные объемные объекты, которые мы рассмотрим далее.


15.3. Объемные объекты

Высококачественная иллюзия объема в графическом редакторе CorelDRAW 10 создается за счет проецирования точек вдоль краев объекта и соединения их для формирования поверхностей. Эти поверхности формируют динамическую группу, связанную с объектом, к которому применили эффект объема, и автоматически обновляются при изменении этого объекта. Применение цветовых эффектов для вновь созданных поверхностей усиливает впечатление объема (Рис. 15.11). Рассмотрим на примере создание объемного объекта. С помощью инструмента "Restangle Tool" создайте произвольный прямоугольник. В дальнейшем мы превратим его в параллелепипед. Выберите инструмент "Interactive Extrude Tool" во вспомогательной панели интерактивных инструментов для добавления эффектов и установите указатель мыши на объекте. Указатель примет другой вид. Нажмите кнопку мыши, и, не отпуская ее, передвиньте мышь в сторону, после чего отпустите кнопку мыши. На экране появятся контуры объема и вектор настройки данного эффекта (Рис. 15.12).

Рис. 15.11. Пример объемного объекта

Рис. 15.12. Объемный объект с вектором настройки

За несколько секунд нами создан параллелепипед из прямоугольника, и теперь мы приступим к редактированию объема. В списке вариантов объема панели Property Bar (Панель свойств) выберите вариант "Interactive Extrude Tool", чтобы объем создавался назад с уменьшением. Возможно, у вас уже выбран этот вариант. Правее расположен список для установки размера объема, но проще изменить размер с помощью мыши. Далее мы изменим положение точки схода. Точкой схода называется маркер, который определяет глубину для параллельного выдавливания или место, в котором грани, придающие объем, сойдутся при удлинении для других типов выдавливания. Точка схода отображается на рисунке как перекрестие. Так как мы выбрали выдавливание назад с уменьшением, точка схода показывает на место, где грани сойдутся. Перетащите с помощью мыши точку схода и проследите, как изменится внешний вид объекта (Рис. 15.13, слева).

Рис. 15.13. Редактирование объема

Перетащите контурный прямоугольник, расположенный на векторе настройки объема, ближе к концу вектора. Этим мы удлинили грани, придающие объем (Рис. 15.13, справа). Щелкните мышью на значке перекрестие в начале вектора объема. Вокруг объекта появится пунктирный круг с треугольниками, предназначенный для вращения объемных объектов (Рис. 15.14). Для вращения, как и для других трансформаций в CorelDRAW 10, следует нажать левую кнопку мыши и, не отпуская ее, переместить мышь, после чего отпустить кнопку. Если указатель мыши при нажатии располагался внутри пунктирного круга и имел вид перекрещенных стрелок, то поворот будет выполнен относительно точки в центре объемного объекта (Рис. 15.15, слева). Если же указатель загнутую стрелку находился вне пунктирного круга и имел вид загнутой стрелки , поворот производится относительно линии, проходящей через центр объекта и точку схода (Рис. 15.15, справа).

Рис. 15.14. Режим вращения объема

Рис. 15.15. Различные варианты вращения объема

Поверните объект обоими способами, чтобы получить приблизительно такой результат (Рис. 15.16).

Рис. 15.16. Результат поворота

Пока мы работали с объемом, имеющим только контур. Давайте раскрасим наш объект. Нажмите кнопку "Color" в панели Property Bar (Панель свойств). Рядом с кнопкой появится вспомогательная панель с элементами настройки цветов объема (Рис. 15.17, сверху).

Рис. 15.17. Вспомогательные панели настройки цвета и скоса

Имеется три варианта заливки вновь созданных объемов, каждому из которых соответствует кнопка во вспомогательной панели. Заливкой исходного объекта, которой соответствует кнопка "Extrude Rotation" , однородной заливкой любого цвета, вызываемой кнопкой "Extrude Rotation" и переходом цветов, который вызывается кнопкой "Interactive Extrude Tool" . Мы выберем переход цветов, чтобы получить наиболее оригинальный рисунок. Нажмите кнопку "Interactive Extrude Tool" во вспомогательной палитре для выбора перехода цветов. В поле From (От) с помощью открывающегося списка выберите черный цвет/ а в поле То (К) выберите белый цвет. Теперь боковые грани закрашены переходом цвета, но передняя сторона осталась прозрачной (Рис. 15.18, слева). Щелкните мышью на черном цвете в палитре, и передняя сторона объемного объекта закрасится (Рис. 15.18, второй слева). Нажмите кнопку "Bevels" в панели Property Bar (Панель свойств). Рядом с кнопкой появится вспомогательная панель с элементами настройки скоса краев (Рис. 15.17, в центре). Скосить углы можно только на передней стороне объемного объекта. Боковые и задние грани всегда получаются без скосов.

Рис. 15.18. Раскрашивание и скос края

Установите флажок Use Bevel (Применить скос) во вспомогательной палитре и перетащите мышью кружок в рисунке для настройки ширины и угла скоса. Теперь наша объемная фигура имеет скос (Рис. 15.18, второй справа). Вы можете также установить размер и угол наклона скаса с помощью соответствующих полей в диалоге. Отметим, что при нажатой кнопке "Interactive Extrude Tool" во вспомогательной панели настройки цвета скос имеет цвет объемных граней, а при отжатой кнопке можно установить любой цвет для скоса с помощью расположенного рядом элемента. Установите флажок Show Bevel Only (Показывать только скос) и вы увидите только скос, без боковых граней (Рис. 15.18, справа). Таким способом можно создавать рисунки табличек. Если при этом вы не используете заливку исходного объекта, то увидите один лишь скос. уберите флажок Show Bevel Only (Показывать только скос), чтобы вернуть на место боковые грани. Далее мы добавим к объемной фигуре падающий сбоку свет от дополнительного источника света. Нажмите кнопку "Lighting" в панели Property Bar (Панель свойств). Рядом с кнопкой появится вспомогательная панель для настройки источников света (Рис. 15.17, слева). Эта панель позволяет создавать и регулировать направление и интенсивность освещения трех источников света. Вы как бы помещаете три лампочки в разных местах, чтобы лучше осветить созданный объемный объект. Нажмите кнопку "Lighting #1" в панели. Вы добавили первый источник света, который показан черным кругом с номером 1 в углу области просмотра. Сфера в центре контурного куба в поле предварительного просмотра представляет собой объемный объект, на котором вы можете увидеть результат работы источников света. Установите указатель мыши на изображении источника света, нажмите кнопку мыши и, не отпуская ее, перетащите изображение источника света в передний верхний левый угол контурного куба. В поле Intensity (Интенсивность) введите значение 80, что означает, что источник светит на восемьдесят процентов от полной силы. Теперь различные грани объемного объекта имеют различный оттенок. Если не установлен флажок Use full color range (Использовать полный цветной диапазон), слабо освещенные места окрасятся в черный цвет. При установленном флажке неосвещенные участки примут свой исходный цвет. В любом случае, яркое освещение может осветлить все оттенки в созданном объеме. Аналогично вы можете настроить еще два источника света, нажимая кнопки "Lighting #2" и "Lighting #3" Если вы придаете объем более сложным объектам, чем прямоугольник, источники света могут дать очень красивый результат. Выберите инструмент "Pick Tool" и, щелкните мышью на свободном месте, чтобы убрать с экрана управляющие элементы и посмотреть на результат своей работы (Рис. 15.19).

Рис. 15.19. Применение источника света

Особенно красиво выглядит применение объема к фигурному тексту. С помощью этого эффекта вы можете получить как бы выпуклые или выдавленные надписи.


15.4. Фигурная обрезка

В CorelDRAW 10 имеется возможность помещать один объект внутри другого. Объект, внутри которого размещаются другие объекты, называется контейнером, а размещенные объекты содержимым контейнера. Контейнер и его содержимое могут быть стандартным объектом, замкнутыми кривыми, группами объектов или фигурным текстом. Так как содержимое обрезается по контуру контейнера, эта операция называется фигурной обрезкой. Фигурная обрезка может также использоваться для размещения растровых изображений, в контейнерах произвольной формы. В результате мы получим оригинальную нестандартную заливку. Рассмотрим применение фигурной обрезки на примере объемного объекта, созданного нами ранее. Создайте прямоугольник меньшего размера, чем объемный объект. Этот прямоугольник будет контейнером. Выберите инструмент "Pick Tool". Подведите указатель мыши к объемному объекту. Нажмите правую (а не левую) кнопку мыши, и, не отпуская ее, начните передвигать мышь. Подведите указатель мыши к созданному только что прямоугольнику, внутри которого мы собираемся поместить объект. Указатель изменит вид на мишень. Отпустите правую кнопку мыши. На экране появится контекстное меню. Выберите команду контекстного меню Power-Clip Inside (Поместить в контейнер). Объемный объект будет расположен внутри контура прямоугольника. При этом содержимое располагается по центру контейнера, а все выступающие за контур части становятся невидимыми. Вы можете отредактировать содержимое контейнера. Щелкните на контейнере правой кнопкой мыши и во вспомогательном меню выберите команду Edit Contents (Редактировать содержимое). Контур объекта - контейнера стал синего цвета, и на экране появился объемный объект. Переместите объемный объект, чтобы его угол был виден в контейнере. Щелкните на контейнере правой кнопкой мыши и во вспомогательном меню выберите команду Finish Editing This Level (Завершить редактирование). Теперь виден только кусок объекта, ограниченный контейнером. Растяните контейнер по горизонтали. Обратите внимание, что содержимое контейнера изменилось вместе с прямоугольником, который является контейнером. Щелкните на контейнере правой кнопкой мыши и во вспомогательном меню выберите команду Extract Contents (Извлечь содержимое). Теперь два объекта снова стали независимыми, причем прямоугольник оказался под объемным объектом. Далее мы используем эти два объекта для демонстрации эффекта линз.


15.5. Линзы

Эффект линзы преобразует изображение, расположенное под объектом, к которому был применен этот эффект. С помощью линзы можно изменить яркость, цвет и геометрию объектов. Линзу могут иметь только замкнутые объекты, а смотреть через линзу можно на любые объекты. Разнообразные варианты линз применяются достаточно широко. С помощью этого эффекта можно быстро смоделировать прозрачность, усиление цвета, фильтрацию цвета, полутоновое и инфракрасное изображение, а также увеличить и исказить изображение. Всего в CorelDRAW 10 имеется более десятка различных линз. Рассмотрим на примере применение эффекта. Выделите прямоугольник, созданный в предыдущем примере. Нажмите кнопку "To Front" на панели Property Bar (Панель свойств), чтобы поместить его поверх объемного объекта. Выберите команду меню Effects/Lens (Эффекты/Линза). На экране появится закрепление для работы с линзами .

Рис. 15.20. Закрепление Lens (Линза)

В поле предварительного просмотра, расположенном в верхней части закрепления, можно увидеть результат применения эффекта. Ниже располагается список эффектов, то есть перечень разнообразных линз. В зависимости от выбранной линзы, в закреплении появляются дополнительные поля настройки. Вы можете настроить прозрачность, степень применения эффекта и цвет линзы, а также некоторые дополнительные параметры. Если кнопка замок в нижней части закрепления нажата, и на ней нарисован закрытый замок, то сразу после ввода значений в поля закрепления сразу будет применен эффект линзы. Отжав кнопку замок вы измените рисунок на ней. Теперь замок открыт замок. В этом случае следует нажать кнопку Apply (Применить) после изменения полей, чтобы эффект вступил в силу. Отожмите кнопку, чтобы не пересчитывать эффект после изменения каждого параметра линзы. Выберите в списке, расположенном под образцом, эффект Fish Eye (Рыбий глаз). Нажмите кнопку Apply (Применить), и выбранный эффект будет придан прямоугольнику. При этом объемный объект на заднем фоне изменит свою форму. Мы смотрим на этот объект как бы через рыбий глаз. Введите в поле Rate (Уровень) значение 200, после чего снова нажмите кнопку Apply (Применить). Изображение будет искажено еще сильнее. Выберите в списке вариантов линз Color Limit (Цветной фильтр). В закреплении появятся поля для настройки степени прозрачности фильтра и его цвета. В поле Rate (Уровень) введите значение 70 процентов, а в поле Color (Цвет) выберите желтый цвет. Вы настроили фильтр желтого цвета семидесяти процентной интенсивности. Нажмите кнопку Apply (Применить), и заливка прямоугольника изменится на желтую, но при этом объемный объект все равно будет виден, хотя и несколько изменит свой цвет. Нажмите кнопку плюс. расположенную справа на цифровом блоке вашей клавиатуры. Прямоугольник будет продублирован в виде нового объекта, и у его копии также будет присутствовать эффект линзы. Выберите в списке вариантов линз< Magnify (Увеличение) и нажмите кнопку Apply (Применить). Вы увидите суммарный эффект от двух линз: цветной фильтр добавил желтый цвет, а вторая линза все увеличила, но в отличии от эффекта рыбьего глаза, при увеличении не вносятся искажения в рисунок . Нажмите клавишу "Tab" чтобы выделить исходный прямоугольник, которому назначен цветной фильтр. Установите в закреплении флажок Remove Face (Пропускать пустоты) и нажмите кнопку Apply (Применить). Теперь эффект линзы применяется только к объектам, а пустое место остается белым, не меняя цвет на желтый. Рассмотрим еще один интересный эффект. Выделите верхний прямоугольник. Для этого сначала снимите выделение, после чего щелкните на нем мышью. Установите флажок. Frozen (Застывшая), затем нажмите кнопку Apply (Применить). Теперь линза как бы запомнила изображение. Переместите выделенный прямоугольник ниже, и вы увидите, как изображение переместилось вместе с линзой. Эффект линзы дает замечательную возможность создания сложных иллюстраций. Например, если использовать фигурный текст в качестве линзы, то можно получить полупрозрачную надпись, из-за которой будет проглядывать фоновый рисунок. В качестве фона особенно красиво смотрятся растровые рисунки. В CorelDRAW 10 имеется множество различных линз, и вы можете создать с их помощью достаточно интересные рисунки, а в следующем примере мы опишем еще один оригинальный эффект.


15.6. Интерактивная прозрачность

Эффект, получаемый с помощью инструмента интерактивной прозрачности, похож одновременно на линзу и на заливку объекта, причем заливка происходит полупрозрачными красками. Особенно красиво выглядят полупрозрачные узоры, текстуры и градиенты. Как и линзы, прозрачность объектов часто используют для создания просвечивающих надписей, расположенных поверх растровых или векторных рисунков. При этом лучше смотрятся полупрозрачные надписи, окрашенные в пастельные тона, расположенные поверх ярких фоновых изображений. Применение крупных текстур добавляет оригинальности иллюстрации. Нарисуйте эллипс, закрывающий половину объемного объекта, и залейте его красным цветом. Выберите инструмент "Interactive Transparensy Tool" во вспомогательной панели интерактивных инструментов для добавления эффектов. Подведите указатель мыши к левой стороне эллипса, нажмите кнопку мыши, и, не отпуская ее, передвиньте мышь к правой стороне, после чего отпустите кнопку мыши. Эллипс станет частично прозрачным, и на экране появится вектор настройки . Большинство элементов управления панели Property Bar (Панель свойств) при работе с инструментом интерактивной прозрачности "Interactive Transparensy Tool" такие же, как и при настройке заливок. Вы можете выбрать однородную, градиентную, текстурную заливку или залить объект узором. При этом все заливки будут прозрачными. Кнопка "Interactive Transparensy Tool" | в панели Property Bar (Панель свойств) предназначена для вызова диалога настройки прозрачной заливки, который очень похож на диалог настройки любой другой заливки. Нажатие кнопки "Freeze" заморозит изображение, как и при работе с линзами. Так же, как и при использовании интерактивной заливки, вы можете редактировать эффект изменением вектора настройки. Удобнее всего для настройки прозрачности использовать поля панели Property Bar (Панель свойств). Выберите в списке вариантов заливки Texture (Текстура), а в следующем списке выберите библиотеку текстур Styles (Стили). В списке текстур выберите рисунок кругов на воде. Теперь эллипс залит полупрозрачными красными кругами. Щелкните мышью на желтом цвете в палитре для изменения цвета и щелкните правой кнопкой мыши в палитре на элементе крест чтобы убрать контур эллипса. Вид объекта сильно изменится. Мы видим объемный объект сквозь желтые полупрозрачные круги. Установите с помощью ползунка в поле панели Property Bar (Панель свойств) значение 40. Мы назначили минимальную прозрачность объекта. Теперь в самых непрозрачных местах все же на сорок процентов заливка прозрачна. Установите в поле максимальную степень прозрачности объекта равную 100. Это означает, что в самых прозрачных местах наша заливка совершенно прозрачная. Меняя минимальную и максимальную прозрачность, можно устанавливать степень применения эффекта. В списке вариантов прозрачности, расположенном в левой части панели Property Bar (Панель свойств), выберите Lightness (Светлость). Теперь заливка эллипса осветляет находящиеся под ним предметы. Так как белый фон и так светлый, то осветление заметно только на объектах. Выберите инструмент "Pick Tool" и щелкните мышью на свободном месте, чтобы убрать с экрана управляющие элементы и посмотреть на результат своей работы. В самом правом списке панели Property Bar (Панель свойств) выбирается часть объекта, к которой применяется эффект. Вы можете сделать прозрачным весь объект или только контур или заливку. Эффекты линзы и прозрачности дополняют друг друга, и с их помощью можно получить оригинальные и красивые иллюстрации.


15.7. Создание теней объектов

Хотя тень объекта можно имитировать приданием ему объема, удобнее воспользоваться специальным инструментом для создания падающей от объекта тени. Так можно создавать полупрозрачные тени, размытые по краям и падающие в разных направлениях. Создайте объект фигурного текста. Выберите инструмент "Interactive Drop Shadow Tool" во вспомогательной панели интерактивных инструментов. Установите указатель мыши в центре созданного объекта, нажмите кнопку мыши, и, не отпуская ее, передвиньте мышь в сторону. На экране появятся контуры тени и вектор настройки (Рис 15.21, слева). Отпустите кнопку мыши, и тень объекта будет нарисована (Рис. 15.21, в центре).

Рис. 15.21. Создание тени объекта

Перетащите конец вектора, чтобы изменить направление падения тени. Контурный прямоугольник, расположенный в середине вектора настройки/ перетащите ближе к концу вектора, чтобы тень стала менее прозрачной. Установите в поле "Interactive Transparensy Tool" панели Property Bar (Панель свойств) значение 50, чтобы получить полупрозрачную тень. Установите в поле панели Property Ваг (Панель свойств) значение 60, чтобы получить размытые границы тени (Рис. 15.22, справа). Уменьшите до 20 значение размытости в поле Перетащите мышью значок в начале вектора настройки тени к нижней границе текста. Тень примет совершенно другую форму (Рис. 15.22). Аналогично можно перетащить начало вектора к верхней или боковой границе/ и тень будет падать в соответствующую сторону.

Рис. 15.22. Другой вариант тени

Чтобы удалить тень, следует нажать кнопку "Cleare" в панели Property Bar (Панель свойств), но мы не будем делать этого, а продолжим наши эксперименты.


15.8. Художественная обводка

При описании создания различных объектов рассказывалось об использовании художественного пера. Вы можете использовать различные заготовки при рисовании линий этим инструментом. Эти же заготовки можно использовать для изменения контура любого объекта. Как произвольный векторный объект, так и стандартный объект или автофигура, сильно изменятся, если вместо контура у них появятся разнообразные рисунки (Рис. 15.23).

Рис. 15.23. Примеры художественной обводки

Чтобы применить к любому объекту художественную обводку, следует выделить его и выбрать команду меню Effects/Artistic Media (Эффекты/Художественные средства). На экране появится закрепление для настройки обводки (Рис. 15.24). В нижней части закрепления содержится список всех доступных заготовок, которые вы можете применить для изменения контура. Список в верхней части закрепления содержит последние использованные вами заготовки. Значок в левой части каждой строки указывает на тип заготовки.

Рис. 15.24. Закрепление для выбора художественной обводки

Выбрав заготовку из любого списка, нажмите кнопку Apply (Применить), и художественная обводка изменит выделенный объект. При этом в многочисленных полях панели Property Bar (Панель свойств) можно настроить параметры выбранной обводки. Работа с этими полями не отличается от настроек художественного пера.


16. Работа с растровыми изображениями

В CorelDRAW 10 включены мощные средства для работы с Растровыми изображениями. Вы можете вставить растровый рисунок в графический документ, преобразовать векторный объект в растровый и трассировать растровое изображение, чтобы получить на его основе векторный рисунок. Кроме того, вы можете выполнить различные преобразования растровых рисунков непосредственно в CorelDRAW. Многочисленные художественные эффекты растровой графики помогут в создании красивых иллюстраций.

16.1. Преобразование в растровую графику

Вы можете вставить в любой документ CorelDRAW 10 растровое изображение. Кроме того, любой объект или группу объектов можно преобразовать в объект растровой графики. После преобразования его нельзя будет редактировать, как векторный объект, но к нему можно будет применить эффекты растровой графики. В большинстве случаев это преобразование и выполняется для использования художественных эффектов, которые работают только с растровой графикой. Создайте несколько векторных объектов и выделите их. Мы преобразуем эти объекты в растровое изображение. Выберите команду меню Bitmaps/Convert to Bitmaps (Растровые изображения/Преобразовать в растровое изображение). На экране появится диалог настройки такого преобразования (Рис. 16.1). Он напоминает диалог экспорта, рассмотренный нами ранее.

Рис. 16.1. Диалог преобразования в растровую графику

В группе полей Color (Цвет) вы устанавливаете количество цветов, которое будет получено. Понятно, что при большем количестве цветов качество рисунка увеличивается, но также растет и размер объекта растровой графики. Если установить флажок в поле Dithered (Смешанный), некоторые оттенки цветов будут достигаться смешением нескольких цветов. То есть вместо точек одного цвета в итоговом рисунке на том же месте могут быть несколько разноцветных точек. В поле Resolution (Разрешение) задается разрешение рисунка в точках на дюйм, флажок Anti-aliasing (Сглаживание) предназначен для создания более гладких изображений путем удаления изломов из исходного рисунка. Флажок Transparent Background (Прозрачный фон) создает прозрачный фон рисунка. Ожидаемый размер объекта при установленных параметрах будет показан в нижней части диалога. Установите в поле Color (Цвет) значение RGB Color (24 bit) (RGB цветной/ 24 разряда), и, не меняя остальных параметров, нажмите кнопку ОК. Диалог закроется, и объект будет преобразован в растровое изображение. При этом никаких изменений на экране не произойдет, если вы не выбрали слишком низкое разрешение растрового рисунка. Но вы больше не можете перемещать отдельные объекты, редактировать узлы и выполнять прочие операции. Все векторные объекты/ выделенные до операции преобразования, превратились в единый растровый рисунок. Теперь к нему можно применить эффекты растровой графики.


16.2. Трассировка растровых изображений

Вы можете любой растровый объект, вставленный в документ CorelDRAW 10, преобразовать в векторный. Преобразование проводится с помощью программы CorelTRACE 10, входящий в состав пакета программ CorelDRAW 10. Чтобы выполнить преобразование, этот компонент пакета программ должен быть установлен на вашем компьютере. В противном случае необходимо выполнить повторную установку пакета/ чтобы добавить компонент CorelTRACE 10. Преобразуйте векторный объект в растровое изображение или вставьте растровый рисунок из файла. Далее мы создадим на его основе группу векторных объектов. Выделите растровый рисунок и нажмите кнопку "Trace Bitmap" на панели Property Bar (Панель свойств). В отдельном окне запустится программа трассировки CorelTRACE 10, в которую загрузится выделенный вами рисунок (Рис. 16.2). Растровый рисунок/ который вы хотите преобразовать, будет показан в левой части рабочей области программы.

Рис. 16.2. Окно программы трассировки

Вы имеете много возможностей по настройки операции трассировки, однако можно предоставить программе, выполнить все действия автоматически. Нажмите кнопку "To Trace" расположенную в верхней панели инструментов, и будет запущен процесс трассировки. По его окончании в правой части рабочей области программы появится созданный векторный рисунок. Возможно, он будет достаточно сильно отличаться от оригинала. Вы можете попытаться улучшить качество трассировки, изменив с помощью ползунка значение в поле "Accuracy", расположенном рядом с кнопкой "To Trace". В этом поле определяется точность трассировки. Чем выше точность, тем больше векторный рисунок похож на исходное изображение, но, вместе с тем, тем больше создается векторных объектов. Простой рисунок, при установленном значении 10 в поле "Accuracy" (Рис. 16.3, слева), содержит всего несколько десятков объектов. При этом качество рисунка очень низкое. Если установить в поле "Accuracy" значение 100, то качество рисунка существенно повысится (Рис. 16.3, в центре). Однако это достигается увеличением количества составляющих векторных объектов до десятков тысяч. Работа с таким количеством объектов потребует мощного компьютера, и даже на нем некоторые операции займут очень много времени.

Рис. 16.3. Разные варианты трассировки

В левой части рабочего окна программы расположена панель инструментов с несколькими кнопками, которые позволяют выбрать иные методы трассировки. Например, выбрав кнопку "Scetch" и нажав после кнопку "Outline" в верхней панели, вы создадите эскиз рисунка из множества пересекающихся линий (Рис. 16.3, справа). Для настройки трассировки рекомендуется расширенный режим, в который вы можете перейти, нажав кнопку "Advansed Outline" в левой панели. В верхней части окна программы появятся несколько полей/ позволяющих произвести точную настройку трассировки. Самостоятельно познакомьтесь с различными вариантами преобразования растровых изображений в векторные объекты. После того, как вы добились требуемого качества трассировки, вернитесь в CorelDRAW. Для этого следует в CorelTRACE выбрать команду меню File/Exit (Файл / Выход). Программа завершит работу, и передаст полученный векторный рисунок CorelDRAW. Векторный рисунок расположится над растровым, при этом исходный растровый рисунок не будет удален. Чтобы увидеть его, следует отодвинуть в сторону вновь созданный векторный объект. Если исходный растровый рисунок вам больше не нужен, лучше удалите его, чтобы не занимать дополнительное место в памяти и на диске.

Примечание:

Качественные векторные рисунки, полученные с помощью трассировки, могут содержать тысячи объектов и занимать в памяти и на диске больше места, чем исходный растровый рисунок.

Полученные в результате трассировки векторные рисунки представляют собой группу объектов, с которыми вы можете выполнять все действия, описанные выше в книге. Разгруппировав объекты, вы можете удалить некоторые из них, поменять цвет и форму других объектов. Так можно получить высококачественный векторный рисунок, который будет даже лучше исходного растрового изображения.


16.3. Редактирование растровых рисунков

Вы можете вставить растровый рисунок в документ CorelDRAW 10, или преобразовать векторные объекты в растровый. В любом случае вам доступны некоторые инструменты редактирования растровых изображений. Следует помнить, что полноценная работа с растровой графикой возможно только в специализированном графическом редакторе растровой графики. Создайте или вставьте растровый рисунок в документ и выделите его. В панели Property Bar (Панель свойств) при этом появятся несколько кнопок для выполнения различных преобразований графики. Нажав кнопку "Edit Bitmap" вы запустите редактор растровой графики Corel PHOTO-PAINT 10, и сможете в нем отредактировать выделенный графический объект. По окончании редактирования следует вернуться в CorelDRAW, выбрав команду меню File/Exit (Файл/Выход). Так как и CorelDRAW 10 и Corel PHOTO-PAINT 10 требуют значительных вычислительных мощностей, иногда удобнее не работать с обеими программами одновременно, а сохранить на диске рисунок, отредактировать его в редакторе растровой графики, после чего импортировать в документ CorelDRAW 10. Растровый рисунок, как и любой другой объект в CorelDRAW 10, можно увеличивать и уменьшать, перетаскивая мышью прямоугольники выделения. Однако сам объект при этом не изменится, а поменяется только его представление. Например, вставив рисунок из большого графического файла и уменьшив его в несколько раз, вы не сэкономите места в памяти и на диске. Для уменьшения количества используемой памяти необходимо изменить параметры растрового изображения.

Примечание:

Не рекомендуется сильно растягивать или сжимать растровый рисунок, так как при этом возможна потеря качества изображения. Лучше трассировать рисунок, после чего изменить его размер.

Нажав кнопку "Resample the Bitmap" панели Property Bar (Панель свойств), вы откроете диалог настройки размеров и разрешения растрового рисунка (Рис. 16.4). В этом диалоге вы можете установить точные значения ширины и высоты растрового объекта, а также его разрешение. При установленном флажке Anti-alias (Сглаживание) сглаживать границы во время преобразования. Флажок Maintain aspect ratio (Сохранить пропорции) позволяет сохранить пропорции при изменении размеров, убрав этот флажок, вы можете изменить размеры по горизонтали и по вертикали в разной степени. Флажок Maintain original size (Сохранить исходный размер) связывает размер рисунка и разрешение. Увеличивая размеры, вы уменьшаете разрешение и наоборот. При этом фактически преобразований исходного рисунка не происходит, меняется только его представление.

Рис. 16.4. Диалог изменения параметров растрового рисунка

Установив нужные параметры/ нажмите кнопку ОК, диалог закроется, и растровый объект будет изменен. Возможно, внешне ничего не изменится, но внутреннее представление объекта станет иным.


16.4. Использование цветовых масок

С помощью кнопки "Bitmap Color Mask Docker Window" панели Property Ваг (Панель свойств) открывается закрепление Bitmap Color Mask (Цветовая маска растрового изображения) (Рис. 16.5), с помощью которого вы можете сделать прозрачными или наоборот, показать, некоторые оттенки выделенного растрового рисунка. Переключатель, расположенный в верхней части закрепления, позволяет выбрать режим работы. Положение Hide Colors (Скрыть цвета) позволяет вам указать цвета, который должны стать невидимыми. Все остальные цвета останутся без изменений. Наоборот, в положении переключателя Show colors (Показать цвета), вам следует указать нужные цвета. Все остальные цвета и оттенки будут убраны. Установив переключатель в нужное положение, следует указать один или несколько цветов. Установив флажок в одной из строк списка цветов, выберите нужный цвет. Вы можете нажать кнопку "Eyedroope Tool" в закреплении, после чего щелкнуть мышью на нужном цвете в рисунке. Также можно выбрать цвет в появившемся диалоге, не отличающемся от аналогичных диалогов выбора цвета в CorelDRAW 10.

Рис. 16.5. Закрепление Bitmap Color Mask (Цветовая маска растрового изображения)

В поле Tolerance (Толерантность) устанавливается степень соответствия выбираемых цветов указанному вами оттенку. При малом значении толерантности будут выбраны участки только указанного цвета. При увеличении толерантности, будут выбираться участки, закрашенные похожими оттенками цвета. После определения одного или нескольких цветов, нажмите кнопку Apply (Применить), чтобы цветовая маска была применена к выделенному растровому рисунку. Если вы выбрали режим сокрытия цветов, то вместо удаленных цветов в рисунке появятся прозрачные области, через которые будет видны расположенные под ним объекты. Нажав кнопку с изображением мусорной корзины вы удалите созданную ранее маску. Так как растровые изображения всегда имеют прямоугольную форму, иногда бывает трудно скомпоновать из них нужную иллюстрацию. Нужная часть рисунка обрамляется по краям белой непрозрачной рамкой. Применяя цветовые маски, вы можете удалить белые поля вокруг рисунков, таким способом создавая растровые изображения любой формы.


16.5. Дополнительные средства изменения растровых объектов

Вы можете преобразовать растровый рисунок, увеличив или уменьшив глубину цвета. Для этого выберите команду меню Bitmaps/Mode (Растровые изображения/Режим) и в появившемся меню выберите один из вариантов глубины цвета. Некоторые преобразования не потребуют дополнительных сведений, но в некоторых случаях вам потребуется определить параметры преобразования. Например, при выборе команды Black and White (Черно-белое), на экране появится диалог выбора метода преобразования цветного рисунка в черно-белое изображение (Рис. 16.6).

Рис. 16.6. Диалог настройки преобразования

В этом диалоге, как и во многих других, вы можете увидеть исходный рисунок и результат преобразований в больших полях просмотра. Если в диалоге вместо двух полей просмотра одно большое, нажмите кнопку в заголовке окна, чтобы перейти в режим работы с двумя полями. В списке Conversion (Преобразование) выбирается метод превращение цветного рисунка в черно-белый. В зависимости от выбранного метода, в диалоге появляются дополнительные поля настройки. С помощью этих полей можно сильно изменить параметры преобразования, и получить самые разные результаты. Выбор подходящего метода и его настройка является очень важной процедурой, так как результаты превращения цветного рисунка в черно-белый сильно различаются качеством (Рис. 16.7).

Рис. 16.7. Варианты черно-белого преобразования

Нажав кнопку Preview (Просмотр), вы сможете увидеть предварительный результат преобразования для выбранных параметров. Перетаскивая мышью исходное изображение, вы увидите разные фрагменты результата, если рисунок не помещается полностью в поле просмотра. Чтобы увеличить масштаб просмотры, вы можете щелкнуть мышью на интересующей вас детали рисунка. Нажмите кнопку ОК, чтобы закрыть диалог и выполнить выбранное преобразование растрового объекта. Вы можете отменить изменения растрового рисунка, но следует помнить, что CorelDRAW 10 помнит значительно меньше последних изменений растровых объектов, чем векторных. Если вы не меняли настроек, то запоминаются только два последних преобразования растровых объектов в документе. Иногда возникает необходимость добавления полей к рисунку. Выбрав команду меню Bitmaps/Inflate Bitmap/Manually Inflate Bitmap (Растровые изображения^Расширить рисунок/ Вручную расширить рисунок), вы откроете диалог добавления полей (Рис. 16.8).

Рис. 16.8. Диалог добавления полей крисунки

Установив новые значения ширины и высоты, и нажав кнопку ОК, вы увеличите рисунок. Однако в отличие от описанных ранее способов, изображение не будет растянуто. Просто по его краям появятся белые полосы. В некоторых случаях CorelDRAW 10 автоматически добавляет поля при выполнении эффектов. Чтобы включить эту функцию, надо выбрать команду меню Bitmaps/Inflate Bitmap/Auto Inflate Bitmap (Растровые изображения/Расширить рисунок /Автоматически расширить рисунок). Рядом с командой меню появится галочка. Повторный выбор этой команды меню приведет к отмене данного режима.


17. Эффекты для растровых изображений

Некоторые эффекты в CorelDRAW 10 вы можете применить исключительно к растровым объектам. К ним относятся операции преобразования цвета, трансформации рисунков и многочисленные художественные эффекты.

17.1. Коррекция цвета

Для эффективной работы с растровыми изображениями необходимы мощные и надежные средства преобразования цветов и оттенков. Графический редактор CorelDRAW 10 предоставляет многочисленные и разнообразные средства обработки цветных растровых объектов. Хотя некоторые эффекты и позволяют работать с векторными объектами, все же основное применение эффектов преобразования цвета - это обработка растровых рисунков. Начнем их рассмотрение с настройки контрастности объекта растровой графики. Выделите такой объект и выберите команду меню Effects/Adjust/Contrast Enhancement (Эффекты/Коррекция/Расширенная контрастность). На экране появится диалог настройки контрастности (Рис. 17.1).

Рис. 17.1. Диалог настройки контрастности

Перед рассмотрением конкретных полей диалога немного остановимся на общих принципах работы с диалогами настройки растровых эффектов. Все эти диалоги могут работать в трех различных режимах, переключение между которыми осуществляется с помощью двух дополнительных кнопок, расположенных в заголовке диалога. Эти кнопки расположены в правой части заголовка, немного левее кнопок крес и вопрос. Кстати, нажав кнопку вопрос и щелкнув на любом поле в диалоге, вы можете получить справку о данном параметре. Нажав кнопку расположенную левее, вы перейдете в режим работы с дополнительными полями просмотра (Рис. 17.2). Рисунок на кнопке при этом изменится на другой. Нажав эту кнопку вы уберете поля предварительного просмотра из диалога (Рис. 17.1).

Рис. 17.2. Различные варианты диалога настройки эффектов

При работе с полями просмотра вы можете переключится в режим работы с одним полем (Рис. 17.2, снизу), нажав правую кнопку квадрат. Рисунок на этой кнопке изменится на другой. Нажав правую кнопку вы переключитесь в режим работы с двумя полями (Рис. 17.2, сверху). В этом режиме в правом поле показывается исходный рисунок, а в левом - результат преобразований. Если вы работаете с одним полем, в нем выводится результат преобразований. В случае использования диалога без дополнительных полей просмотра, предварительный результат можно увидеть непосредственно в документе, нажав в диалоге кнопку Preview (Просмотр). Выбор того или иного вида диалога зависит от ваших вкусов, так как работа с диалогом при этом не меняется. В дальнейшем все диалоги будут показываться без дополнительных полей, но вы можете выбирать наиболее удобный вам тип работы с диалогами настройки эффектов. После этого отступления рассмотрим настройку контрастности в полях соответствующего диалога. В этом диалоге объединены несколько методов изменения контрастности изображения. Вы можете выбрать один из них, или воспользоваться несколькими методами одновременно. С помощью ползунка Gamma Adjustment (Регулирование гаммы) вы можете изменить яркость и контрастность рисунка без потери в полутонах. Уменьшая значение гаммы, вы затемняете рисунок, а увеличивая - осветляете его. С помощью гистограммы вы можете вручную изменить баланс цвета и тени в рисунке. Гистограмма показывает предел и распределение полутонов в изображении. Два треугольника в верхней части гистограммы задают диапазон входных значений. Все тона, попавшие за границы этого диапазона, будут считаться белыми или черными, если нижние треугольники расположены по краям гистограммы. Передвигая нижние треугольники, вы меняете выходные значения. Например, самый темный оттенок, соответствующий правому верхнему треугольнику, будет отображаться черным цветом, если правый нижний треугольник стоит в крайней правой позиции. Если же он перемещен левее, то этот оттенок будет отображаться серым цветом. Аналогично, левый нижний треугольник описывает самые светлые оттенки. Рисунок гистограммы описывает реальные цвета, присутствующие в изображении. Сбалансированное изображение имеет все оттенки и пик в центре гистограммы. Вы можете установить входные и выходные границы в гистограмме, перетаскивая с помощью мыши соответствующие треугольники, или введя конкретные значения в поля ввода. Нажав кнопку "Eyedrooper Tool" и щелкнув мышью на самом темном участке рисунка, вы определите границу тени. Соответственно, нажав кнопку "Eyedrooper Tool" и щелкнув мышью на самом светлом участке, вы определите границу света. При этом, если переключатель в диалога установлен в положении Set input values (Задать входные значения), то устанавливается диапазон входных значений. Положение переключателя Set output values (Задать выходные значения) позволяет установить выходной диапазон. Изменить оттенки рисунка можно по отдельным цветовым каналам. Для этого следует выбрать нужный канал в списке Channel (Канал). Установив флажок Auto-adjust (Автокоррекция), вы можете попытаться автоматически улучшить баланс цветов в рисунке. устанавливая разные варианты параметров, вы можете увидеть результат коррекции, нажимая кнопку Preview (Просмотр). В зависимости от используемого варианта диалога, результат будет показан в поле диалога или непосредственно в редактируемом графическом документе. Добившись требуемого результата, нажмите кнопку ОК, и оттенки растрового объекта изменятся. Другим фильтром для коррекции цвета является фильтр локального выравнивания. Он позволяет увеличить контрастность изображения вблизи перехода цветов и выделить детали рисунка. Выберите команду меню Effects/Adjust/Local Equalization (Эффекты/Коррекция/Локальное выравнивание). На экране появится диалог настройки фильтра (Рис. 17.3).

Рис. 17.3. Настройка фильтра локального выравнивания

С помощью ползунков вы устанавливаете размер локальной области, внутри которой следует провести выравнивание. Увеличение значения приведет к выделению только крупных деталей, а уменьшение позволит выделить все мелкие детали. При выделении мелких деталей рисунок может существенно изменить свой вид. Выравнивание мелких областей изменит их Цвет случайным образом и добавит в рисунок множество мелких пятен. При использовании больших областей выравнивания повысится контрастность изображения, так как пропадут промежуточные цвета в цветовых переходах. Отжав кнопку замок в Диалоге, вы сможете устанавливать разные размеры области выравнивания по горизонтали и по вертикали, чтобы использовать прямоугольные, а не квадратные области. Выбрав команду меню Effects/Adjust/Sample/Target Balance (Эффекты/Коррекция/Баланс выбранных цветов), вы откроете одноименный диалог (Рис. 17.4), позволяющий настраивать баланс цветов и оттенков рисунка.

Рис. 17.4. Диалог Sample/Target Balance(Баланс выбранных цветов)

В нем можно изменить цветовую гамму растрового изображения. Щелкая мышью на нужных цветах в рисунке, вы задаете светлые, промежуточные и темные цвета. Выбранный цвет появляется в поле Sample (Выборка). Щелкнув мышью на цвете в поле Target (Цель), вы откроете диалог выбора цвета. Задайте в нем новый цвет, заменяющий старый в рисунке. После задания всех трех цветов, можете закрыть диалог с помощью кнопки ОК. Цветовые оттенки в рисунке будут изменены. Следующий фильтр вызывается с помощью команды меню Effects/Adjust/Tone Curve (Эффекты/Коррекция/Кривая тона). На экране появится диалог настройки фильтра (Рис. 17.5). С помощью этого преобразования вы можете изменить цвета отдельных точек изображения. Щелкая мышью на графике, вы добавляете точки в кривую. Вы можете перетащить точки с помощью мыши в другое место. Прямая линия в графике под углом в сорок пять градусов описывает отсутствие изменений. Точки, расположенные вне этой прямой, изменят цвет частей рисунка. Попробуйте добавить точки, после чего посмотрите на результат. Работа с тональной кривой требует навыка. Проще воспользоваться другими инструментами цветокоррекции, встроенными в редактор CorelDRAW 10. Для автоматической настройки изображения иногда полезно воспользоваться авто эквалайзером. Выберите команду меню Effects/Adjust/Auto Equalize (Эффекты/Коррекция/Авто эквалайзер), и оттенки в рисунке изменятся. Иногда эта операция существенно улучшает не слишком качественный рисунок.

Рис. 17.5. Диалог настройки тональной кривой

Выбрав команду меню Effects/Adjust^Brightness-Contrast-Intensity (Эффекты/Коррекция/Яркость-Контрастность-Интенсивность), вы откроете диалог настройки (Рис. 17.6).

Рис. 17.6. Яркость, контрастность и интенсивность

При работе в этом диалоге у вас не возникнет никаких трудностей. С помощью ползунков настраивается яркость, контрастность и интенсивность изображения, кок это делается, например, при настройке телевизора. Стоить отметить, что при данном способе изменения изображения могут быть утеряны некоторые полутона, поэтому желательно пользоваться иными фильтрами, например Contrast Enhancement (Расширенная контрастность), рассмотренным выше. Удобно для изменения контрастности и яркости также воспользоваться гамма - коррекцией. Выберите команду меню Effects/Adjust/Gamma (Эффекты/Коррекция/Гамма). На экране появится одноименный диалог (Рис. 17.7).

Рис. 17.7. Настройка фильтра гамма - коррекции

Гамма - коррекция позволяет настроить средние цвета изображения, не затрагивая при этом светлые участки и тени. С помощью ползунка вы можете осветлить или затемнить изображение. Гамма коррекция также доступна в фильтре Contrast Enhancement (Расширенная контрастность). Для настройки цветового баланса выберите команду меню Effects/Adjust/Color Balance (Эффекты/Коррекция/Баланс цвета). На экране появится одноименный диалог (Рис. 17.8). Флажки в левой части диалога позволяют выбрать то, к чему . будет применяться изменения цвета: Shadows (Тени), Midtones (Средние тона). Highlights (Светлые участки). Preserve Luminance (Сохранить светлые области). Устанавливая те или иные флажки, вы можете изменить оттенки теней или светлых участков. С другой стороны, можно изменить только цвета средних тонов, оставив тени и блики неизменными. Ползунки в правой части позволяют изменять попарно цвета: Cyan (Голубой) или Red (Красный), Magenta (Пурпурный) или Green (Зеленый), Yellow (Желтый) или Blue (Синий). С помощью этого диалога вы легко сможете изменить оттенки рисунка, например, улучшить фотографию с ошибочной передачей цветов.

Рuc. 17.8. Настройка цветового баланса

Выбрав команду меню Effects/Adjust/Hue/Saturation/Lightness (Эффекты/Коррекция/Цвет/Насыщенность/ Яркость), вы откроете другой диалог настройки цвета (Рис. 17.9).

Рис. 17.9. Другой вариант настройки цветов

В этом диалоге используются каналы и цветовая модель HSL, то есть имеется возможность изменять цветовой тон, насыщенность и яркость, как всего рисунка, так и каждого из составляющих рисунок основных цветов. Хотя использование данного фильтра Достаточно сложно, с его помощью можно получить Превосходные результаты. Особенно полезным этот фильтр оказывается при необходимости незначительных изменений некоторых оттенков рисунка. Поменять отдельно различные составляющие цвета вы можете в следующем рассматриваемом диалоге. Выберите команду меню Effects/Adjust/Selective Color (Эффекты/Коррекция/ Выбранный Цвет) и на экране появится одноименный диалог (Рис. 17.10).

Рис. 17.10. Изменение цветов

Устанавливая переключатель в нижней части диалога, вы можете изменить цветовой спектр с помощью ползунков, расположенных сверху. Выбрав определенные цвета, вы исправляете именно их, не меняя остальной цветовой спектр. Как вы видите, в данном фильтре используется цветовая модель CMYK, и вы можете изменить оттенки, добавляя или уменьшая значения отдельных составляющих. Работа с данным фильтром очень похожа на работу с помощью предыдущего фильтра. Основным отличием является использование модели CMYK вместо цветовой модели HSL. Часто возникает необходимость изменения одного цвета в рисунке. При этом остальные цвета должны остаться неизменными. Выберите команду меню Effects/Adjust/Replace Colors (Эффекты/Коррекция/Замена Цветов) и на экране появится диалог замены цвета (Рис. 17.11).

Рис. 17.11. Замена цвета

В поле Old Color (Старый цвет) выбирается оттенок, который вы хотите заменить. Вы можете нажать расположенную рядом кнопку и щелкнуть на нужном цвете в рисунке. Справа в диалоге показана цветовая маска. Все участки в рисунке, где имеется данный цвет, в маске светлые. Остальные участки темные. В поле New Color (Новый цвет) выбирается цвет, который вы хотите использовать при замене. Можно настроить этот цвет с помощью ползунков, описывающих оттенок в цветовой модели HSL. Меняя значение в поле Range (Диапазон), вы можете выбрать диапазон изменения оттенка при создании маски. Например, выбрав минимальный диапазон, вы замените единственный оттенок цвета. При выборе большого диапазона будут изменены множество похожих оттенков одного цвета. Если вы хотите убрать все цвета из рисунка, превратив его в черно-белый, то выберите команду меню Effects/Adjust/Desaturate (Эффекты/Коррекция/Очернитъ). При этом рисунок все равно останется цветным, но все цвета будут преобразованы к оттенкам серого. Вы как бы убрали Цветность в цветном телевизоре, но от этого телевизор не стал черно-белым. При дальнейшем редактировании такого рисунка, например в случае применения художественных эффектов, возможно появления любых цветов. Коррекция цвета растровых изображений достаточно сложна и требует определенного навыка. Лучше начинать с простых фильтров, постепенно переходя к более сложным. Освоив возможности изменения цвета в CorelDRAW, вы сможете создавать сложные иллюстрации, содержащие множество векторных и растровых объектов, оформленные в едином цветовом стиле.


17.2. Трансформация растровых объектов

Несколько команд, объединенных в одну группу, позволяют выполнить полезные преобразования растровых объектов. В CorelDRAW 10 вы можете превратить рисунок в негатив, выполнить постеризацию и улучшить качество чрезстрочного изображения. Для превращения любого растрового рисунка в негатив следует выбрать команду меню Effects/Transform/Invert (Эффекты/Преобразование/Инвертировать). Все цвета в изображении заменятся на противоположные. Повторное выполнение команды вернет исходные цвета изображения. Выбрав команду меню Effects/Transform/Posterize (Эффекты/Преобразование/Постеризировать), вы вызовите диалог настройки постеризации (Рис. 17.12).

Рис. 17.12. Диалог настройки постеризации

Это преобразование закрашивает большие участки рисунка однородными цветами, удаляя все схожие оттенки. С помощью ползунка Level (Уровень) выбирается степень применения преобразования. Чем меньше уровень, тем меньше цветов останется в рисунке, и тем больше он будет изменен. Минимальные значения уровня слишком сильно искажают рисунок и редко применяются. Выбрав команду меню Effects/Transform/Deinterlace (Эффекты/Преобразование/убрать чрезстрочность), вы вызовете диалог удаления горизонтальных линий (Рис. 17.13).

Рис. 17.13. Диалог -удаления горизонтальных линий

При сканировании изображений и захвате отдельных кадров из видеофильмов бывает, что в рисунке присутствует только четные или нечетные строки. Остальные строки не содержат полезной информации. Чтобы заменить ненужные строки, следует использовать предлагаемый фильтр. Установив переключатель в левой части диалога, вы можете выбрать четные или нечетные строки. В правом переключателе следует выбрать Duplication (Дублирование), если вы хотите продублировать соседние строки, и Interpolation , (Интерполяция), если вы хотите, чтобы CorelDRAW 10 попытался восстановить утраченные строки.


18. Художественные эффекты растровой графики

В CorelDRAW 10 вы можете применить к растровому объекту оригинальный художественный эффект, получая эффектную и качественную иллюстрацию с минимальными затратами. Всего доступно около сотни эффектов, и выбор того или иного эффекта зависит только от вашей фантазии. Некоторые эффекты сильно изменяют исходные рисунки, а результат от применения других почти не заметен. Большинство эффектов лучше смотрятся при использовании многоцветных рисунков. Низкокачественные растровые изображения не позволят получить требуемого результата от художественного эффекта.

18.1. Трехмерные преобразования

При работе с растровой графикой вы можете использовать эффекты, дающие иллюзию объема. Выберите команду меню Bitmaps/3D Effects (Растровые изображения/Трехмерные эффекты). Во вложенном меню содержится несколько эффектов, которые выполняют трехмерные преобразования изображений. В качестве примера мы взяли фотографию скворечника (Рис. 18.1, слева), и применили к ней разнообразные эффекты. Все дальнейшие примеры также будут выполнены с использованием этой фотографии.

Рис. 18.1. Исходный и преобразованный рисунки

Эффект трехмерного вращения (Рис. 18.1, второй слева) вызывается командой меню 3D Rotate (трехмерный поворот). После выбора команды на экране появится диалог настройки поворота (Рис. 18.2). Общие принципы работы с диалогами эффектов не отличаются от аналогичной работы при коррекции цвета, рассмотренной выше, поэтому не будем на них останавливаться. Вы можете повернуть рисунок, перетащив с помощью мыши эскиз, или введя значения в поля диалога. Можно выполнить поворот по горизонтали, по вертикали или по обоим направлениям. Команда меню Cylinder (Цилиндр) имитирует помещение рисунка на цилиндрическую поверхность (Рис. 18.1, второй справа). В диалоге (Рис. 18.3) вы можете установить переключатель в положение Horizontal (Горизонтально) или Vertical (Вертикально), чтобы выбрать направление оси цилиндра.

Рис. 18.2. Трехмерное вращение

С помощью ползунка определяется диаметр воображаемого цилиндра, то есть степень искривления рисунка. Отрицательные величины описывают вогнутый цилиндр, а положительные - выпуклый. В результате преобразования сильно сжимаются или растягиваются области в центре рисунка/ а края остаются почти без изменений.

Рис. 18.3. Цилиндрическое искажение

Рельефное однотонное изображение (Рис. 18.1, справа) получается с помощью эффекта Emboss (Чеканка). В диалоге настройки эффекта (Рис. 18.4) вы можете установить толщину полученных контуров с помощью ползунка Dept (Толщина) и глубину выдавливания с помощью ползунка Level (Уровень). Ниже задается угол падения лучей света, создающих эффект объема. В правой части диалога можно выбрать цвет чеканки.

Рис. 18.4. Эффект чеканки

Оригинальный эффект, имитирующий загнувшийся лист бумаги (Рис. 18.6, слева), получается при выборе команды меню Page Curl (Загиб листа). В появившемся диалоге (Рис. 18.5) вы можете выбрать край листа, который должен быть загнут, нажав соответствующую кнопку в левой части диалога. Переключатель Direction (Направление) предназначен для выбора горизонтального или вертикального загиба. Установив переключатель Paper (Бумага) в положение Transparent (Прозрачная) вы можете создать полупрозрачный загиб. Положение переключателя Opaque (Непрозрачный) позволяет создавать непрозрачный загиб. Чаще прозрачный загиб листа выглядит значительно красивее. Цвет загиба и подложки устанавливается в правой части диалога. С помощью ползунков можно выбрать размер загиба по горизонтали и по вертикали.

Рис. 18.5. Загиб листа

При выборе команды меню Perspective (Перспектива) вы создадите рисунок, уходящий в перспективу (Рис. 18.6, второй| слева).

Рис. 18.6. Другие трехмерные эффекты.

В появившемся диалоге (Рис. 18.7) вы должны перетащить углы рамки в эскизе, чтобы создать эффект перспективы. Противоположные стороны рамки связаны друг с другом. Меняя одну сторону, вы автоматически переместите и противоположную. Можно создать эффект перспективы по горизонтали или по вертикали. Если вы установите в переключателе значение Shear (Сдвиг), то сможете параллельно поворачивать стороны рамки образца. Это операция похожа не перекос векторного объекта.

Рис. 18.7. Перспектива

Выпуклые и вогнутые изображения (Рис. 18.6, второй справа) получаются с помощью команды Pinch/Punch Возвышение/Удар).В соответствующем диалоге (Рис. 18.8) с помощью ползунка настраивается степень искажений. В поле, расположенном в правой части диалога, схематически показывается степень и направление искажений. Результат применения эффекта похож на деформацию жестяного листа после сильного удара круглым предметом.

Рис. 18.8. Выпуклые и вогнутые рисунки

Похожий эффект (Рис. 18.6, справа) достигается с помощью команды Sphere (Сфера). В диалоге настройки сферического искривления (Рис. 18.9) вы также можете задать степень искривления с помощью ползунка. Кроме того, установив переключатель Optimize (Оптимизировать) в положение Quality (Качество), вы получите высококачественное изображение, но преобразование будет выполняться достаточно долго. Установив переключатель в положение Speed (Скорость), вы ускорите преобразование, немного потеряв в качестве.

Рис. 18.9. Сферическое искривление

Объемные эффекты позволяют создавать оригинальные иллюстрации из простых рисунков. Особенно часто используется эффекты загиба листа и трехмерного вращения. Иногда последовательно применяются несколько эффектов.


18.2. Имитация живописи

С помощью CorelDRAW 10 вы можете превратить любой рисунок в живописное произведение. Например, взяв фотографию и применив к ней эффект имитации импрессионизма, вы получите портрет, похожий на работу великого мастера. Редактор может имитировать самые разные техники живописи, предоставляя вам возможность настраивать некоторые особенности эффектов. Выберите команду меню Bitmaps/Art Strokes (Растровые изображения/Художественные штрихи), и в открывшемся вспомогательном меню вы увидите команды эффектов имитации живописи. Рассмотрим особенности применения этих эффектов, взяв в качестве примера все ту же фотографию скворечника (Рис. 18.10, слева).

Рис. 18.10. Различные материалы для рисования

Для получения из рисунка черно-белого наброска, выполненного углем (Рис. 18.10, слева), выберите команду Charcoal (Древесный уголь). В появившемся диалоге настройки эффекта (Рис. 18.11) вы можете настроить толщину уголька, перемещая ползунок Size (Размер). Ползунком Edge (Край) настраивается толщина краев рисунка, то есть места резких изменений цвета.

Рис. 18.11. Рисование углем

Выбрав команду Conte Crayon (Специальные мелки), вы сможете получить рисунок мелками (Рис. 18.10, второй слева). После выбора команды на экране появится диалог настройки эффекта (Рис. 18.12). Если вы не установите флажки рядом с образцами цветов в верхней части диалога, при создании рисунка будут использоваться оригинальные цвета изображения. Установив флажки, вы можете использовать от одного до пяти цветных мелков. Цвет холста устанавливается в поле, расположенном в правой части диалога. Ползунок Pressure (Давление) определяет степень нажатия мелков на холст. При большем нажатии получаются более контрастные рисунки. Ползунок Texture (Текстура) позволяет установить степень проявления текстуры поверхности. Сильно текстурированная поверхность может отвлекать от основного рисунка, поэтому не рекомендуется злоупотреблять этой возможностью.

Рис. 18.12. Мелки

Другой вариант рисунка с помощью мелков (Рис. 18.10, второй справа) можно получить, выбрав команду меню Crayon (Мелок). В связанном с эффектом диалоге (Рис. 18.13) настраивается размер мелка с помощью ползунка Size (Размер). Кроме того, можно установить с помощью ползунка Outline (Контур) толщину линий контура. Картины, полученные с помощью этого эффекта, выглядят значительно проще, чем при использовании предыдущего художественного эффекта.

Рис. 18.13. Другие мелки

Получить картину в стиле кубизма (Рис. 18.10, справа) можно с помощью команды Cubist (Кубизм). В диалоге настройке эффекта (Рис. 18.14) устанавливается размер мазков с помощью ползунка Size (Размер) и яркость картины с помощью ползунка Brightness (Яркость). В поле Paper Color (Цвет бумаги) выбирается цвет бумаги, на котором рисуется иллюстрация.

Рис. 18.14. Кубизм

Другой известный художественный стиль - импрессионизм, тоже доступен в CorelDRAW 10. Многие великие художники создавали свои работы в этом стиле. Скворечник в стиле импрессионизма выглядит очень оригинально (Рис. 18.15, слева).

Рис. 18.15. Имитация техники живописи

Для получения эффекта следует выбрать команд Impressionism (Импрессионизм). В диалоге выбирается стиль мазков. В переключателе Style (Стиль) нужно выбрать стиль Strokes (Штрихи) или Dabs (Пятно). Различные стили помогут создать совершенно разные рисунки. С помощью верхнего ползунка выбирается размер мазков, ползунок Coloration (Окраска) задает степень разброса цветов, а с помощью ползунка Brightness (Яркость) устанавливается яркость полученного рисунка.

Рис. 18.16. Импрессионизм

Оригинальный эффект (Рис. 18.15, второй слева) вызывается командой Palette Knife (Нож палитры). В диалоге настройки эффекта (Рис. 18.17) выбирается ширина мазков с помощью верхнего ползунка. В правой части диалога устанавливается направление мазков. Ползунок Soft Edge (Мягкие грани) позволяет смягчить края мазков.

Рис. 18.17. Нож палитры.

Пастельный рисунок (Рис. 18.15, второй справа) выполняется с помощью команды Pastels (Пастель). В диалоге (Рис. 18.18) установкой переключателя в положение Soft (Мягкий) или Oil (Масло) выбирается тип пастели. Ползунком Stroke Size (Размер штрихов) устанавливается размер штрихов в создаваемом рисунке, а с помощью ползунка Hue Variation (Изменение цвета) задается разнообразие цветов в рисунке. Пастельные рисунки могут быть очень красивы.

Рис. 18.18. Пастель

Черно-белый рисунок, выполненный с помощью перьевой ручки (Рис. 18.15, справа), получается с помощью команды Реп & Ink (Ручка и чернила). На экране появится диалог настройки эффекта (Рис. 18.19). Переключателем в правой части диалога выбирается стиль рисунка. Варианты Crosshatch (Штриховка) и Stippling (Пунктир) задают разный вид штрихов, и в результате мы получаем совершенно непохожие друг на друга рисунки. Ползунком Density (Плотность) задается плотность чернил. Ползунком Ink Pool (Пул чернил) задается количество используемых чернил.

Рис. 18.19. Ручка и чернила

Еще одним известным стилем живописи является рисование разноцветными круглыми мазками. Для создания рисунка в этом стиле (Рис. 18.21, слева) следует выбрать команду Pointillist (Поинтилизм). В диалоге настройки эффекта (Рис. 18.20) можно настроить размер мазков ползунком Size (Размер) и их яркость с помощью ползунка Brightness (Яркость). В отличие от некоторых других эффектов, цвета в исходном рисунке не меняются.

Рис. 18.20. Эффект рисования кружками

Очень интересный эффект (Рис. 18.21, в центре) вызывается командой Scraperboard (Резьба по дереву).

Рис. 18.21. Другая популярная техника

Диалог настройки эффекта (Рис. 18.22) позволяет выбрать вариант рисунка с помощью переключателя, расположенного в левой части диалога. Вырезанные части всегда черные, а фон может остаться цветным, если переключатель установлен в положение Color (Цветной), или превратится в белый, если переключатель установлен в положение White (Белый). Ползунком Density (Плотность) задается плотность, а ползунком Size (Размер) - размер вырезанных линий.

Рис. 18.22. Резьба по дереву

Другой эффект (Рис. 18.21, справа) можно получить, выбрав команду Sketch Pad (Доска наброска). В диалоге настройки (Рис. 18.23) вы можете существенно изменить внешний вид получаемого рисунка. Установив переключатель в положение Graphite (Графитовый), вы создадите черно-белый рисунок, а в положение Color (Цветной) - цветной. С помощью ползунка Style (Стиль) настраивается стиль выполняемых мазков. Ползунок Pressure (Давление) определяет степень нажатия на доску при рисовании. Кроме того, можно установить с помощью ползунка Outline (Контур) толщину линий контура.

Рис. 18.23. Доска наброска

Красивый акварельный рисунок (Рис. 18.24, слева) можно получить из любого растрового изображения с помощью команды Watercolor (Акварель).

Рис. 18.24. Использование водных красок

В диалоге настройки эффекта (Рис. 18.25) вы можете настроить пять параметров. Ползунок Brush Size (Размер кисти) задает размер мазков, а ползунком Granulation (Гранулирование) задается пятнистость рисунка. Ползунок Water Amount (Количество воды) определяет интенсивность цветов. С помощью ползунка Bleed (Расплывание) можно создать более размытое изображений. Ползунком Brightness (Яркость) регулируется яркость рисунка.

Рис. 18.25. Акварель

Оригинальный эффект (Рис. 18.24, в центре) достигается при выборе команды меню Water Marker (Водный маркер). В диалоге настройки эффекта (Рис. 18.26) вы можете выбрать один из трех вариантов эффекта. Варианты Default (По умолчанию). Order (Порядок) и Random (Случайно) описывают различное расположение мазков в рисунке. С помощью ползунка Size (Размер) устанавливается размер мазков. Ползунком Color Variation (Изменение цвета) задается степень разнообразия цвета в соседних мазках.

Рис. 18.26. Водный маркер

Не менее оригинален эффект (Рис. 18.24, справа), получаемый при выборе команды Wave Paper (Волнистая бумага). В диалоге настройки (Рис. 18.27) вы можете выбрать цветной рисунок, установив переключатель в положение Color (Цветной), или черно-белый, установив переключатель в положение Black & White (Черно-белый). Ползунок Brush Pressure (Давление кисти) определяет степень нажатия кисти на бумагу при рисовании. Чем сильнее кисть давит на бумагу, тем более интенсивные цвета получаются в рисунке. Однако при любых установках цвета окажутся бледнее, чем в оригинале.

Рис. 18.27. Волнистая бумага

Различные эффекты, имитирующие разную технику живописи, очень часто используются при оформительских работах. Особенно красиво эффекты смотрятся на больших цветных изображениях.


18.3. Использование размытых рисунков

При создании иллюстраций не всегда требуются четкие и ясные границы между разными частями. Иногда размытые изображения выглядят лучше, чем четкие. Иногда размытие используется для добавление динамичности в рисунок. В CorelDRAW 10 есть несколько вариантов создания размытых рисунков. Все команды для вызова разных эффектов размытия вызываются из меню, которое появляется после выбора команды Bitmaps/Blur (Растровые изображения/Размытие).

Рис. 18.28. Разные варианты размытия

Наиболее часто используется, так называемое, размытие по Гаусу (Рис. 18.28, слева). Этот фильтр размывает изображение немного выбивая его из фокуса, что используется при созданий эффекта свечения, тени и многих других. Им можно исправлять изображения, содержащие рубленые края. Достаточно часто применяется и эффект, имитирующий размытие от движения объекта (Рис. 18.28, второй слева). Для смягчения изображения без потери в полутонах применяют фильтр Directional Smooth (Направленное сглаживание). В диалоге настройки фильтра (Рис. 18.29) вы можете установить степень его применения с помощью ползунка Percentage (Процент). Этот фильтр анализирует значения пикселей похожих оттенков, чтобы определить направление максимального размытия. Некоторые рисунки почти не изменятся после применения фильтра, только несколько сгладятся отдельные переходы цветов.

Рис. 18.29. Направленное сглаживание

Распространенный эффект размытия по Гаусу (Рис. 18.28, слева) вызывается командой Gaussian Blur (Размытие по Гауссу). В диалоге настройки (Рис. 18.30) устанавливается степень размытия изображения с помощью ползунка Radius (Радиус).

Рис. 18.30. Размытие по Гауссу

Следующий фильтр дробит пятна, создавая мягкий, размытый эффект с небольшими искажениями. Выберите команду Jaggy Despeckle (Дробление пятен) и установите в диалоге настройки (Рис. 18.31) с помощью ползунков значения высоты и ширины области диффузии.

Рис. 18.31. Дробление пятен

Б отличие от остальных фильтров размытия, следующий эффект удаляет свет и цвет, оставляя тени и крупные детали. Выберите команду low Pass (Малый проход) для вызова диалога настройки эффекта (Рис. 18.32.). Ползунком Percentage (Процент) устанавливается интенсивность применения эффекта, а с помощью ползунка Radius (Радиус) задается диапазон пикселей, попадающих под действие фильтра.

Рис. 18.32. Малый проход

Для придания эффекта движения (Рис. 18.28, второй слева) вберите команду Motion Blur (Размытие движением). В диалоге настройки (Рис. 18.33.) устанавливается величина размытия ползунком Distance (Расстояние). С помощью элемента Direction (Направление) устанавливается направление движения.

Рис. 18.33. Размытие движением

Размыть рисунок, сдвинув по кругу пиксели (Рис. 18.28, второй справа), можно с помощью команды Radial Blur (Радиальное размытие). В диалоге настройки фильтра (Рис. 18.34.) задается величина размытия ползунком Amount (Количество).

Рис. 18.34. Радиальное размытие

Небольшое сглаживание выполняется при помощи команды Smooth (Сглаживание). В диалоге (Рис. 18.35.) с помощью ползунка Percentage (Процент) устанавливается степень сглаживания. Часто результат действия фильтра почти не заметен. Однако он может улучшить некоторые рисунки, удалив из них мелкие ненужные детали.

Рис. 18.35. Сглаживание

Фильтр, очень похожий на предыдущий, вызывается с помощью команды Soften (Смягчение). Аналогичный диалог (Рис. 18.36.) позволяет настроить степень размытия с помощью ползунка Percentage (Процент). Различие в результатах применения фильтров практически невозможно обнаружить.

Рис. 18.36. Смягчение

Размытие в направлении от центра (Рис. 18.28, справа) используется в фильтре, вызываемом командой Zoom (Масштаб). Диалог настройки фильтра (Рис. 18.37.) позволяет настроить степень искажений с помощью ползунка Amount (Количество).

Рис. 18.37. Масштаб

Различные виды размытия позволяют сглаживать картину, удаляя мелкие погрешности. Часто размытие используется для создания специальных эффектов. При этом не следует злоупотреблять этим эффектом, так как можно просто испортить иллюстрацию.


18.4. Художественное преобразование цвета

В CorelDRAW 10 есть множество средств коррекции цвета. Изменение цвета описывалось выше в этой книге. Кроме того, вы можете изменять цвета рисунка для получения художественных эффектов. Выберите команду меню Bitmaps/Color Transform (Растровые изображения/Преобразование цвета), чтобы открыть вспомогательное меню эффектов художественного преобразования цвета. С их помощью можно существенно изменить цвета рисунка.

Рис. 18.38. Художественное преобразование цвета

Эффект постеризации (Рис. 18.38, слева), то есть выделение областей рисунка и закрашивание их одним цветом выполняется командой Bit Planes (Слои бит). Вы можете выполнить преобразование для каждого из цветовых каналов. В диалоге настройки эффекта (Рис. 18.39) определяется чувствительность эффекта. Высокие установки задают меньше тоновых переходов. При минимальных значениях рисунок будет содержать цветовые помехи, так как мелкие изменения носят случайный характер. Установив флажок, вы одинаково меняете значения для всех каналов, а убрав его, можете настроить различную чувствительность для разных цветов.

Рис. 18.39. Слои бит

Полутоновые изображения (Рис. 18.38, второй слева) получаются с помощью команды Halftone (Полутона). Этот эффект превращает хороший рисунок в зернистое изображение. Иногда и такое может понадобиться.

Рис. 18.40. Полутона

В диалоге настройки (Рис. 18.40) вы определяете размеры полутоновых точек с помощью ползунка Мах dot radius (Максимальный радиус точки). Кроме того, остальные ползунки задают углы поворота точек для каждого цветового канала. Для замены цветов на яркие, кричащие тона используется следующий эффект (Рис. 18.38, второй справа), который вызывается командой Psychedelic (Психоделический). В диалоге (Рис. 18.41) задается уровень изменений цвета. Передозировка эффекта может вызвать неприятные ощущения, поэтому лучше устанавливать небольшие значения уровня.

Рис. 18.41. Психоделический

Для создания негативного изображения (Рис. 18.38, справа) используется команда Solarize (Солнечность). Однако работа этого эффекта сложнее, чем просто инвертирование цветов. Вы можете задать уровень инвертирования. Минимальное значение не приведет к изменениям, а максимальное - создаст негатив. Промежуточные значения превратят в негатив отдельные фрагменты рисунка. (Рис. 18.42)

Рис. 18.42. Солнечность

Команда Red Eye Removal (Устранить эффект красных глаз) позволяет удалить из фотографии эффект красных глаз. Хотя большинство современных фотоаппаратов уже не страдает от этой проблемы, иногда может понадобиться и этот эффект. Перед применением эффекта следует применить маску к рисунку. Об использовании цветовых масок было рассказано выше. В диалоге настройки эффекта вы выбираете заменяемый цвет. Художественная обработка цвета дополняет многочисленные возможности цветокоррекции. Умелое применение обеих возможностей CorelDRAW 10 поможет создать наилучшие иллюстрации.


18.5. Обработка контуров

Для выделения контуров, то есть резких границ между разными цветами в рисунке, используется несколько эффектов. Выберите команду меню Bitmaps/Contour (Растровые изображения/Контур), чтобы открыть меню контурных эффектов.

Рис. 18.44. Выделение контуров рисунков

Вы можете обвести карандашом все границы цветных областей в рисунке (Рис. 18.44, слева). В результате получается рисунок, состоящий из множества линий. Эффект вызывается командой Edge Detect (Определение границ). В диалоге настройки эффекта (Рис. 18.45) выбирается цвет фона. Кроме того, с помощью ползунка Sensitivity (Чувствительность) устанавливается степень применения фильтра к изображению.

Рис. 18.45. Определение границ

Очень похожий эффект (Рис. 18.44, в центре) вызывается командой Find Edges (Поиск границ). В диалоге настройки эффекта (Рис. 18.46) вы можете выбрать вариант работы фильтра. Положение переключателя Soft (Мягкий) позволяет создать более мягкие границы, а положение Solid (Твердый) более жесткие. С помощью ползунка Level (Уровень) задается степень применения фильтра.

Рис. 18.46. Поиск границ

Чтобы обвести края объектов в рисунке (Рис. 18.44, справа), следует воспользоваться командой Trace Contour (Трассировка контура). Естественно, эта трассировка не имеет ничего общего с преобразованием растровых объектов в векторные.

Рис. 18.47. Трассировка контура

В диалоге настройки эффекта (Рис. 18.47) с помощью ползунка Level (Уровень) задается степень применения эффекта. Если вы установите переключатель в диалоге в положение Lower (Ниже), края будут определяться изнутри. Положение Upper (Выше) задает определение краев снаружи. Четкий контур объектов достаточно трудно создать с помощью этих эффектов. Возможно, вам покажется удобным преобразовать растровый объект в векторный, после чего вручную выделить контур фрагмента рисунка и отредактировать его.


18.6. Оригинальные эффекты

Следующая группа эффектов используется очень часто, так как позволяет создавать оригинальные иллюстрации на основе простых рисунков. Разнообразные эффекты предоставляют прекрасные возможности для самовыражения. Выберите команду меню Bitmaps/Creative (Растровые изображения/ Творчество).

Рис. 18.48. Оригинальные эффекты.

Для разбиения рисунка на множество составных частей (Рис. 18.48, слева) следует воспользоваться командой Crafts (Ремесла). В появившемся диалоге (Рис. 18.49) вы можете выбрать в списке Style (Стиль) один из вариантов эффекта. Можно выбрать картонки, карамель, чипсы, керамическую плитку или иной материал для создания мозаики. В результате вы получите самые разные изображения. С помощью ползунка Size (Размер) задается размер элементов. Уменьшая значение Complete (Полнота), вы создадите незавершенную мозаику, часть элементов которой заменена черными пустотами. Ползунком Brightness (Яркость) задается яркость рисунка, а с помощью элемента Rotation (Вращение) можно повернуть элементы.

Рис. 18.49. Ремесла

Создать рисунок из кристаллов (Рис. 18.48, второй слева). Можно с помощью команды Crystalize (Кристаллизация). В диалоге настройки эффекта (Рис. 18.50) с помощью ползунка Size (Размер) вы можете установить нужный размер кристаллов.

Рис. 18.50. Кристаллизация

Вы можете легко имитировать рисунок, нанесенный на ткань (Рис. 18.48, второй справа). Эффект вызывается командой Fabric (Ткань). В диалоге настройки эффекта (Рис. 18.51) в списке Style (Стиль) выбирается конкретная ткань. В зависимости от выбранной ткани, вы можете получить разнообразные рисунки. Доступны шесть типов ткани, каждый из которых имеет свой уникальный вид. С помощью ползунка Size (Размер) устанавливается величина стежков, а ползунком Complete (Полнота) задается процент заполнения рисунка. В поле Brightness (Яркость) задается яркость, а с помощью Rotation (Вращение) элементы рисунка можно повернуть.

Рис. 18.51. Ткань

Создать красивую рамку для рисунка (Рис. 18.48, справа) можно с помощью команды Frame (Рамка). Примерно такого же эффекта можно добиться применением фигурной обрезки. Однако художественный эффект Frame (Рамка) предоставляет некоторые дополнительные возможности. В диалоге настройки эффекта на вкладке Select (Выбор) (Рис. 18.52) выбирается одна из установленных в системе рамок. Вы можете открыть созданный ранее графический файл, в котором сохранена рамка. Вместе с CorelDRAW 10 поставляется набор художественных рамок.

Рис. 18.52. Выбор рамки

Если вы хотите настроить использование рамки, перейдите на вкладку Modify (Изменить) диалога (Рис. 18.53). На этой вкладке вы можете изменить масштаб, цвет и прозрачность рамки, а также размыть ее края.

Рис. 18.53. Настройка рамки

Следует отметить, что многие эффекты очень похожи друг на друга. Большинство эффектов разбивают изображение на мелкие элементы, преобразуют эти элементы и составляют новое изображение. Все эти эффекты можно, с определенной долей условности, назвать мозаиками. Различие состоит только в методе преобразования элементов.

Рис. 18.54. Другие оригинальные эффекты

Чтобы увидеть рисунок через стеклянные блоки (Рис. 18.54, слева), выберите команду Glass Block (Стеклянный блок). В диалоге настройки эффекта (Рис. 18.55) устанавливается размеры блоков.

Рис. 18.55. Стеклянный блок

Превратить иллюстрацию в детский рисунок (Рис. 18.54, второй слева) можно с помощью команды Kids Play (Детский рисунок). В диалоге настройки эффекта (Рис. 18.56) в списке Game (Игра) выбирается тип составляющих элементов. Доступны самые разные типы, сильно отличающиеся друг от друга. С помощью ползунка Size (Размер) устанавливается размер элементов, в поле Complete (Полнота) задается процент заполнения рисунка. В поле Brightness (Яркость) задается яркость, а с помощью Rotation (Вращение) элементы рисунка можно повернуть.

Рис. 18.56. Детский рисунок

Классическую мозаику также можно создать с помощью CorelDRAW 10 (Рис. 18.54, второй справа). Эффект вызывается командой Mosaic (Мозаика). В диалоге настройки эффекта (Рис. 18.57) с помощью ползунка Size (Размер) задается размер элементов мозаики. Кроме того, вы можете задать цвет фона, просвечивающего между камешками мозаики.

Рис. 18.57. Мозаика

Добавить к рисунку случайные элементы (Рис. 18.54, справа) можно с помощью команды Particles (Частицы). В диалоге настройки эффекта (Рис. 18.58) с помощью ползунка Size (Размер) задается размер частиц, а с помощью ползунка Density (Плотность) - их количество. Ползунком Coloration (Окраска) задается разброс цветов, а с помощью ползунка Transparency (Прозрачность) устанавливается прозрачность частиц. Переключатель Style (Стиль) можно установить в положение Bubbles (Пузырьки) или Stars (Звезды), чтобы добавить выбранный вид частиц. В поле Angle (Угол) задается угол наклона частиц.

Рис. 18.58. Частицы

Следующий эффект похож на размытие (Рис. 18.59, слева), но все же несколько отличается от него. Точки случайным образом рассеиваются в разные стороны от исходной точки. При этом не происходит сглаживание, как при использовании размытия. Рисунок становится нечетким, но иначе, чем при размытии.

Рис. 18.59. Еще несколько эффектов

Эффект вызывается командой Scatter (Рассеиватель). В диалоге настройки эффекта (Рис. 18.60) задаются размеры области рассеивания. Можно установить одинаковые значения по горизонтали и вертикали, а можно и разные.

Рис. 18.60. Рассеиватель

Чтобы увидеть рисунок через дымчатое стекло (Рис. 18.59, в центре), следует выбрать команду Smoked Glass (Дымчатое стекло).

Рис. 18.61. Дымчатое стекло

В диалоге настройки эффекта (Рис. 18.61) вы можете выбрать цвет стекла. С помощью ползунка Tint (Оттенок) задается прозрачность стекла, а ползунком Blurring (Размывание) устанавливается степень размытия рисунков. Чтобы получить рисунок, похожий на стеклянные витражи (Рис. 18.59, справа), нужно выбрать команду Stained Glass (Цветное стекло). В диалоге настройки эффекта (Рис. 18.62) с помощью ползунка Size (Размер) задается размер элементов витража, а ползунком Light Intensity (Интенсивность света) устанавливается яркость. С помощью Solder Width (Ширина спайки) задается ширина полосы между стеклянными элементами, а с помощью Solder Color (Цвет спайки) - их цвет. Установив флажок 3D Lighting (Трехмерное освещение), вы придадите работе более интересный вид.

Рис. 18.62. Цветное стекло

И напоследок рассмотрим еще несколько очень красивых художественных эффектов.

Рис. 18.63. Несколько других эффектов

Виньетку для фотографии (Рис. 18.63, слева) можно сделать командой Vignette (Виньетка). В диалоге настройки эффекта (Рис. 18.64) выбирается цвет полей в группе полей Color (Цвет) и форма виньетки в группе полей Shape (Форма). Ползунком Offset (Смещение) выбирается расположение полей, а ползунком Fade (Переход) устанавливается плавный переход от рисунка к закрашенному полю. Если вам не требуется плавный переход, то аналогичный результат можно получить, разместив над растровым рисунком векторный объект с отверстием нужной формы и размера.

Рис. 18.64. Виньетка

Рисунок из множества завитков (Рис. 18.63, в центре) получается при использовании команды Vortex (Завихрения). В диалоге настройки эффекта (Рис. 18.65) выбирается стиль завихрений с помощью списка Style (Стиль). Различные стили сильно отличаются друг от друга. Ползунком Size (Размер) задается размер отдельных завитков. Элементы Inner Directional (Внутреннее направление) и Outer Directional (Внешнее направление) позволяют задать направления для создаваемых элементов.

Рис. 18.65. Завихрения

Чтобы добавить погодные особенности (Рис. 18.63, справа) к рисунку, следует вызвать команду Weather (Погода). В диалоге настройки эффекта (Рис. 18.66) вы можете выбрать один из вариантов: Snow (Снег), Rain (Дождь) или Fog (Туман). Ползунком Strength (Сила) задается интенсивность непогоды, а с помощью ползунка Size (Размер) задается размер снежинок или капель. Нажимая кнопку Randomize (Рандомизировать), вы меняете случайные места, где будут расположены добавляемые объекты.

Рис. 18.66. Погода

Так как во многих описанных эффектах есть несколько различных вариантов, для творчества вам предоставляется несколько десятков замечательных эффектов, с помощью которых вы можете создать самые разные творения.


18.7. Искажения рисунков

При обработке рисунков иногда возникает необходимость в сложных преобразованиях, искажающих исходное изображение и создающих новую уникальную иллюстрацию. Хотя некоторые другие эффекты тоже искажают рисунок, несколько эффектов выделены в отдельную группу. Для выполнения искажений следует выбрать команду меню Bitmaps/Distort (Растровые изображения/Исказить), после чего выбрать нужный эффект в появившемся меню. Разбить рисунок на множество блоков (Рис. 18.67, слева) можно с помощью команды Blocks (Блоки).

Рис. 18.67. Трансформации изображений

В диалоге настройки эффекта (Рис. 18.68) вы можете выбрать цвет контура добавляемых элементов и их размеры. Ползунком Мах offset (Максимальное смещение) задается смещение блоков, то есть степень применения эффекта.

Рис. 18.69. Замещение

Сместить начало рисунка (Рис. 18.67, второй справа) можно командой Offset (Смещение). В диалоге настройки эффекта (Рис. 18.70) вы задаете вертикальное и горизонтальное смещение. Освободившаяся область будет закрашена выбранным цветом.

Рис. 18.68. Блоки

Очень красивый эффект частичного добавления заданной текстуры (Рис. 18.67, второй слева) вызывается командой Displace (Замещение). В диалоге настройки эффекта (Рис. 18.69) вы можете выбрать рисунок, на основе которого в заданном изображении будет создана текстурная поверхность. В качестве текстур могут использоваться изображения, поставляемые в составе CorelDRAW 10, или любые другие рисунки. Также вы можете задать размер элементов текстуры и их повторяемость. В списке Undefined Areas (Неопределенные области) выбирается область рисунка, где текстура не будет видна. Текстура проявляется по краям объектов в изображении.

Рис. 18.70. Смещение

Зрительно увеличить пиксели в изображении (Рис. 18.67, справа) можно командой Pixelate (Пикселизация). В диалоге настройки эффекта (Рис. 18.71) с помощью переключателя Pixelate Mode (Режим пикселизации) выбираются квадратные, прямоугольные или круглые пиксели. Ползунками Width (Ширина) и Height (Высота) задаются размеры пикселей, а с помощью ползунка Opacity (Непрозрачность) - степень их проявления. Вы можете создать копию рисунка, выполнить фигурную обрезку и преобразовать результат снова в растровый объект. После этого, применив пикселизацию к полученному рисунку, поместить его поверх оригинала. Так можно скрыть некоторые детали рисунка. Хотя, конечно, проще это сделать с помощью редактора растровой графики.

Рис. 18.71. Пикселизация

Следующие два эффекта позволяют сильно исказить рисунок. Такие преобразования могут занять достаточно много времени, особенно на маломощном компьютере.

Рис. 18.72. Сложные искажения рисунков

Чтобы создать иллюзию ряби, идущей по поверхности рисунка (Рис. 18.72, слева) следует вызвать команду Ripple (Рябь). В диалоге настройки эффекта (Рис. 18.73) настраиваются параметры волн, создающих рябь. Ползунком Period (Период) устанавливается частота волн, а ползунком Amplitude (Амплитуда) - их величина. Если установить флажок Perpendicular Wave (Перпендикулярная волна) рябь усложнится, и вы сможете задать амплитуду перпендикулярной волны. Кроме того, установив переключатель Optimize (Оптимизировать) в положение Quality (Качество), вы получите высококачественное изображение, но преобразование будет выполняться достаточно долго. Установив переключатель в положение Speed (Скорость), вы ускорите преобразование, немного потеряв в качестве. Флажок Distort ripple (Исказить рябь) позволяет внести дополнительные искажения, а расположенный рядом элемент Angle (Угол) повернуть рябь. После приобретения определенного навыка вы сможете создавать достаточно правдоподобную рябь на рисунках.

Рис. 18.73. Рябъ

Имитировать водоворот, в который затягивается рисунок (Рис. 18.72, в центре), можно с помощью команды Swirl (Завихрение). В диалоге настройки эффекта (Рис. 18.74) переключателем Direction (Направление) задается направление завихрения - по часовой стрелке или против часовой стрелки. Переключателем Optimize (Оптимизировать) задается оптимизация по качеству или скорости. Ползунок Whole Rotation (Целых оборотов) задает количество полных оборотов завихрения, а ползунком Additional Degrees (Дополнительные градусы) устанавливается дополнительный угол поворота. Дополнительный поворот добавляется к нескольким полным поворотам.

Рис. 18.74. Завихрение

Эффект уменьшения и размножения рисунка (Рис. 18.72, справа) вызывается командой Tile (Черепица). В диалоге настройки эффекта (Рис. 18.75) задается количество уменьшенных изображений по горизонтали и вертикали. Ползунком Overlap (Перекрытие) устанавливается процент перекрытия соседних изображений.

Рис. 18.75. Черепица

Следующие эффекты не вносят таких сильных искажений, как рассмотренные ранее, но создают очень симпатичные рисунки. Иллюзию потекшей от воды краски (Рис. 18.77, слева) можно создать при использовании команды Wet Paint (Жидкая краска). В диалоге настройки эффекта (Рис. 18.76) с помощью ползунка Wetness (Влажность) задается влажность красок, а ползунком Percent (Процент) устанавливается процент участков, на которых краска потекла.

Рис. 18.76. Жидкая краска

Оригинальный эффект, добавляющий множество мелких завитков (Рис. 18.77, в центре) вызывается командой Whirlpool (Водоворот).

Рис. 18.77. Незначительные искажения

В диалоге настройки эффекта (Рис. 18.78) с помощью ползунка Spacing (Пробелы) задаются расстояния между водоворотами.

Рис. 18.78. Водоворот

Если установлен флажок Warp (Деформация), рисунок дополнительно деформируется водоворотами. При убранном флажке деформация отсутствует. Ползунком Smear Length (Длина мазков) задает степень размытия рисунка, а с помощью ползунка Streak Detail (Полоса деталей) можно восстановить размытые детали. Ползунок Twist (Завихрение) определяет направление потока в водоворотах. С помощью списка Style (Стиль) можно выбрать одну из готовых настроек эффекта. Эффект сильного ветра (Рис. 18.77, справа) вызывается командой Wind (Ветер). В диалоге настройки эффекта (Рис. 18.79) с помощью ползунка Strength (Сила) устанавливается сила ветра. С помощью ползунка Opacity (Непрозрачность) задается степень проявления эффекта.

Рис. 18.79. Ветер

Искажения помогают имитировать различные природные эффекты. Особенно интересных результатов можно добиться при комбинировании этих эффектов с оригинальными художественными эффектами. Например, сначала создать имитацию рисунка на ткани, после чего с помощью ряби превратить тряпку в развевающееся полотнище. Немного пофантазировав, вы сможете придумать более интересные комбинации эффектов.


18.8. Добавление и удаление шумов

Шум, то есть небольшие пятна произвольного цвета, не всегда является недостатком. В некоторых случаях художники специально добавляют шум в изображение. Для перехода в меню работы с шумом выберите команду меню Bitmaps/Noise (Растровые изображения/Шум). Для добавления в рисунок цветного шума (Рис. 18.80, слева) выберите команду Add Noise (Добавить шум),

Рис. 18.80. Добавление шумов

В диалоге настройки эффекта (Рис. 18.81) переключателем Nois type (тип шума) задается один из алгоритмов добавления шуме В группе полей Color mode (Цветовой режим) выбираете изменение интенсивности цвета/ случайный цвет или задаете определенный цвет. Ползунком Level (Уровень) задаете уровень шума, то есть степень изменения точек в рисунке, ползунком Density (Плотность) задается количество измененны точек.

Рис. 18.81. Добавить шум

Убрать некоторые помехи можно с помощью команды Diffuse (Диффузия). В диалоге настройки эффекта (Рис. 18.82 единственным ползунком устанавливается степень применение фильтра. Результат работы диффузии похож на размытие изображения. Некоторые помехи можно удалить командой Dust and Scratcl (Пылинки и царапины). Чаще всего этот эффект применяется при обработке старых фотографий, которые испортились при неправильном хранении.

Рис. 18.82. Диффузия

В диалоге настройки эффекта (Рис. 18.83) ползунком Threshold (Порог) задается порог чувствительности фильтра,а с помощью ползунка Radius (Радиус) устанавливается количество пикселей вокруг помехи/ которые будут изменены.

Рис. 18.83. Пылинки и царапины

Для осветления изображения путем удаления темных цветов (Рис. 18.80, второй слева) используется команда Maximum (Максимум). В диалоге настройки (Рис. 18.84) ползунком Percentage (Процент) задается степень осветления. С помощью ползунка Radius (Радиус) устанавливается размеры области изменений.

Рис. 18.84. Максимум

Похоже работает следующий эффект, но он не осветляет рисунок, а усредняет цвета в нем (Рис. 18.80, второй справа). Эффект вызывается командой Median (Медиана). В диалоге настройки эффекта (Рис. 18.85) можно задать размеры области применения.

Рис. 18.85. Медиана

Аналогично двум предыдущим эффектам, можно затемнить рисунок (Рис. 18.80, справа) с помощью команды Minimum (Минимум). В диалоге настройки эффекта (Рис. 18.86) задаются те же параметры, что и при осветлении.

Рис. 18.86. Минимум

При сканировании изображений иногда возникает муар. Для его удаления можно воспользоваться командой Remove Moire (Удалить муар). В диалоге настройки эффекта (Рис. 18.87) задается точность преобразования.

Рис. 18.87. удалить муар

Также вы можете удалить шумы в рисунке с помощью команды Remove Noise (Удалить шум). В диалоге настройки эффекта (Рис. 18.88) рекомендуется установить флажок Auto (Автоматически), чтобы CorelDRAW 10 самостоятельно убрал шум. Если убрать флажок, то можно вручную настроить чувствительность фильтра с помощью ползунка, расположенного в диалоге.

Рис. 18.88. Удалить шум

Работа с шумами требует определенного навыка. Часто вы можете не заметить результата удаления шумов, так как в исходном рисунке шумы отсутствуют.


HTMLHelp File

Web2HTMLHelp 1.0
Русификация программ
[ Back ]